Issue 127770 - Save As ... DocBook is not available in W7 or W10 but is available in Linux and XP
Summary: Save As ... DocBook is not available in W7 or W10 but is available in Linux a...
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.1.5
Hardware: All Windows, all
: P5 (lowest) Normal (vote)
Target Milestone: 4.1.6
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 17:09 UTC by John
Modified: 2018-09-01 10:21 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: Easy


Attachments
Format options under Save As.gif shows available formats under Save As ... (12.35 KB, image/gif)
2018-05-03 17:09 UTC, John
no flags Details
XML Filter Settings.gif shows Tools > XML Filter Settings (18.79 KB, image/gif)
2018-05-03 17:11 UTC, John
no flags Details
AOO 4.1.5 Custom Setup (26.91 KB, image/png)
2018-05-03 17:37 UTC, Matthias Seidel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description John 2018-05-03 17:09:04 UTC
Created attachment 86415 [details]
Format options under Save As.gif shows available formats under Save As ...

1.  Install AOO 4.1.5 on Windows 7 as a new, vanilla install.
2.  File > Save As.
3.  Click arrow on Save as type ..., so save format options are shown.

Expected result:  DocBook will be available as an option

Actual result:  DocBook is not present - see uploaded image Format options under Save As.gif

Diagnosis using Windows 7 system:  

1.  See forum post Beginning with OO, how to save as docbook at https://forum.openoffice.org/en/forum/viewtopic.php?f=5&t=93448&p=444377#p444377

2.  docbook is available in 4.1.5 under Linux and under Windows XP.

3.  docbook is not available under W7 or W10.

4.  Judging from XP, I would expect the folder C:\Program Files (x86)\OpenOffice 4\share\xslt\ to contain a folder \docbook which has the required files.  There is no such folder.

5.  openoffice1.cab in the AOO 4.1.5 installation files has sofftodocbookheadings.xsl, docbooktosoffheadings.xsl and DocBookTemplate.stw which are present in the XP installation. 

6.  Tools > XML Filter Settings ..., does not show DocBook

7.  Merely placing sofftodocbookheadings.xsl, docbooktosoffheadings.xsl and DocBookTemplate.stw in a newly created C:\Program Files (x86)\OpenOffice 4\share\xslt\docbook does not fix the problem.

8.  32 bit Java 1.8.0_171 is installed and AOO sees it under Tools > Options > OpenOffice > Java.
Comment 1 John 2018-05-03 17:11:14 UTC
Created attachment 86416 [details]
XML Filter Settings.gif shows Tools > XML Filter Settings

XML Filter Settings.gif shows Tools > XML Filter Settings ....  Note that docbook is not available.
Comment 2 Matthias Seidel 2018-05-03 17:36:28 UTC
On Windows this is an optional feature and has to be installed via Custom Setup (XSLT Filters).

See attached picture.
Comment 3 Matthias Seidel 2018-05-03 17:37:02 UTC
Created attachment 86417 [details]
AOO 4.1.5 Custom Setup
Comment 4 John 2018-05-03 17:52:37 UTC
This is one of the better bugs because the fix is given by the bug reporter.

It appears that the Windows 7 and 10 (and others?) installation fails to install the DocBook filter(s).  The user fix appears to be:

1.  Run setup.exe from the Installation files

2.  Select Modify

3.  Expand Optional Components

4.  Note that "XSLT Sample Filters" is marked with [X] saying it is not installed.

5.  Remove the [X] by selecting "This feature and all sub-features will be installed on the local hard drive"

6.  Start AOO.  DocBooks is now made available under File > Save As ...
Comment 5 John 2018-05-03 18:01:50 UTC
(In reply to Matthias Seidel from comment #2)
> On Windows this is an optional feature and has to be installed via Custom
> Setup (XSLT Filters).
> 
> See attached picture.

Matthias

Thanks.  Our posts crossed and you are saying it is "working as designed".  May I say that the design is therefore incorrect.  Why?

1.  AOO 4.1.5 announces that DocBook is available - see "Getting Started With DocBook on OpenOffice" at http://www.openoffice.org/xml/xmerge/docbook/UserGuide.html

2.  Nowhere is that announcement, nor anywhere in Help, does it mention that you need to install it as an option.

So, my question is this:  How does a user get the newly announced feature to work?  

The answer is they do what tay did, and they come to the forum where we had to diagnose the problem from first principles because there is no documentation.

Please consider this a request for all AOO installers to install the DocBook feature by default because it is announced as a feature.
Comment 6 Matthias Seidel 2018-05-03 18:30:43 UTC
(In reply to John from comment #5)
> (In reply to Matthias Seidel from comment #2)
> > On Windows this is an optional feature and has to be installed via Custom
> > Setup (XSLT Filters).
> > 
> > See attached picture.
> 
> Matthias
> 
> Thanks.  Our posts crossed and you are saying it is "working as designed". 

I did not say that. ;-)
I confirmed the behavior and pointed to a simple solution...

...

> Please consider this a request for all AOO installers to install the DocBook
> feature by default because it is announced as a feature.

I will have a look into it.
Comment 7 SVN Robot 2018-05-05 19:08:24 UTC
"mseidel" committed SVN revision 1830998 into trunk:
#i127770#
Comment 8 Matthias Seidel 2018-05-05 19:13:47 UTC
"XSLT Sample Filter" now included in default installation on Windows.
Comment 9 John 2018-05-06 09:47:10 UTC
Thanks Matthias.
Comment 10 SVN Robot 2018-09-01 10:21:03 UTC
"mseidel" committed SVN revision 1839814 into branches/AOO416:
i127770 - Include "XSLT Sample Filter" in default installation on Windows