Issue 127805 - Crash in Impress on Ubuntu 18.04 when selecting Master Pages in sidebar
Summary: Crash in Impress on Ubuntu 18.04 when selecting Master Pages in sidebar
Status: CLOSED DUPLICATE of issue 127929
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: 4.1.5
Hardware: All Linux, all
: P5 (lowest) Normal with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: crash
Depends on:
Blocks:
 
Reported: 2018-06-30 09:08 UTC by Matthias Seidel
Modified: 2018-11-09 20:11 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
petko: 4.1.6_release_blocker-


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Matthias Seidel 2018-06-30 09:08:52 UTC
Impress crashes when selecting Master Pages in sidebar.

Steps to reproduce:
 - Create new (empty) Presentation
 - Open sidebar
 - Click on "Master Pages"

Expected behavior:
 - AOO should display samples of the Master Pages in the sidebar

Shown behavior:
 - Impress crashes

This is reproducible on Ubuntu 18.04 (64-bit) and Xubuntu 18.04 (32-bit) with AOO 4.1.5.

It is *not* reproducible with Ubuntu 16.04.
Comment 1 oooforum (fr) 2018-07-04 16:02:17 UTC
Not reproduce with LUbuntu 17.04 x64 and AOO 4.1.5

Did you think to reset the user profile before?
Comment 2 Matthias Seidel 2018-07-04 16:04:34 UTC
(In reply to oooforum (fr) from comment #1)
> Not reproduce with LUbuntu 17.04 x64 and AOO 4.1.5
> 
> Did you think to reset the user profile before?

As I wrote above, this crash happens in Ubuntu 18.04.
Comment 3 Mechtilde 2018-08-05 17:53:50 UTC
I can confirm this problem with an old user profile under Debian Testing (Buster).

It works under a fresh Debian Stable (Stretch) with a free user profile.

To remove my user profile is no option now
Comment 4 Pedro 2018-08-05 23:32:23 UTC
Crash confirmed with AOO 4.1.5 under Ubuntu 18.04.1 x64
This was tested on a new user profile.
Comment 5 Matthias Seidel 2018-09-18 14:22:30 UTC
I could reproduce the crash on Xubuntu 18.04.1.

Title:
soffice.bin crashed with SIGSEGV in FT_Glyph_Get_CBox()

Disassembly:
 => 0x7f7412d941aa <FT_Glyph_Get_CBox+58>:	mov    0x30(%rax),%rax
    0x7f7412d941ae <FT_Glyph_Get_CBox+62>:	test   %rax,%rax
    0x7f7412d941b1 <FT_Glyph_Get_CBox+65>:	je     0x7f7412d94220 <FT_Glyph_Get_CBox+176>
    0x7f7412d941b3 <FT_Glyph_Get_CBox+67>:	push   %rbp
    0x7f7412d941b4 <FT_Glyph_Get_CBox+68>:	push   %rbx
    0x7f7412d941b5 <FT_Glyph_Get_CBox+69>:	mov    %esi,%ebp
    0x7f7412d941b7 <FT_Glyph_Get_CBox+71>:	mov    %rdx,%rbx
    0x7f7412d941ba <FT_Glyph_Get_CBox+74>:	mov    %rdx,%rsi
    0x7f7412d941bd <FT_Glyph_Get_CBox+77>:	sub    $0x8,%rsp
    0x7f7412d941c1 <FT_Glyph_Get_CBox+81>:	callq  *%rax
    0x7f7412d941c3 <FT_Glyph_Get_CBox+83>:	mov    %ebp,%eax
    0x7f7412d941c5 <FT_Glyph_Get_CBox+85>:	and    $0xfffffffd,%eax
    0x7f7412d941c8 <FT_Glyph_Get_CBox+88>:	cmp    $0x1,%eax
    0x7f7412d941cb <FT_Glyph_Get_CBox+91>:	je     0x7f7412d941f0 <FT_Glyph_Get_CBox+128>
    0x7f7412d941cd <FT_Glyph_Get_CBox+93>:	lea    -0x2(%rbp),%esi
    0x7f7412d941d0 <FT_Glyph_Get_CBox+96>:	cmp    $0x1,%esi

See the full crash log at:
https://home.apache.org/~mseidel/_opt_openoffice4_program_soffice.bin.1000.crash
Comment 6 Matthias Seidel 2018-09-18 16:05:20 UTC
Ubuntu switched from FreeType 2.6.x in 16.04 to 2.8.x in 18.04.

The only occurrences searching for "FT_Glyph_Get_CBox" are in:
https://svn.apache.org/repos/asf/openoffice/trunk/main/vcl/source/glyphs/gcach_ftyp.cxx
Comment 7 Matthias Seidel 2018-09-18 16:53:39 UTC
After installing FreeType 2.8.1 via PPA on Ubuntu 16.04 the crash can be reproduced immediately with Jim's latest 4.1.6 build.

So I am asking for release blocker 4.1.6.
Comment 8 Peter 2018-09-18 19:20:31 UTC
I think this bug will delay the release longer. I rather would like to release now and evaluate this again in the next release. Even a version 4.1.7 sounds more attractive then press this in 4.1.6.
I am sorry, but the initiative is welcome.

Also this might be older and not a new effect. I had crashes like this in 2017. But I forgot about it bcause of FOSDEM.
Comment 9 Matthias Seidel 2018-09-18 19:31:16 UTC
No, this crash is related to FreeType 2.8.x.

4.1.6 is likely to crash on every Linux that uses it.
4.1.5 crashes and even 4.2.0 does...

That will create a huge amount of traffic in the forum and on the list.
Comment 10 Peter 2018-09-18 19:42:03 UTC
If we can fix it fast I change my mind. No patch no release blocker. Only exception: if a release can be blocked by the issue.
We can prepare another release if needed.
Comment 11 Matthias Seidel 2018-09-18 19:52:52 UTC
Maybe now that the problem is localized a developer could have a look at it?

We always released OpenOffice "when it is ready".
Comment 12 Kay 2018-09-18 20:23:31 UTC
No problem with AOO 4.1.5 and freetype 2.3 on 32-bit CentOS 6.10. I can select master pages in sidebar without issue.
Comment 13 Matthias Seidel 2018-09-18 20:27:50 UTC
(In reply to Kay from comment #12)
> No problem with AOO 4.1.5 and freetype 2.3 on 32-bit CentOS 6.10. I can
> select master pages in sidebar without issue.

Of course not!

This issue is about Ubuntu 18.04 (and flavors) or Debian which uses FreeType 2.8.x.
Comment 14 Matthias Seidel 2018-09-20 14:35:42 UTC
Why was this set to unconfirmed?

The title says it all...
Comment 15 Peter 2018-09-20 18:30:28 UTC
I checked now. Freetype 2.8.1 has been active since 2017-05-13 on arch. So I have the crash longer then that. I had use paste &copy for my talk on Fosdem 2017 because it crashed.
I thought it was special to Arch, so I thought if I build a special Version it will fix.
Comment 16 Matthias Seidel 2018-09-20 19:10:35 UTC
That fits to Mechtilde's comment.

Debian Stretch uses FreeType 2.6.x
Debian Buster uses Freetype 2.8.x

Crash occurs in Debian Buster.
And Ubuntu 18.04 is (more or less) based on Debian Buster.
Comment 17 Matthias Seidel 2018-09-28 18:38:06 UTC
AOO also crashes when accessing the master pages via menu:
View -> Master -> Slide Master
View -> Master -> Notes Master
Comment 18 Peter 2018-10-08 11:15:36 UTC
side note: Draw does not crash when masterpage is opened.
Comment 19 Peter 2018-10-09 08:11:43 UTC
I checked the code around FT_Glyph_Get_CBox() by a dry run.
It looks fine to me and there is no indication of a change in the freetype.
So my guess is that we have an ABI error.
Lets try to compile OpenOffice as is against freetype 2.8.x and see if that fixes the crash. If so we have an Issue with our distribution approach.
Comment 20 Peter 2018-11-08 21:10:54 UTC
Possible patch on the report 127929. Lets continue there.

*** This issue has been marked as a duplicate of issue 127929 ***