Issue 127814 - add/enable [none] to the list of languages in the Spell Check dialog box
Summary: add/enable [none] to the list of languages in the Spell Check dialog box
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.5
Hardware: PC Windows 7
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-11 18:52 UTC by Tracey
Modified: 2018-08-05 21:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Tracey 2018-07-11 18:52:08 UTC
At the top of the Spell Check dialog box there is a field for Text Language.
Please add/enable [none] (Do not check spelling) to the list of languages because the Spanish Spell Check treats...

 [letters of the alphabet] and [Roman Numerals] 

... as incorrect/invalid spelling.
They are not flagged as invalid for English.
I have to "fix" the error outside the Spell Check dialog box.

Thanks, Tracey
Comment 1 oooforum (fr) 2018-07-17 07:30:54 UTC
Don't open multiple reports for a same issue

*** This issue has been marked as a duplicate of issue 127808 ***
Comment 2 Tracey 2018-07-17 18:59:44 UTC
This is NOT a duplicate of 127808.
127808 is referencing the [Language Options] accessible from the status bar which has a bug/flaw in functionality.


127814 is an enhancement request to the [Spell Check Dialog Box] (when you press [F7])
ADDing "[None] (Do not check spelling)" as a language option...
to the [Spell Check Dialog Box]...

that is also available from [Language Options] on the status bar.

I have a problem (understandably so) changing the the spell check condition to [None] from the [Language Options] on the status bar while the [Spell Check Dialog Box] is open.

When I have "errors" that require the spell check condition be set to [None], I have to keep closing the [Spell Check Dialog Box], access [None] from the  [Language Options] on the status bar then re-opening the [Spell Check Dialog Box] to continue the spell check process.

Thanks, Tracey
I do have another related issue with the Spell Check Dialog Box, but I think I should post it to the Users Group to figure out how I should phrase it.
Comment 3 oooforum (fr) 2018-07-19 07:57:31 UTC
Your request has no make sense. Language is set in Format > Character dialog.
Comment 4 Tracey 2018-07-19 18:49:19 UTC
Simply stated: I want to add to the options... "[None] (Do not check spelling)"... to the "Text Language Options" field of the [Spell Check Dialog Box].

Reason:
When spell checking a Spanish document, Roman Numerals [for ordinal numbers] and 
Letters [like there are in Bullets and Numbering] flag as an error.

Via the Spell Check dialog box, I can change the "language" of each offending character string from Spanish to English and those characters will no longer be flagged as an error.

But these are not in "English" text nor are they Spanish words.

During a spell check session, I can:
1) high-light the offending characters
2) close/stop the Spell Check dialog box
3) right click the [Language Options] and change the Language Text to:
"[None] (Do not check spelling)"
4) Resume spell checking.

This makes Spell Checking the Spanish text rather tedious.

If I do not close the [Spell Check Dialog Box] before changing the text language, spell checking will very ungracefully not resume.

If I close the dialog box first the cursor jumps to another part of the document then I have to hunt for the offending text.
Comment 5 oooforum (fr) 2018-07-20 10:15:03 UTC
Please stop to change status!

>During a spell check session, I can:
>1) high-light the offending characters
>2) close/stop the Spell Check dialog box
>3) right click the [Language Options] and change the Language Text to:
> "[None] (Do not check spelling)"
>4) Resume spell checking.

1) Select offending characters
2) Menu Format > Character
3) Set Language to [None]
Result is spell checking will be disabled for this text