Issue 127825 - Standard filter with option "No duplication" is losing results.
Summary: Standard filter with option "No duplication" is losing results.
Status: CLOSED DUPLICATE of issue 29844
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 4.1.5
Hardware: All All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-28 23:45 UTC by Wolfgang Jäger
Modified: 2020-02-24 17:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Wolfgang Jäger 2018-07-28 23:45:59 UTC
The standard filter offers the option to suppress repetitions. 
Applied to long data columns it returns less distinct items than actually contained.  

From a few tests it seems that a maximum of 16384 distinct items can be handled. Yes. That's a Strange number. We might expect a maximum of 2^15=32768 if an array with non-negative indices of type Integer (16 bit) was used. But 2^14?

The bug was found by a friend of mine. I reproduced it with an independent example under AOO V4.1.5 (from PortableApps package). In both cases the error occured as well when filtering in situ as when delivering the results to a different range (option 'Copy results to...'). 

Occurring only with data sets of more than 16384 items, it's a poisonous bug, because few users will look thoroughly enough on the results to notice it.

The attached demo needs a large file due to the nature of the bug. To open it will take some time.
Comment 1 Wolfgang Jäger 2018-07-28 23:54:45 UTC
the mentioned demo was rejected due to the file size. Therefor I uploaded the file to my domain. The link is:
http://psilosoph.de/bugDemosAOO/FilterNoDublicatesBug16384atMost.ods
Comment 2 jeffooo 2020-02-24 14:15:23 UTC
(In reply to Wolfgang Jäger from comment #0)
>it seems that a maximum of 16384 distinct items

Hello,

Possible duplicate issue of https://bz.apache.org/ooo/show_bug.cgi?id=29844
:
Issue 29844 - Filtering limited to 16384 row when No duplication checked

Regards
Comment 3 Keith N. McKenna 2020-02-24 17:20:54 UTC
Closing as duplicate

*** This issue has been marked as a duplicate of issue 29844 ***