Issue 127828 - PDF export: Background is split up around frames, showing white lines (gaps)
Summary: PDF export: Background is split up around frames, showing white lines (gaps)
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.1.5
Hardware: All All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-30 17:36 UTC by Manuel
Modified: 2018-08-01 14:36 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Exported pdf with split-up background (10.11 KB, application/pdf)
2018-07-30 17:36 UTC, Manuel
no flags Details
Writer document with blue background and a frame (10.13 KB, application/vnd.oasis.opendocument.text)
2018-07-30 17:37 UTC, Manuel
no flags Details
Preview app on macOS 10.13.5 (29.11 KB, image/png)
2018-07-30 18:41 UTC, Manuel
no flags Details
Preview app on macOS 10.13.15 (zoomed out) (22.89 KB, image/png)
2018-07-30 18:45 UTC, Manuel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Manuel 2018-07-30 17:36:35 UTC
Created attachment 86469 [details]
Exported pdf with split-up background

On a writer page with solid blue background, a frame with no border and no background is added. When exporting as PDF, the background is now split up around the frame into multiple rectangles, resulting in the split borders showing up as white lines (gaps) in PDF readers.
Comment 1 Manuel 2018-07-30 17:37:45 UTC
Created attachment 86470 [details]
Writer document with blue background and a frame
Comment 2 Regina Henschel 2018-07-30 17:45:10 UTC
I view the pdf with Acrobat Reader Version 2018.011.20055 on Win10 without any gap. Which Reader do you use? At what zoom? Which OS?
Comment 3 Manuel 2018-07-30 18:41:12 UTC
Created attachment 86471 [details]
Preview app on macOS 10.13.5
Comment 4 Manuel 2018-07-30 18:45:52 UTC
Created attachment 86472 [details]
Preview app on macOS 10.13.15 (zoomed out)
Comment 5 Manuel 2018-07-30 18:56:00 UTC
The lines appear in various OS's on various PDF readers. I've seen them on:

- Preview app 10.0 (944.5) on macOS 10.13.15 (see attached screenshots)
- Adobe Reader 9.5.5 on Ubuntu 18.04
- GSview 4.9 on Windows XP

I was not able to reproduce on:

- Foxit Reader 3.0 on Windows XP
- Adobe Reader XI 11.0.08 on Windows XP
Comment 6 oooforum (fr) 2018-07-31 08:08:00 UTC
For me not an AOO bug.
Report this to each PDF viewer editor
Comment 7 Manuel 2018-07-31 11:58:20 UTC
Okay, I'll try and report the bug to the several PDF viewer manufacturers. (Needless to say that the problem does not appear when exporting the PDF using LibreOffice 5.4.6.2 instead.)

Some more apps where the gap lines appear when viewing the PDF:

evince 3.28.2 on Ubuntu 18.04
pdf.js included in Firefox 61.0.1 (64-bit) on Ubuntu 18.04

And some more apps which render the PDF without problems:

xpdf 3.04 on Ubuntu 18.04
okular 1.3.3 on Ubuntu 18.04
PdfRenderer (?) on Android 6.0

And I need to correct myself, the following viewer does NOT show the gap lines:

Adobe Reader 9.5.5 on Ubuntu 18.04
Comment 8 Manuel 2018-07-31 18:11:10 UTC
Filed some bugs:

pdf.js included in Firefox 61.0.1 (64-bit) on Ubuntu 18.04
https://bugzilla.mozilla.org/show_bug.cgi?id=1479849

Preview app 10.0 (944.5) on macOS 10.13.15
https://bugreport.apple.com/web/?problemID=42777283

evince 3.28.2 on Ubuntu 18.04
https://gitlab.gnome.org/GNOME/evince/issues/952