Issue 127861 - Writer does not show OLE Object inserted from file
Summary: Writer does not show OLE Object inserted from file
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 4.2.0-dev
Hardware: All Windows 7
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-08-23 15:10 UTC by Pedro
Modified: 2018-12-01 01:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Small equation document for testing (5.18 KB, application/vnd.oasis.opendocument.formula)
2018-08-23 15:10 UTC, Pedro
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Pedro 2018-08-23 15:10:09 UTC
Created attachment 86493 [details]
Small equation document for testing

This issue occurs on AOO 4.2.0 when inserting any OLE object if the "Link to file" option is not checked.
It was detected on version 4.2.0 build 1838150 and newer on Windows 7 x64 Pro

Steps to reproduce
1) Create new Writer file
2) Insert > Object > OLE Object > Create from file > Search > Select any file (a small sample equation is attached as example)
3) Do _not_ check the "Link to file" option
4) Click OK

Result: an image with a yellow electric plug on top of a document with red text Object 1 shows up

Expected: an image of the inserted object is shown

If the user double clicks on the yellow plug image then the OLE object is opened for editing as expected and after closing the edit window, the correct image is shown.

If the "Link to file" option is checked then the image of the object shows as expected
Comment 1 jmpoo 2018-10-24 10:08:27 UTC
I can confirm this on Linux Mint 18.3 with AOO420m1(Build:9800) - Rev. 1844412

Tried to insert a text file as ole object and get the same error.

Works as expected in AOO416m1(Build:9790) - Rev. 1844227
Comment 2 leva.carol.a 2018-11-30 23:49:01 UTC
I replicated this bug on AOO 4.2 rev 1846059 on a Windows 10 Enterprise desktop for files types TXT, RTF, and PNG.  I could not replicate the bug on prior version AOO 4.1.6 rev 1844436 on a Windows 10 Enterprise desktop for file types TXT, RTF, and PNG.  

I also tried file types OXPS and WMV, and I noticed a different behavior in AAO 4.2, where the generic icon and title show up after (instead of before) double-clicking on the object.  These file types appear as icons in the document instead of showing their content in the document.  Initially, an appropriate icon and title is shown in the document, but after you double-click on the icon and open the file, it changes to the plug-in icon with a generic Object title.

Steps to replicate:
1) Open a new Writer document
2) From the menu, select Insert>Object>OLE Object
3) From the “Insert OLE Object” dialog, select “Create from File”, then use the Search button to select a file with a WMV extension.  Make sure “Link to file” is not checked and select OK.
4) Note that an appropriate icon and title appears on the object.
5) Double-click on the object, then select Open from the “Open Package Contents” dialog.  The WMV file opens in a video player app.  Close this app.
6) Note that the object icon has changed to a plug-in icon and the title has changed to Object 1.

Actual Result: Icon and title on object are changed to a generic icon and title
Expected Result: Appropriate icon and title on object are retained

Additional information: This behavior does not occur when using the “Link to file” option for a WMV file.  This behavior also occurs in AOO 4.1.6 for a WMV file.
Comment 3 Keith N. McKenna 2018-12-01 01:01:00 UTC
Confirmed by Comments 1 & 2.

jmpoo and leva.carol.a please consider joining the QA team. For more information see the QA orientation page at https://openoffice.apache.org/orientation/intro-qa.html