Issue 127867 - chart disappears
Summary: chart disappears
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.5
Hardware: PC Windows 10
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-31 00:30 UTC by adrian816
Modified: 2018-09-16 09:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A document I'm writing which should display charts displays blank space instead (23.94 KB, application/vnd.oasis.opendocument.text)
2018-08-31 00:30 UTC, adrian816
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description adrian816 2018-08-31 00:30:26 UTC
Created attachment 86496 [details]
A document I'm writing which should display charts displays blank space instead

I create a new native-format writer document and type some text. I then insert a bar chart using the "chart wizard" feature. After that I type in more text. After saving the document I quit the program. When I subsequently open the document the text is there but the chart has vanished or shifted down the page. The amount of space in the document is still allocated for the chart.
Comment 1 oooforum (fr) 2018-09-01 12:29:55 UTC
No problem to see "Victim nationalities" chart in page 6.
Try Tools > Options > Writer > View and see if Graphics & Objects has become unchecked.

For this kind of question, please use first our forum or mailing list:
www.openoffice.org/support/
Comment 2 adrian816 2018-09-01 13:13:12 UTC
I can confirm that option "view graphics and objects" has always been "checked" (I have never de-selected that option) and also that many other charts are still visible in the document. 

In the whole document the problem just affects 3 out of a total of 6 charts, the others have always been visible. It may be related to the type of chart used, bar charts seem to remain in the document, pie charts are more likely to be affected.
Comment 3 Wolfgang Jäger 2018-09-01 22:06:56 UTC
The attached variant of the document only contains one embedded object. It contains the already mentioned chart.
 
This is the consistent result 
- shown by the Naviagtor
- visible in the Basic IDE when inspecting the respective objects
- obvious when inspecting the file with an unzipper.

Not a bug.

(See also https://forum.openoffice.org/en/forum/viewtopic.php?f=30&t=94901)
Comment 4 adrian816 2018-09-02 00:22:44 UTC
I've never inserted empty frames into the document, only charts of different types (by using the chart wizard). When the document is saved then re-opened what I get instead of all my charts (whether pie or bar) are:

some bar charts
some empty frames (without their contents of pie chart)
Comment 5 Wolfgang Jäger 2018-09-02 13:58:48 UTC
(In reply to adrian816 from comment #4)
> I've never inserted empty frames into the document, only charts of different
> types (by using the chart wizard). When the document is saved then re-opened
> what I get instead of all my charts (whether pie or bar) are:
> 
> some bar charts
> some empty frames (without their contents of pie chart)

If there is an issue at all then it is about NOT SAVING some charts correctly. The file you attached simply does not contain any chart except the one already mentioned. It therefore doesn't give any hint how to chack for a bug or to reproduce it. 

If YOU can reproduce the issue, please give a step-by-step description how to do it. 

In the case under discussion this must start with the CREATION of the document CONTAINING the charts.
Next steps are simple then: 
Save the document and close it.
Open the document again and see. 

Unfortunately an attached document cannot help in this case.
Comment 6 Wolfgang Jäger 2018-09-02 14:02:01 UTC
In addition: 

We can assume your charts came from spreadsheets originally and were copy/pasted into the Writer document? 

If so it would be very helpful if you attached the spreadsheet(s) containing the original charts to your next post.
Comment 7 oooforum (fr) 2018-09-13 07:35:04 UTC
No news from OP

Feel free to reopen and provide requested information in comments 5 & 6