Issue 127940 - Issue with blurred text when typing and editing in Writer
Summary: Issue with blurred text when typing and editing in Writer
Status: UNCONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: 4.1.5
Hardware: Mac macOS 10.12
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-20 20:04 UTC by elkalamar
Modified: 2018-11-23 12:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot demonstrating appearance of text (457.23 KB, image/png)
2018-11-20 20:04 UTC, elkalamar
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description elkalamar 2018-11-20 20:04:11 UTC
Created attachment 86555 [details]
screenshot demonstrating appearance of text

I'm experiencing an issue in Writer where the text becomes temporarily blurred whilst typing or editing. The blurriness is solved be changing the zoom value for the open document, but quickly returns. The blurred text might be a word, sentence, paragraph or entire document - the trigger seems to be selecting text, starting a new paragraph, or placing the cursor in a new position within the document. Scrolling the document can also cause text to blur, and also to restore blurred text to normal.

Also in combination with the blurred text I see cursor icons (sorry if this is not the correct terminology - please see attached screenshot!) randomly appearing around the document.

Text saves / opens okay. The issue is merely appearance - but it is debilitating as one needs to continually change the zoom value of the document in order to restore the text to normal (i.e. not blurred).

Here is a link to a forum thread where it has been discussed https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=95920

Other details:
It has been suggested that the issue might be Mac issue (rather than OO), however I don't see this issue replicated in the display of text in any other programme at all - not text editors, web browsers, PDF viewers, video or audio editors, in fact strangely the problem does not occur ever in OO Calc which I also use.

Attempted solutions:
I have been advised to try different (lower) screen resolutions, but this has not resolved the issue. I have tried varying lower screen resolutions but the problem persists.

OS and machine info:
I'm using a Macbook Pro (2016, 15" display) running OS Sierra 10.12.6.
Comment 1 elkalamar 2018-11-20 20:06:44 UTC
Steps to reproduce:
For me this happens as soon as I begin to type and edit text in Writer. Placing the cursor in different parts of the document may trigger the issue, as might pasting in new text. Basically the issue is constant in Writer (though as I mention the text can be restored to normal temporarily by adjusting the zoom factor of the document.
Comment 2 Peter 2018-11-22 09:38:58 UTC
Have you asked on forums that have this behavior, too?

This sounds very specific, since we do not have any other record to this.
Comment 3 elkalamar 2018-11-23 12:18:07 UTC
Hi,

the only one I have seen that appears to be the same issue is this thread - https://forum.openoffice.org/en/forum/viewtopic.php?f=17&t=92135&p=437426&hilit=blurred+text+mac#p437426

there was a suggestion on this thread to reduce the display resolution in order to solve the problem - for me this does not resolve the issue, although at some resolutions the problem seems to be less insistent (its very hard to document this very scientifically though!)

there may be others, but without better description / screenshots on those threads I can't tell if they are describing the same issue that I'm experiencing.

I don't recall when this problem started for me - I think that it has existed for me since installing OO on this macbook machine after purchase (I don't recall it starting suddenly after a particular OS update, but I could be wrong).

I have tested all available display resolutions offered within OS Sierra (I don't know what they are exactly - Sierra says "looks like" 1680 x 1050, 1440 x 900, 1280 x 800 and 1024 x 600). 1680 x 1050 and 1024 x 600 seem to be the worst, but the issue still exists with the other resolutions. I have tested after restarting the machine in safe mode, the problem still persists. 

Display drivers are uptodate etc.

I have recently installed and tested in LibreOffice, and I do not get this problem in LibreOffice Writer (or equivalent of Writer).