Issue 127952 - headless crash on doc to pdf conversion
Summary: headless crash on doc to pdf conversion
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.1.6
Hardware: Other Linux 64-bit
: P5 (lowest) Critical (vote)
Target Milestone: 4.1.9
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-04 19:52 UTC by alex.demarco
Modified: 2021-01-14 11:48 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.8
Developer Difficulty: ---
marcus: 4.1.9_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description alex.demarco 2018-12-04 19:52:53 UTC
[root@scentawl1 init.d]# Application Error

Fatal exception: Signal 6
Stack:
/opt/openoffice4/program/libuno_sal.so.3[0x7f4970b85c3a]
/opt/openoffice4/program/libuno_sal.so.3[0x7f4970b85d6c]
/opt/openoffice4/program/libuno_sal.so.3[0x7f4970b85e09]
/lib64/libc.so.6[0x3190430030]
/lib64/libc.so.6(gsignal+0x35)[0x319042ffc5]
/lib64/libc.so.6(abort+0x110)[0x3190431a70]
/opt/openoffice4/program/libvcl.so[0x7f496d51e7b5]
/opt/openoffice4/program/libsofficeapp.so[0x7f49708e354b]
/opt/openoffice4/program/libvcl.so[0x7f496d548f06]
/opt/openoffice4/program/libuno_sal.so.3[0x7f4970b84a02]
/opt/openoffice4/program/libuno_sal.so.3[0x7f4970b85dea]
/lib64/libc.so.6[0x3190430030]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f49581d5acf]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f49581b798c]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f495818a1ac]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f495808a464]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f495808b5b8]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f4957ff3f43]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f495804b044]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f495808c4c3]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a04a985]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a05af76]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a05ba84]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a05c5d6]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a05dc8b]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a057155]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a04867d]
/opt/openoffice4/program/../program/fastsax.uno.so[0x7f495a04c593]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f4958082027]
/opt/openoffice4/program/../program/libwriterfilter.so[0x7f4958220347]
/opt/openoffice4/program/libsfx.so(_ZN14SfxObjectShell10ImportFromER9SfxMedium+0                        x6e3)[0x7f496f5687cf]
/opt/openoffice4/program/libsfx.so(_ZN14SfxObjectShell6DoLoadEP9SfxMedium+0x952)                        [0x7f496f5694ba]
/opt/openoffice4/program/libsfx.so(_ZN12SfxBaseModel4loadERKN3com3sun4star3uno8S                        equenceINS2_5beans13PropertyValueEEE+0x1f2)[0x7f496f5903f6]
/opt/openoffice4/program/libsfx.so[0x7f496f5e5287]
/opt/openoffice4/program/libfwk.so[0x7f49693fb750]
/opt/openoffice4/program/libfwk.so[0x7f49693fc07e]
/opt/openoffice4/program/libfwk.so[0x7f49693fd188]
/opt/openoffice4/program/libfwk.so[0x7f496941bc86]
/opt/openoffice4/program/libgcc3_uno.so[0x7f4962be6ecd]
/opt/openoffice4/program/libgcc3_uno.so[0x7f4962be74e2]
/opt/openoffice4/program/libgcc3_uno.so[0x7f4962be8220]
/opt/openoffice4/program/binaryurp.uno.so[0x7f495f0b1386]
/opt/openoffice4/program/binaryurp.uno.so[0x7f495f0b23ff]
/opt/openoffice4/program/binaryurp.uno.so[0x7f495f0b65c6]
/opt/openoffice4/program/libuno_cppu.so.3[0x7f4970013a28]
/opt/openoffice4/program/libuno_cppu.so.3[0x7f49700145c5]
/opt/openoffice4/program/libuno_cppu.so.3[0x7f49700146bf]
/opt/openoffice4/program/libuno_sal.so.3[0x7f4970b7f2d2]
/lib64/libpthread.so.0[0x319100683d]
/lib64/libc.so.6(clone+0x6d)[0x31904d518d]
/opt/openoffice4/program/soffice: line 121: 13329 Aborted                 "$sd_p                        rog/$sd_binary" "$@"
Comment 1 alex.demarco 2018-12-04 19:54:42 UTC
I have a test case but it us 1427 kb and I have no place to store it for you to retrieve.
Comment 2 Peter 2018-12-05 22:23:24 UTC
Have you checked:
https://bz.apache.org/ooo/show_bug.cgi?id=97227

https://bz.apache.org/ooo/show_bug.cgi?id=119423

Can you please describe what you were doing? Your setup maybe?
Comment 3 oooforum (fr) 2018-12-07 13:38:07 UTC
Which distro and which UX is used?

(In reply to alex.demarco from comment #1)
> I have a test case but it us 1427 kb and I have no place to store it for you
> to retrieve.
Did you means that crash occurs with one document?
Comment 4 alex.demarco 2018-12-07 14:12:53 UTC
The crash happens with documents that contain embedded tables.

It happens on OEL 5 and OEL 6, with openoffice running headless via:
su - oouser -c "/opt/openoffice4/program/soffice -nologo -headless -invisible -nofirststartwizard -accept='socket,host=localhost,port=8100;urp;StarOffice.ServiceManager' &"
Comment 5 oooforum (fr) 2018-12-12 13:00:39 UTC
(In reply to alex.demarco from comment #4)
> The crash happens with documents that contain embedded tables.
Provide a sample document
 
> It happens on OEL 5 and OEL 6, with openoffice running headless via
Did the crash occurs when you run AOO in normal mode?
Comment 6 alex.demarco 2018-12-12 13:11:06 UTC
File is available at

https://www.suny.edu/badfile.docx

No i Have not tested it in AOO in normal mode.  Will try and let you know.
Comment 7 alex.demarco 2018-12-12 13:16:35 UTC
Loading the file in AOO and it loses all formatting (sorry not an avid AOO user) I can export to pdf without issue.  BUt again the formatting is all gone.
Comment 8 oooforum (fr) 2018-12-12 20:08:02 UTC
(In reply to alex.demarco from comment #6)
> File is available at
> h**ps://www.suny.edu/badfile.docx

Already reported

*** This issue has been marked as a duplicate of issue 116723 ***
Comment 9 Peter 2018-12-13 07:47:24 UTC
the Document crashes on my Machine.
System is Arch Linux, with 4.1.6
Comment 10 Peter 2019-01-01 09:53:22 UTC
I am not sure it is the same issue as linked. Here we have a crash, on the other issue we have a incorrect export. Why should they be the same?
Comment 11 Matthias Seidel 2020-12-12 21:03:11 UTC
This is not a duplicate.

The file crashes for me with AOO 4.1.8 on Ubuntu 16.04 - 64bit.
However, I can open it on Windows (which is a 32bit version)
Comment 12 Jim Jagielski 2021-01-08 11:21:46 UTC
Closed:
The following commit(s) were added to refs/heads/trunk by this push:
    new d14b525  Check for non-empty stacks before pop()
    new 477f4cf  Merge pull request #116 from ardovm/bug127952
d14b525 is described below

commit d14b525b4817f6497df2d8888b5b9975281de58a
Author: Arrigo Marchiori <ardovm@yahoo.it>
AuthorDate: Thu Jan 7 22:17:21 2021 +0100
Comment 13 Matthias Seidel 2021-01-09 15:22:59 UTC
One thing I forgot:

While the file can be opened on Windows with AOO 4.1.x the import is far from perfect (see comment 7).

I get much better results with AOO 4.2.x.
Comment 14 Matthias Seidel 2021-01-14 11:48:43 UTC
BTW: Did anyone test this in headless mode?