Issue 128023 - Bad encodage with concordance file UFT8
Summary: Bad encodage with concordance file UFT8
Status: CLOSED DUPLICATE of issue 67649
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.6
Hardware: All Windows 10
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-28 10:29 UTC by jeffooo
Modified: 2019-01-29 10:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Text document (9.58 KB, application/vnd.oasis.opendocument.text)
2019-01-28 10:29 UTC, jeffooo
no flags Details
SDI file with UFT-8 encodage (41 bytes, application/octet-stream)
2019-01-28 10:30 UTC, jeffooo
no flags Details
SDI file with ANSI encodage (36 bytes, application/octet-stream)
2019-01-28 10:31 UTC, jeffooo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jeffooo 2019-01-28 10:29:46 UTC
Created attachment 86626 [details]
Text document

Hi developpers,

On Windows with locale Fr, if I used a concordance file with UFT-8 encodage, I have a bad encodage with accent characters.

For the text :
Texte français accentué

Obtained result :
Texte français accentué

I must encodind my File.sdi to ANSI encodage...but the defect is on Linux.

Step to reproduce :
 1) Open a file "TestSdiUFT8.odt"
 2) Connect sdi file :
   a) Menu Insert > Indexes and tables > Indexes and tables...
   b) In "Option", choose file > Open, and select the file "SDIfileUFT8.sdi"

I join a ANSIfile.sdi too, for Linux test.

Thanks
Comment 1 jeffooo 2019-01-28 10:30:31 UTC
Created attachment 86627 [details]
SDI file with UFT-8 encodage
Comment 2 jeffooo 2019-01-28 10:31:37 UTC
Created attachment 86628 [details]
SDI file with ANSI encodage
Comment 3 jeffooo 2019-01-29 03:25:54 UTC
Sorry is a duplicate of https://bz.apache.org/ooo/show_bug.cgi?id=67649
Comment 4 oooforum (fr) 2019-01-29 10:46:16 UTC
Already reported

*** This issue has been marked as a duplicate of issue 67649 ***