Issue 128036 - Crash in Writer when linking frames on OS/2
Summary: Crash in Writer when linking frames on OS/2
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.6
Hardware: All OS/2
: P5 (lowest) Normal (vote)
Target Milestone: 4.1.7
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: crash
Depends on:
Blocks: 126518
  Show dependency tree
 
Reported: 2019-02-10 20:01 UTC by Matthias Seidel
Modified: 2019-08-18 14:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Matthias Seidel 2019-02-10 20:01:42 UTC
I get a crash in Writer when trying to link frames with AOO 4.1.6 on ArcaOS (OS/2).

Steps to reproduce:

 - Create new Writer document
 - Insert a frame by choosing "Insert - Frame" from menu
 - Accept the defaults by clicking "OK"
 - Leave the frame selected and click on icon "Link Frames" in toolbar

Result:

 - Crash

Expected behavior:

 - You should see a mouse pointer indicating that you cannot link a single frame

In fact you need at least two frames but even then the crash occurs.
Comment 1 Matthias Seidel 2019-02-10 20:08:03 UTC
The main problem seems to be that the two pointers

 /main/vcl/os2/source/src/chain.ptr

and

 /main/vcl/os2/source/src/chainnot.ptr

are broken. In fact they have only the size of 16 bytes.
Comment 2 Matthias Seidel 2019-02-10 20:17:33 UTC
I fixed the two broken pointers (and several other) in trunk with
 
 r1851115
 r1851118
 r1851121
 r1851206
 r1851215

Merged to AOO42X with

 r1851280

Merged to AOO417 with

 r1853254

I hope this fixes the crash.
Comment 3 oooforum (fr) 2019-02-11 14:15:01 UTC
I Cc-ed Yuri for information
Comment 4 Matthias Seidel 2019-02-12 17:50:56 UTC
I forgot to mention that after clicking on "Link Frames" the mouse has to be moved to the document area to force the mouse pointer change.

Then the crash occurs.
Comment 5 Yuri Dario 2019-02-15 11:33:02 UTC
After building the current 4.1.7 branch I can confirm that the crash is gone and the correct pointer is visible.