Issue 128283 - Issue with layout of dialog "Solver"
Summary: Issue with layout of dialog "Solver"
Status: RESOLVED FIXED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 4.1.7
Hardware: All All
: P5 (lowest) Trivial (vote)
Target Milestone: 4.1.8
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-09 22:36 UTC by Czesław Wolański
Modified: 2020-08-02 22:24 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Comparison of Solver dialog - Polish vs English (169.36 KB, image/jpeg)
2020-02-09 22:36 UTC, Czesław Wolański
no flags Details
Changed dialog width (89.25 KB, image/jpeg)
2020-02-09 23:19 UTC, Czesław Wolański
no flags Details
Proposal for translation in dialog "Solver" (311.50 KB, image/jpeg)
2020-02-10 04:39 UTC, Czesław Wolański
no flags Details
Resized Solver dialog (37.23 KB, application/pdf)
2020-02-16 19:46 UTC, Matthias Seidel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Czesław Wolański 2020-02-09 22:36:38 UTC
Created attachment 86826 [details]
Comparison of Solver dialog - Polish vs English

choose Tools > Solver..., dialog "Solver" appears

in POLISH version two labels have not enough space allocated to be displayed in full.

See attached file - these labels are marked in yellow.


Issue doesn't occur in many other language versions, i've checked English, French and German ones.


Please consider changing either the width of dialog "Solver" or names for labels.
Comment 1 Matthias Seidel 2020-02-09 23:08:30 UTC
Hi,

Can you think of a shorter Polish translation for:

Optimize result to

and:

By changing cells

?
Comment 2 Czesław Wolański 2020-02-09 23:17:26 UTC
(In reply to Matthias Seidel from comment #1)
> Hi,
> 
> Can you think of a shorter Polish translation for:
> 
> Optimize result to
> 
> and:
> 
> By changing cells
> 
> ?

Hi, nice to hear from you again.

Of course I could find shorter translation but first take a look at solution applied in Libre Office - they changed the width of dialog. See atttached screenhot.

If that doesn't suit you, i'll send my proposal later because right now I am preparing two new issue for Bugzilla
Comment 3 Czesław Wolański 2020-02-09 23:19:12 UTC
Created attachment 86827 [details]
Changed dialog width
Comment 4 Matthias Seidel 2020-02-09 23:25:11 UTC
I am already looking into the dialog resource file... ;-)
Comment 5 Matthias Seidel 2020-02-09 23:37:22 UTC
Confirmed on Windows 7 with Polish Language Pack.
Comment 6 Czesław Wolański 2020-02-10 04:37:09 UTC
(In reply to czeslaw.wolanski from comment #2)
> (In reply to Matthias Seidel from comment #1)
> > Hi,
> > 
> > Can you think of a shorter Polish translation for:
> > 
> > Optimize result to
> > 
> > and:
> > 
> > By changing cells
> > 
> > ?
> 
> Hi, nice to hear from you again.
> 
> Of course I could find shorter translation but first take a look at solution
> applied in Libre Office - they changed the width of dialog. See atttached
> screenhot.
> 
> If that doesn't suit you, i'll send my proposal later because right now I am
> preparing two new issue for Bugzilla


I presume that current Polish description is:

"Optimize result to" --> "Zoptymalizuj wynik pod kątem"

"By changing cells" --> "Komórki dla zmiennych źródłowych"



MY PROPOSAL, hopefully nearing other translations, is as follows:

1.   "Optimize result to" --> "Zoptymalizuj wynik do"  ["Optymalizuj wynik do","Równa","Wartość docelowa","Funkcja celu"]  
2.   "By changing cells"  -->  "Komórki zmieniane"     ["Przez zmianę komórek","Komórki dla zmiennych"]     

Please note few alternatives given in square brackets (in order of inferiority). They all have proper length too.

In doubt any user can find in AOO Help, in Polish, concise and precise explanation of Solver.


A last resort - if it's not possible to increase dialog's width - could be putting original content into help text of label control (quirky...).



In attached file you will find both original version and a new one of dialog "Solver", done in Dialog Editor.



By the way: "By changing cells" in French version reads "Par modification de cell".
"Cell" equivalent in French is "cellule" not "cell". Seems to me that someone knowingly (?) shrinked word 
"cellules" (plural for "cellule") to non-existing word "cell" and avoided problem of limited space for label.
(One could report that to Bugzilla...)
Comment 7 Czesław Wolański 2020-02-10 04:39:40 UTC
Created attachment 86829 [details]
Proposal for translation in dialog "Solver"
Comment 8 Matthias Seidel 2020-02-10 16:40:52 UTC
(In reply to czeslaw.wolanski from comment #7)
> Created attachment 86829 [details]
> Proposal for translation in dialog "Solver"

Regarding translations:

Feel free to subscribe to our localization mailing list and coordinate with the Polish translation team:

https://openoffice.apache.org/mailing-lists.html#localization-mailing-list-public
Comment 9 Matthias Seidel 2020-02-10 16:43:00 UTC
(In reply to czeslaw.wolanski from comment #3)
> Created attachment 86827 [details]
> Changed dialog width

Looking at the LO dialog it seems that they simply moved the upper elements to the right.

This is just a quick (and dirty?) hack.

I am sure we can find a better solution.
Comment 10 Matthias Seidel 2020-02-16 19:46:36 UTC
Created attachment 86839 [details]
Resized Solver dialog

Resized and aligned.
Hopefully enough space for every language.
Comment 11 Matthias Seidel 2020-02-16 21:40:44 UTC
Committed to trunk:

https://github.com/apache/openoffice/commit/b6c7a28b99eb2897f6f5ea9585b3031356dcfd24

and Cherry-Picked for AOO42X.
Comment 12 Matthias Seidel 2020-02-18 11:06:33 UTC
Should be visible in new test builds now.
Comment 13 Matthias Seidel 2020-08-02 22:24:36 UTC
Cherry-picked for AOO 4.1.8