Issue 128340 - Change of Icon style not applied to all UI elements immediately
Summary: Change of Icon style not applied to all UI elements immediately
Status: UNCONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.7
Hardware: PC Windows 7
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-18 15:56 UTC by Czesław Wolański
Modified: 2020-03-18 16:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Czesław Wolański 2020-03-18 15:56:15 UTC
This issue seems to fall across various AOO components.

Initial setting - Icon style: "Galaxy"
(Tools > Options > OpenOffice > View)

Steps to reproduce:

1. run AOO Writer
2. visible should be
   - sidebar, deck Navigator
   - Navigator (View > Navigator  or  F5)
   - Navigation toolbar (for example undocked from Navigator)
3. Change icon style to "Industrial"
   Tools > Options > OpenOffice > View
   Notice that icons in two areas have not changed
   i.e. in Navigation toolbar and in Navigator window (gray area).
4. Close and open Navigation toolbar and Navigator.
   Both have been updated.
5. Change icon style to "High Contrast"
   Tools > Options > OpenOffice > View
   Just as in point 3. icons in two areas have not changed.
6. Close and open Navigation toolbar and Navigator
   Just as in point 4. all icons reflect new Icon style.

See attached screenshots in file "Changing Icon Style"


Same problem (non-uniform update) occurs for saved document.
Comment 1 Czesław Wolański 2020-03-18 16:01:10 UTC
File with screenshots is available at the following link:

https://pasteboard.co/IZGq5Fo.jpg