Issue 128426 - the diagram disappears after modification in 419 RC1
Summary: the diagram disappears after modification in 419 RC1
Status: RESOLVED FIXED_WITHOUT_CODE
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 4.1.9
Hardware: Mac macOS 11.0
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-28 14:45 UTC by dle
Modified: 2021-02-09 17:58 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Spreadsheet after updated on AOO 419 (15.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-28 14:45 UTC, dle
no flags Details
Spreadsheet created on AOO 418 (15.24 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-28 14:46 UTC, dle
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description dle 2021-01-28 14:45:40 UTC
Created attachment 87001 [details]
Spreadsheet after updated on  AOO 419

Hi, 
This issue happens to AOO 419 RC1 and not in AOO 418.
In a sheet I have a diagram, if I modify and save it, when reopening the diagram has disappeared, the diagram area is empty.

Attached two files
"Test_diagram": created under W10 AOO 418
"Test_diagramme_Maj": result after updating and saving. We see a white rectangle in "K17: M20", click on it the frame with the green handles is displayed, a double click displays the diagram area, but everything is empty.
Comment 1 dle 2021-01-28 14:46:47 UTC
Created attachment 87002 [details]
Spreadsheet created on AOO 418
Comment 2 Matthias Seidel 2021-01-28 15:16:43 UTC
Cannot replicate...

I opened your spreadsheet (created with AOO 4.1.8), modified a value and did save it with AOO 4.1.9 (RC1).

All values and the diagram are still there.

Test was done on Windows 10 Pro 64-bit (German OS and German AOO).
Comment 3 dle 2021-01-28 15:33:36 UTC
Hi Matthias,
I'm so sorry, I forgot to say I'm on Mac OS Big Sur, but it also happens in High Sierra.
Regards
Comment 4 Matthias Seidel 2021-01-28 15:36:21 UTC
OK, I adjusted the OS now...

Then we need to find testers with macOS. ;-)
Comment 5 tintin60 2021-01-28 15:44:03 UTC
Hi

I confirm the malfunction described by dle.

Thanks to Matthias for his comment.

Then it shoud be useful to change Hardware All All to macOS

Malfunction occurs with macOS 11.1 Big Sur AND 10.3.6 High Sierra 
on AOO 4.1.9RC1 (French) while AOO 4.1.8 operates as usual.

NB :
Issue 128415 https://bz.apache.org/ooo/show_bug.cgi?id=128415
resulted in the release of AOO 4.1.9.
It would be a shame if the final version came out with a regression.

Rgds
Comment 6 Matthias Seidel 2021-01-28 15:54:03 UTC
(In reply to tintin60 from comment #5)

> NB :
> Issue 128415 https://bz.apache.org/ooo/show_bug.cgi?id=128415
> resulted in the release of AOO 4.1.9.
> It would be a shame if the final version came out with a regression.
> 
> Rgds

Well the testing is over for a week now...
RC1 is voted to be released.
Comment 7 Matthias Seidel 2021-01-28 16:08:08 UTC
Confirmed on macOS 11 (Big Sur)
Comment 8 Jim Jagielski 2021-01-28 16:23:01 UTC
Tested on Catalina (10.15.7) and I cannot recreate.
Comment 9 oooforum (fr) 2021-01-28 16:38:45 UTC
Maybe it will be interesting to try with 4.2.0-dev if the issue occurs too.
Comment 10 Jim Jagielski 2021-01-28 19:51:09 UTC
Please try the binaries found at:

    https://dist.apache.org/repos/dist/dev/openoffice/4.1.9-RC1/binaries/
Comment 11 Dave Fisher 2021-01-28 20:20:10 UTC
Seemed to work for me. I changed both a data cell and the chart type.
Comment 12 Matthias Seidel 2021-01-28 20:22:05 UTC
What O(In reply to Dave Fisher from comment #11)
> Seemed to work for me. I changed both a data cell and the chart type.

What version of macOS are you using?
Comment 13 Matthias Seidel 2021-01-28 20:23:40 UTC
(In reply to Dave Fisher from comment #11)
> Seemed to work for me. I changed both a data cell and the chart type.

Ah, sorry!
You already tested the new binaries?

I can confirm that the issue is gone with the new builds on macOS 11.2.
Comment 14 tintin60 2021-01-28 21:12:10 UTC
Hi,

About diagram, https://dist.apache.org/repos/dist/dev/openoffice/4.1.9-RC1/binaries/ works
on macOS 10.13.6 High Sierra AND 11.1 Big Sur

Rgds
Comment 15 Dave Fisher 2021-01-28 22:20:14 UTC
(In reply to Matthias Seidel from comment #12)
> What O(In reply to Dave Fisher from comment #11)
> > Seemed to work for me. I changed both a data cell and the chart type.
> 
> What version of macOS are you using?

Catalina - 10.15.7
Comment 16 dle 2021-01-29 07:59:59 UTC
Hi, 
I confirm the issue is resolved.
Regards
Comment 17 Keith N. McKenna 2021-01-29 18:43:28 UTC
Marking as Resolved Fixed per Comment 16 from the original reporter of the bug report