Issue 128439 - Inconsistent results when incorporating mp3 files in a presentation
Summary: Inconsistent results when incorporating mp3 files in a presentation
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: 4.1.9
Hardware: PC Windows 10
: P5 (lowest) Normal (vote)
Target Milestone: 4.1.10
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2021-03-20 14:42 UTC by Peter Pratten
Modified: 2021-05-03 20:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Peter Pratten 2021-03-20 14:42:02 UTC
I'm trying to incorporate music in a regular presentation. Most songs are mp3 although some are m4a.

Some mp3 files open but other report unsupported although they  come from the same source. Why the inconsistency?

Why is m4a not supported when you have so many others that the list is too long to display across the screen?

Suggestion: when a format is not supported call on the default app of the PC. Also I suggest that wpl is treated this way.

Context is similar to 11746.

I submitted this bug by email but it doesn't show up.
Comment 1 Matthias Seidel 2021-03-20 19:04:24 UTC
MP3 can contain ID3Tags.

After removing the Tags (on Windows) with ID3Remover [1] I could successfully open such a file in Impress.

It looks like we need to implement some code to recognize MP3 with ID3Tags.

Comment 2 Matthias Seidel 2021-03-20 23:49:11 UTC
The problem seems to be only with ID3Tags v2. Removing them makes AOO load that file.

MP3 files with ID3Tag v1 generally should work.
Comment 3 Matthias Seidel 2021-03-21 12:03:00 UTC
Setting this back to DEFECT since AOO should open MP3 files despite of ID3Tags.
Comment 4 Matthias Seidel 2021-03-21 16:21:07 UTC
(In reply to Peter Pratten from comment #0)
> Context is similar to 11746.

Is there a number missing?
Comment 5 Peter Pratten 2021-03-21 23:54:59 UTC
Sorry, this was a mistype, ID should be 17446. It was just referring to a similar context of the requirement, not a connection with the bug.
Comment 6 Matthias Seidel 2021-03-22 15:36:48 UTC
Thanks for the clarification!

Regarding m4a:
You can always see such files using "all files"
(I will add m4a to the list of audio files for the next release)

However to get AOO/Windows play these files you need to install additional codecs. I took "K-Lite Codec Pack Basic" and it worked for me on Windows 10 with AOO 4.1.9:
Comment 7 Matthias Seidel 2021-03-24 16:02:19 UTC
Added m4a to the list of audio files to trunk with:

Cherry-picked for AOO42X with:
Comment 8 Matthias Seidel 2021-04-06 00:28:51 UTC
Cherry-picked for AOO41X with:
Comment 9 Matthias Seidel 2021-04-21 15:14:03 UTC
I will close this issue as fixed.

The problem with MP3 was solved with installing additional codecs on Windows.

M4A was added to the list of audio files now.