Issue 12885 - installation program hardcoded to use /tmp
Summary: installation program hardcoded to use /tmp
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@installation
Keywords: rfe_eval_ok
Depends on:
Reported: 2003-03-31 17:00 UTC by Unknown
Modified: 2005-10-14 21:53 UTC (History)
3 users (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-03-31 17:00:04 UTC

The install script and the setup app seems to be hard coded to use /tmp. This
causes me problems since my / only has around 20MB free. Setting the TEMPDIR env
var does not seem to have any affect.

I also tried changing the line in install to point to /var/tmp but the binary
still seems to point to /tmp. Any help in resolving this would be appreciated.


Comment 1 Olaf Felka 2003-04-01 14:52:22 UTC
On my Mandrake box OOo 1.1 writes its temp files to /<user_home>/tmp
when I start ./setup. So the setup script is looking for the system
Can you give a hint what's to do or should the community be asked?
Comment 2 khendricks 2003-04-01 15:14:21 UTC

I have no idea here.  The "install" script only uses /tmp to create a very small response file and it could be changed to use an environment variable but those 20 or so bytes are not what is causing his problem.

I believe that the setup binary (which is invoked by the "install" script) would have to be changed to use some other /tmp directory location since it is the thing that unpacks the files to run the full installer.  But I am not sure how that is done.  You would have to ask the installation project people to be sure how the /tmp directory is determined.

The temporary solution is to use symlinks to move /tmp to some volume with more space on it until setup2 is modified to handle TEMPDIR in some way.

Changing assignment back to issues@installation

Here is the snippet of the "install script" that makes use of /tmp but like I said, those 20 or so bytes are not the issue.



TMPFILE=`mktemp -q /tmp/$0.XXXXXX`
if [ $? -ne 0 ]; then
     echo "$0: Can't create temp file, exiting..."
     exit 1
cat << EOF >> ${TMPFILE} 


Comment 3 Unknown 2003-04-01 16:12:46 UTC
You are absolutely right. I had tried hardcoding the script to use
/var/tmp and that did not fix the problem that I was having.

The app itself is hardcoded to use /tmp which is a bit annoying at the

Should I report this bug elsewhere for the installation team to take a
look at it ?


Comment 4 Olaf Felka 2003-04-02 08:40:45 UTC
Hi Shriram,
OOo is not hardcoded to /tmp, OOo uses what is defined in the
systemsettings. In your case it is /tmp. There is no setup switch to
use another tmp directory. Please try the workaround with the symlink.
I forward this as 'wish to enhance'.
The comment that you've written here misses some linebreaks. Only when
I switch to resolution 3072 X 1024 I can read the lines without
scrolling :-))
Comment 5 bettina.haberer 2003-04-02 16:17:07 UTC
I changed the issue type to enhancement.
Comment 6 christof.pintaske 2004-11-29 16:29:13 UTC
Starting with OpenOffice 2.0 the installation will use the systems "native"
package mechanism (i.e. currently Linux RPM, Solaris PKG, and Windows MSI).
Wether these installer provide support for changing the tmp directory is not
controlled by in any way. There is no need and no way to fix this
issue in
Comment 7 flibby05 2005-10-14 21:52:41 UTC
ok, we have 2.0 rc3 now,
closing this issue as obsolete
Comment 8 flibby05 2005-10-14 21:53:17 UTC