Issue 12936 - Word processor crashes when opening file
Summary: Word processor crashes when opening file
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.1
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: philipp.lohmann
QA Contact: issues@sw
URL:
Keywords: oooqa
: 14629 14836 14871 14919 15489 (view as issue list)
Depends on:
Blocks: 14053
  Show dependency treegraph
 
Reported: 2003-04-02 02:41 UTC by Unknown
Modified: 2013-08-07 14:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Word document that crashes the word processor (180.50 KB, application/octet-stream)
2003-04-02 02:42 UTC, Unknown
no flags Details
valgrind stack traceback of ooo1.1beta1 on rh8. Wild pointer in PrintFontManager::getMetrics? (9.55 KB, text/plain)
2003-05-13 08:27 UTC, dankegel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-04-02 02:41:07 UTC
Attached is an MS Word document that crashes the word processor when I try to  
open it.  I am using Red Hat 8.0 with the 1.0.1-8 RPM's.  I have not tried to 
reproduce this with 1.0.2 or with the new 1.1 beta.
Comment 1 Unknown 2003-04-02 02:42:29 UTC
Created attachment 5405 [details]
Word document that crashes the word processor
Comment 2 dankegel 2003-05-13 08:25:15 UTC
I reproduced your problem on Linux with OpenOffice1.1beta1
under valgrind.  I'll upload the stack traceback next.
Thanks!
Comment 3 dankegel 2003-05-13 08:27:04 UTC
Created attachment 6169 [details]
valgrind stack traceback of ooo1.1beta1 on rh8.  Wild pointer in PrintFontManager::getMetrics?
Comment 4 h.ilter 2003-05-13 10:59:06 UTC
Reassigned to MRU
Comment 5 michael.ruess 2003-05-13 13:56:07 UTC
I was not able to reproduce the crash on my RedHat 7.2. But Dan's
stack is a kind of evidence... ;-) and this tells us, that it is not
to be found in the WinWord filter.

MRU->HDU: Can you see from the stack, what the problem might be?
Comment 6 hdu@apache.org 2003-05-13 16:38:16 UTC
psprint... 
Comment 7 philipp.lohmann 2003-05-14 17:46:24 UTC
problem does not exist anymore in current version; however i found a
side effect which while debugging: this would cause type1 fonts with
adjacent afm files not to be recognized.
Comment 8 philipp.lohmann 2003-05-14 17:48:33 UTC
fixed in CWS vcl10
Comment 9 philipp.lohmann 2003-05-20 18:09:16 UTC
*** Issue 14629 has been marked as a duplicate of this issue. ***
Comment 10 philipp.lohmann 2003-05-26 13:07:49 UTC
verified in vcl10
Comment 11 philipp.lohmann 2003-05-27 13:32:00 UTC
*** Issue 14919 has been marked as a duplicate of this issue. ***
Comment 12 philipp.lohmann 2003-05-27 13:32:58 UTC
*** Issue 14871 has been marked as a duplicate of this issue. ***
Comment 13 christof.pintaske 2003-05-27 14:25:57 UTC
*** Issue 14871 has been marked as a duplicate of this issue. ***
Comment 14 philipp.lohmann 2003-06-10 10:46:57 UTC
changes are in 645m4s1, closing issue
Comment 15 philipp.lohmann 2003-06-11 09:20:54 UTC
*** Issue 15489 has been marked as a duplicate of this issue. ***
Comment 16 philipp.lohmann 2003-06-16 16:20:03 UTC
*** Issue 14836 has been marked as a duplicate of this issue. ***
Comment 17 dankegel 2003-07-22 16:31:01 UTC
Adding keyword 'valgrind', since I seem to recall I needed to use
valgrind to track it down.
Comment 18 dankegel 2003-07-22 16:31:24 UTC
No, really.
Comment 19 hans_werner67 2006-08-08 10:52:10 UTC
remove keyword 'valgrind'