Issue 1304 - Using frames in header or footer
Summary: Using frames in header or footer
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 633
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-07-23 15:39 UTC by issues@www
Modified: 2013-08-07 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
example file in word with frames in header (24.50 KB, application/msword)
2003-12-06 14:52 UTC, issues@www
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description issues@www 2001-07-23 15:39:52 UTC
In word your able to place frame's defined in a header to be place anywhere on
the page. In Openoffice (633) (and staroffice 5.2) you can only place the
frame's within the margins (upper and lower). The reason for placing a frame in
the header or footer is to place the frame automaticly on every page.
We want to use Openoffice withing the company as a multiplatform office tool.
But the company template's use the frame methode heavily.
Comment 1 issues@www 2001-07-24 09:04:21 UTC
Created attachment 421 [details]
example file in word with frames in header
Comment 2 stefan.baltzer 2001-08-02 09:19:49 UTC
Reassigned to Michael.
Comment 3 michael.ruess 2001-08-02 10:14:31 UTC
What you used in your Word document aren´t frames; these are Textboxes from the
drawing tools. StarWriter is not able to use drawing objects in the headers,
because the page handling is much different from that in Word (the
implementation of this would be too extensive for us). 
If you want to use something similar, place the cusor in the header an choose
"Insert / Frame" from the menu. Then you have Frames repeating automatically.
Comment 4 michael.ruess 2001-08-02 10:15:32 UTC
Close, because it is not a bug; it is a well known restriction.
Comment 5 michael.ruess 2001-08-02 12:19:47 UTC
Reopened, because it´s an Enhancement suggestion.
Comment 6 michael.ruess 2001-08-02 12:28:45 UTC
MRU->FT: What the user wants, is a possibility to place a frame outside a header
or footer, where it remains anchored to the paragraph in the header/footer. 
At the moment, this is not possible in [Star|Open]Office.
This would also extend our WinWord-Import capacity.
Comment 7 issues@www 2001-08-02 13:00:15 UTC
In the current situation a frame attached to a paragraph in a header or a footer
can be placed between the left PAPER side and the right PAPER side and between
the top HEADER/FOOTER MARGIN and the bottom HEADER/FOOTER MARGIN.
I like to be able to place te frame between the PAPER top and PAPER bottom.
The check on left en right is already on PAPER level !
Comment 8 wimkok 2001-09-11 12:53:22 UTC
Are there more questions ?
Comment 9 falko.tesch 2001-09-17 10:19:04 UTC
Accepted
Comment 10 wimkok 2001-10-23 13:18:35 UTC
Is there any progres ?
I like to test te new feature.
Comment 11 Unknown 2001-11-08 23:11:42 UTC
changing QA contact from bugs@ to issues@
Comment 12 wimkok 2002-11-04 07:51:44 UTC
Problem is stil there even in 1.01

Comment 13 wimkok 2003-07-09 08:16:22 UTC
Is there already a decision about this enhancement

I know more than one company wich use the sideline on every page.
Comment 14 falko.tesch 2003-09-11 15:50:45 UTC
Good news: in 2.0 everthing will be fine!
We already fixed most of the problems in 1.1 and the "outside-header"
graphic position problem will be solved in 2.0.
Comment 15 bettina.haberer 2003-10-22 17:44:21 UTC
That has been implemented and is available in the newest version (1.1).
Comment 16 bettina.haberer 2003-10-22 17:44:40 UTC
Closed.
Comment 17 oblong 2003-10-23 13:20:48 UTC
I don't understand whether this is meant to saying that the issue is 
completed now (1.1), or whether it will be completed later in 2.0. 
If the latter, why is it closed?

Anyway, using 1.1rc5 I can't see how the issue is fixed. My 
understanding is that the problem was that a frame inserted into a 
header could not extend vertically above or below the limits of the 
header. It is possible for the frame to extend to the left or right 
of the header. The request is to have a frame anchored inside a 
header, with the frame allowed to be positioned, say, in the left 
margin, so that it will repeat on each page (because headers 
repeat). Maybe I'm missing something, though!
Comment 18 wimkok 2003-10-23 20:18:36 UTC
The enhancement is about placing a frame above or below the header or 
footer limmits like in Word.
Placing a frame outside the left and right borders is possible since 
SO 5.

In OO 1.1 it is NOT possible to place a frame above or below the 
header or footer margins. So i don't think there is a reason to close 
his issue.
Comment 19 bettina.haberer 2003-10-28 16:10:24 UTC
Sorry, I was too quick. The "outside-header" graphic position problem
is not yet implemented, that will happen in the OO.o 2.0. Please have
a look into the concerning product concept document (PCD-ID 20191). 

Comment 20 oblong 2003-10-29 00:15:48 UTC
So should the status remain as CLOSED FIXED then? Unless I don't 
understand Issuezilla (quite possible!), then I would have thought 
not.