Issue 13150 - Cross reference to abitrary paragraph formats
Summary: Cross reference to abitrary paragraph formats
Status: CLOSED DUPLICATE of issue 2593
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.0.2
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-04-08 07:07 UTC by warnerpj
Modified: 2003-09-08 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description warnerpj 2003-04-08 07:07:03 UTC
It would be great if the cross-reference dialog in OO would allow a reference 
to any paragraph style to be automatically created.

In FrameMaker, you can select a paragraph style (eg. Heading1 or Body etc) and 
the list of possible X-refs will include the first few words (and number) of 
all paragraphs of that style in the document. 

In the case of OO, it would be great if this could be done automatically, and 
then generate the appropriate reference point at the start of the paragraph 
along with the desired xref. Ideally these should be 'hidden' so that users 
could not see them and could not delete them by accident.
Comment 1 ingenstans 2003-06-01 12:44:58 UTC
This is a dupe of #2593. That does not mean it is invalid or less 
urgent. The issue has come up at least three times as a requested 
enhancement, and I think it should be seriously considered for 2.0.

Numbering and reference are two of the weakest points of writer at the 
moment; and they are also points were Word is vulneralbe. Turning 
writer into a better wp for long documents, with their fairly 
specialised demands, really ought to be a strategic priority. This is 
not the same as trying to turn it into a full-blown FrameMaker clone. 

But small improvmeents to things like the outline numbering and the 
cross refeences sytem couldmake a big difference to usability.


*** This issue has been marked as a duplicate of 2593 ***
Comment 2 h.ilter 2003-07-23 15:15:05 UTC
.