Issue 13573 - Various Matrix Issues
Summary: Various Matrix Issues
Status: CLOSED DUPLICATE of issue 5998
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.2
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: thomas.lange
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-04-18 00:41 UTC by cgranade
Modified: 2013-08-07 14:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description cgranade 2003-04-18 00:41:20 UTC
In the absence of an align= command that would work similarly to alignc, alignl,
etc., but align to the = sign in a line, I use a matrix similar to matrix {1 # +
# 2 # = # 3 ## 3 # - # 2 # = # 1} to align the = sign and the various operators
in a linear system. OO.o Math v1.0.2 reads that lone =, + or - as errors, and
corrupts the entire matrix. As a solution, I place {} around an operator, as in
{}={}. This solves the problem, however, the extra empty groups greatly reduce
the legibility of the code. Also, the space between the columns is far to large.
Comment 1 cgranade 2003-04-18 00:47:11 UTC
Sorry for the spelling error in the last line in the issue opening. It
should be far *too* large. Also, sorry for my rudeness in this
statement. I appriciate all the work you guys do. Really appriciate
it. Thanks.
Comment 2 thomas.lange 2003-10-22 15:45:03 UTC
I think the real solution would be something like a align command or
maybe a TAB command that can be used to justify the text.

That will be new though really(!) needed feature.
Also it must give some time what the best (most common) approach would
be. We do not only want the "=" charcacter aligned.
It should work at least with all the relational operators, and given
that why not work with any character?

But because it will not be an easy doing and given the time frame for
OOo 2.0 and my other tasks at hand I need to do the time for this is
missing.

Set target to OOo later.

TL->BH: To you for final decision.
Comment 3 guido.pinkernell 2003-10-24 10:52:32 UTC
.

*** This issue has been marked as a duplicate of 5998 ***
Comment 4 guido.pinkernell 2003-10-24 10:52:53 UTC
.