Issue 13829 - Sort Ascending (A>Z) Button use causes loss of formatting
Summary: Sort Ascending (A>Z) Button use causes loss of formatting
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.0.2
Hardware: All All
: P4 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
: 81969 82136 84598 94407 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-04-25 21:01 UTC by jkfly
Modified: 2013-08-07 15:14 UTC (History)
10 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Spreadsheet formatting loss example (5.02 KB, application/octet-stream)
2003-04-25 21:03 UTC, jkfly
no flags Details
Spreadsheet formatting loss example (5.02 KB, application/octet-stream)
2003-04-25 21:06 UTC, jkfly
no flags Details
patch to fix this (532 bytes, patch)
2008-12-25 07:02 UTC, kyoshida
no flags Details | Diff
TestCaseSpecification (11.04 KB, text/html)
2009-05-11 08:36 UTC, oc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jkfly 2003-04-25 21:01:55 UTC
In OOo 1.0.2, 1.1 beta, and in SO 6.0, use of the "sort ascending" button causes
loss of formatting in cells (cell formatting does not get reordered along with
the text in the cells).  However, going to "Data" then "Sort" instead of using
the A>Z button does NOT cause loss of formatting.  

Example: See the attachment--I made a column called "fruit".  In the column I
listed "banana" with a yellow background color, "apple" with red, and "orange"
with orange.  If one uses the sort ascending A>Z button, the fruits will
correctly be listed in alphabetical order but the background colors of the cells
do not get rearranged along with the respective text in these cells. However, if
one uses the "Data" menu then "Sort" and sorts by "fruit", the cell text and
background colors get reordered appropriately.
Comment 1 jkfly 2003-04-25 21:03:48 UTC
Created attachment 5894 [details]
Spreadsheet formatting loss example
Comment 2 jkfly 2003-04-25 21:06:00 UTC
Created attachment 5895 [details]
Spreadsheet formatting loss example
Comment 3 frank 2003-04-28 07:58:48 UTC
Hi Niklas,

1 4 u

Frank
Comment 4 niklas.nebel 2003-04-28 09:17:53 UTC
"Include formats" is a selectable option in the sort dialog. When
using the button, there is no dialog and a default has to be used,
which is "don't include formats". Without a very good reason, we can't
switch around such defaults between releases.
Comment 5 niklas.nebel 2003-04-28 09:18:10 UTC
closing.
Comment 6 frank 2007-10-01 14:19:14 UTC
*** Issue 82136 has been marked as a duplicate of this issue. ***
Comment 7 frank 2007-10-01 14:20:33 UTC
re-opened
Comment 8 frank 2007-10-01 14:21:34 UTC
added fl to cc list
Comment 9 frank.loehmann 2007-10-01 16:34:47 UTC
FL->NN: Default for sorting via Sort dialog has changed to included formats by
default. Therefore sorting via button has to include formats as well. Calc UX
candidate for 2.4?
Comment 10 frank 2007-10-25 07:52:55 UTC
*** Issue 81969 has been marked as a duplicate of this issue. ***
Comment 11 Rainer Bielefeld 2007-12-16 11:21:43 UTC
*** Issue 84598 has been marked as a duplicate of this issue. ***
Comment 12 Rainer Bielefeld 2007-12-16 11:23:26 UTC
*** Issue 84598 has been marked as a duplicate of this issue. ***
Comment 13 Regina Henschel 2008-09-29 17:07:16 UTC
*** Issue 94407 has been marked as a duplicate of this issue. ***
Comment 14 kyoshida 2008-12-25 07:02:22 UTC
Created attachment 59008 [details]
patch to fix this
Comment 15 kyoshida 2008-12-25 07:03:58 UTC
Perhaps this is so simple that it doesn't require a patch, but I'll throw a
patch in anyway.
Comment 16 frank.loehmann 2009-03-13 16:23:22 UTC
59745 regarding sorting of notes has been fixed for 3.1 so I think this one i
quite similar and should be fixed too. 3.2? 
Comment 17 niklas.nebel 2009-03-17 19:07:42 UTC
I added this to CWS "calc49".
Comment 18 niklas.nebel 2009-04-03 08:57:27 UTC
reassigning to QA for verification
Comment 19 oc 2009-05-11 08:36:10 UTC
Created attachment 62155 [details]
TestCaseSpecification
Comment 20 oc 2009-05-11 08:36:58 UTC
verified in internal build cws_calc49
Comment 21 amy2008 2009-06-01 07:52:19 UTC
Verified in DEV300m49 on WinXP. Works well
Closing