Issue 13965 - superscript character position misalignment (html)
Summary: superscript character position misalignment (html)
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 Beta
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-04-30 12:31 UTC by rmaris
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
sample Wordprocessor file from HTML-edit "save as .sxw" (7.73 KB, text/sxw)
2003-07-02 08:58 UTC, rmaris
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rmaris 2003-04-30 12:31:12 UTC
When using the OOo html editor with a superscript in a table cell, the text 
baseline of the rest of (non-superscripted text)remains unchanged, which is 
correct. However, when the html-file is stored and then opened again, the 
superscript appears too high, hence lowering the baseline. This is visible in 
comparison with horizontal adjacent text cells when any text is given there 
without superscripts.
This is a serious problem, when the html page must be imported into a standard 
sxw native format document. One must change the properties of all superscript 
characters in the document into "automatic" (format menu, character).
Comment 1 eric.savary 2003-06-30 18:12:18 UTC
Please add a sample doc (sxw)
Comment 2 rmaris 2003-07-02 08:58:35 UTC
Created attachment 7325 [details]
sample Wordprocessor file from HTML-edit "save as .sxw"
Comment 3 tamblyne 2003-11-01 19:39:21 UTC
Confirmed RH9/680m11

Steps to reproduce:  

1.  Create new HTML document; 
2.  Insert > Table > OK;
3.  Type "testing" in each cell across one row of table;
4.  Select a couple of letters in the word in the first cell;  
5.  Apply superscript:  Format > Character > Position tab > 
    Superscript;
6.  After this application, the letters are properly placed and the 
    remainder of the text in the other rows, and row height, is
    unaffected.  The base line of all text in the row is equal.  
7.  Save and close HTML document;  
8.  Re-open document.  
9.  The text in the first cell (where superscript is applied) has a 
    lower baseline in the row than the text in the remaining cells.  

The same behavior presents if subscript formatting is applied.  

This behavior is not present if same steps are applied to a text
document.  




9.  Note that the 
Comment 4 h.ilter 2003-11-03 09:48:40 UTC
Reassigned to ES
Comment 5 eric.savary 2003-11-07 18:03:03 UTC
ES->MIB: the "Automatic" option for Superscript get lost when exported
to HTML because HTML does not support this.
It's a typical case of a Writer UI offering more than what HTML can
do...see issue 19690

*** This issue has been marked as a duplicate of 19690 ***
Comment 6 eric.savary 2003-11-07 18:04:07 UTC
Closed
Comment 7 rmaris 2003-11-10 18:01:46 UTC
Eric,
this conclusion is not adequate. Please recall that the original text is written in the *html*-editor of OOo. So it may be expected that a document saved in the html-editor mode will reload without visual changes, here the baseline problem - which also appears as erroneous when the html-file is imported in the word processor.

I believe, the trouble can be avoided, when all superscript and subscript characters are (internally) assigned the automatic mode, and not any fixed mode, which causes the baseline problems.