Issue 14008 - Allow anchor settings in frame styles (graphic-styles)
Summary: Allow anchor settings in frame styles (graphic-styles)
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta
Hardware: All All
: P3 Trivial with 16 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: usability
: 19814 22015 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-05-02 02:11 UTC by bibhas
Modified: 2017-10-04 14:47 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bibhas 2003-05-02 02:11:42 UTC
The style editor dialog for a frame style does not include anchor settings.
Comment 1 prgmgr 2003-07-09 16:17:30 UTC
Thank you for using and supporting OOo.org.

Could you please list step by step instructions to get to the dialog
box you are referring to?
Comment 2 bibhas 2003-07-09 17:41:05 UTC
In the Styles floating window click on the Frame Styles tool bar to 
list all the styles applicable to a frame. Right click on any frame 
style and click on Modify. Click on the Type tab. Notice that there 
is no way to set the anchor properties of the frame, such as, anchor 
to page, to paragraph etc. You can't store the anchor properties with 
the style. After applying the style to a frame, you will need to open 
the properties dialog of the specific frame and set the anchor.
Comment 3 guido.pinkernell 2003-10-28 17:28:54 UTC
Confirming this as an enhancement.
Have rewritten summary accordingly.
Comment 4 stefan.baltzer 2003-10-29 13:39:59 UTC
SBA: Changed issue type to enhancement. Reassigned to Bettina.
Comment 5 lohmaier 2004-07-03 14:43:10 UTC
This would be handy if one could use Insert|Graphic with the style that has the
corresponding anchor set.
Right now you have to first insert the graphic and then modify the anchor.

Any chance for OOo 2.0?

(Platform, OS -> ALL)
Comment 6 lohmaier 2004-07-03 14:43:44 UTC
*** Issue 22015 has been marked as a duplicate of this issue. ***
Comment 7 goa103 2004-12-08 18:09:23 UTC
cloth, I think your request is related to issue 33184. I submitted a comment to
that issue about the problem I have to drag & drop objects from the gallery as
characters.
Comment 8 ceres 2005-03-17 09:06:10 UTC
I would point out that this is not really an enhancement but a missing part of
UI. The frame style DOES remember an anchor setting, which is derived from the
position settings when they are first displayed, and cannot be modified
afterwards except by some very unusual tricks.

In OpenOffice 1.1.4, when you create a new frame style and start in the
Organizer tab of the style editing dialog box, the Contains part of the tab will
be empty. When you switch to the Type tab, you will see selections in the
Position part of the tab that correspond to the last anchor setting that was
displayed by OpenOffice. When you switch back to the Organizer tab, the Contains
part of the tab will now contain an anchor setting (to page, to character, etc.)
derived from the position settings. There is no way to edit this setting.

Therefore, when somebody wants to create a frame style, they need to select
another part of the UI which displays anchor settings, select the proper setting
there (the UI will remember the settings of the drop boxes in the dialog box),
then create the frame style, switch to the Type tab of that style, and you will
get a frame style with the (hopefully) desired anchor setting.

Wanting to fix this really does not seem like a new feature request to me.
Comment 9 jdpipe 2009-06-27 15:24:42 UTC
It seems like a BUG to me that when using the picture properties, "Type" tab,
one sees completely different stuff when when editing the Frame->Modify
Style->Type tab.

If I can't use the styles editor to fix this, is there any way I can set OOo to
insert pictures "as character" by default?
Comment 10 rocco83 2009-11-12 17:18:59 UTC
Any news on that bug?

It is open since 2003...

Also i have the needing to set a style anchored as character.
Comment 11 paschuller 2010-01-26 15:57:19 UTC
I support the need to fix this issue. 

To encourage fixing, here an example where a working frame style would come in
very handy: Minutes of meetings often contain action items (AI). The minutes
have page layout with extra wide margin. A frame is place in this margin,
containing person's name who is in charge of that AI, anchored to the characters
"AI". The frame style contains eye catchers like borders, background etc.

Please requalify this issue as BUG and fix. Thank you!
Comment 12 bettina.haberer 2010-05-21 15:05:16 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 13 cno 2010-12-20 11:16:06 UTC
looks rather a defect indeed.
Comment 14 cno 2011-02-07 15:43:58 UTC
issue 19814 is basically the same as this one.
and issue 33184 is closely related.
Comment 15 cno 2011-02-07 15:44:33 UTC
*** Issue 19814 has been marked as a duplicate of this issue. ***
Comment 16 KG 2013-12-04 13:13:15 UTC
Any news on that bug?

It is open since 2003...

Inserting graphics into Writer document without this feature is piece of hell...
Comment 17 Alex 2014-02-27 17:56:41 UTC
g a w d
someone have to fix this
Comment 18 Patrick Hayes 2017-10-04 14:47:11 UTC
Among all the things that bug me the most about OpenOffice and that makes it an eternal "not good enough to replace MS Word", not being able to change the anchor as default for pasted graphics tops the list. The inability to do so in OO's GUI isn't a trivial bug, it's a show stopping usability bug that makes OO a PITA to use.

I'm a technical writer and inserting screen shots into documents is in the normal workflow of at least half my documents.

That this bug _STILL_ hasn't been fixed 14 years after it was declared makes me worry that it will never be fixed.