Issue 14070 - Setting the Preformatted Text in HTML editor
Summary: Setting the Preformatted Text in HTML editor
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta
Hardware: PC Windows 2000
: P4 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-05-04 15:07 UTC by bibhas
Modified: 2004-07-06 13:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bibhas 2003-05-04 15:07:57 UTC
In the HTML editor enter a few paragraphs. Change the style of one of the 
middle paragphs to Preformatted Text. The space between that paragraph and the 
next disappears. Everything looks OK after I close the file and reopen it.
Comment 1 prgmgr 2003-07-09 16:26:01 UTC
Thank you for using and supporting OOo.org

Duplicate on RH 9.0, OOo 1.1 Beta 2.

1.  Create a new HTML doc.
2.  Type 3 lines of text separated by carriage return.

    test

    test

    test

3.  Format the 2nd line as preformatted text.

    OOo.org render doc like

    test

    test
    test

4.  Save doc and reload as HTML.  Notice new rendering

    test

    test

    test
Comment 2 mci 2003-12-22 08:54:56 UTC
reassigned to es

Hi es, 
I think this may be something for you ...?
Comment 3 flibby05 2004-03-23 15:41:31 UTC
hi, tried to reprocude.
what is "Preformatted Text"?
sorry to be so ignorant,
Max
Comment 4 bibhas 2004-03-23 16:35:25 UTC
Preformatted Text is a paragraph style available in the HTML editor. I guess it 
represents the <PRE> HTML tag.
Comment 5 lc3 2004-06-23 19:35:21 UTC
Duplicated on Win XP Pro 2002 SP1, OOo 1.1.2
Comment 6 eric.savary 2004-07-06 13:43:48 UTC
Yes, "Preformatted text" corresponds to the <PRE> tag while "Text body"
corresponds to a simple <p> tag.
We have here a conflict between the Word processor rendering which sticks the
"Text body" paragraphs to the previous paragraph (because the spacing to top is
O.OO) and the Web editor rendering which displays the <P> tag as Browsers will
display it.
Indeed, when you use <p>, browsers always render those paragraph with one blank
paragraph space between them.
Thus this issue is duplicate of issue 19690

*** This issue has been marked as a duplicate of 19690 ***
Comment 7 eric.savary 2004-07-06 13:44:03 UTC
closed