Issue 14074 - Crash loading rtf document with many footnotes
Crash loading rtf document with many footnotes
Status: CLOSED DUPLICATE of issue 10826
Product: Writer
Classification: Application
Component: code
OOo 1.1 Beta2
All All
: P2 trivial (vote)
: ---
Assigned To: caolanm
issues@sw
: oooqa
Depends on:
Blocks: 14053
  Show dependency treegraph
 
Reported: 2003-05-04 16:24 UTC by matthewbrett
Modified: 2013-08-07 14:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
rtf document causing crash on loading for OO 1.1Beta (289.46 KB, application/octet-stream)
2003-05-04 16:27 UTC, matthewbrett
no flags Details
Symbolic stack dump on OOo1.1beta1 on Linux (6.01 KB, text/plain)
2003-05-07 05:53 UTC, dankegel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description matthewbrett 2003-05-04 16:24:35 UTC
The attached document causes OOo 1.1beta to crash with an "unrecoverable error"
when loading. Reproduced on Windows 2000 and Linux.  Also occurs with same
document in Word format.   Both versions load quickly in Word 97. 

This document loaded without error in previous versions of OpenOffice, but
locked up when scrolling through the document; see issue 10826
Comment 1 matthewbrett 2003-05-04 16:27:23 UTC
Created attachment 6024 [details]
rtf document causing crash on loading for OO 1.1Beta
Comment 2 dankegel 2003-05-07 05:53:42 UTC
Created attachment 6061 [details]
Symbolic stack dump on OOo1.1beta1 on Linux
Comment 3 ingenstans 2003-05-07 17:49:33 UTC
confirmed on 644_m11 under Windows 2k
Comment 4 h.ilter 2003-05-08 14:49:49 UTC
Reassigned to MRU
Comment 5 dankegel 2003-05-22 01:56:23 UTC
Still broken in beta2, same stack trace, in case anyone was wondering :-)
Comment 6 michael.ruess 2003-05-22 11:05:00 UTC
MRU->DVO: Please have a look, if this is to be found in the core or in
the filter.
The debug throws the assertion "Error: Pagedescs ueberindiziert"
before it crashes.
The document contains about 6000 Footnotes, for the case its of any
interest.
Comment 7 openoffice 2003-05-22 12:08:08 UTC
dvo->cmc: Likely a duplicate of #i10826#, at least the ww8 part of it.
Since you already fixed that, could you check this issue as well? Thanks.
Comment 8 caolanm 2003-05-22 12:24:47 UTC
Yes, its the same problem. Actually its the same document, one must be
the other resaved to .rtf again.

*** This issue has been marked as a duplicate of 10826 ***
Comment 9 caolanm 2003-05-22 12:25:33 UTC
We'll mark this one as closed, and follow issue 10826 for updates.