Issue 14348 - map point in numeric keyboard into decimal separator when are different
Summary: map point in numeric keyboard into decimal separator when are different
Status: CLOSED DUPLICATE of issue 1820
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta
Hardware: PC Windows 2000
: P1 (highest) Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
Depends on:
Reported: 2003-05-12 00:20 UTC by mmenaz
Modified: 2003-09-08 16:55 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description mmenaz 2003-05-12 00:20:35 UTC
Hi, in many countries (like mine, Italy, or Argentina, or others) the decimal
separator is "," (coma), while in then numeric keyboard we have "." (point).
This has historical reasons, anyway "clever" software always maps that key (".")
to the decimal separator, so we can do numeric data entry in a handy way (all
our programs, es. accounting ones, and M$ Excell or M$ calculator do that).
Unfortunately, OO calc does not map that key, so user experience with it is very
bad. Since mapping that key is a trivial thing in code, and the lack of that
feature is a big damage to the acceptance of OO here, please fix it soon!
Comment 1 frank 2003-05-12 08:48:37 UTC
Hi Marco,

it's a double to Issue 1820


*** This issue has been marked as a duplicate of 1820 ***
Comment 2 frank 2003-05-12 08:51:59 UTC
closed double
Comment 3 mmenaz 2003-05-12 12:13:13 UTC
Sorry for the duplication, your search engine is a nightmare. You must
simplyfy it, I don't know if you provide detailed istruction about how
to use it, the true thing is that it's not as easy as a google search
is, and people will not spent hours in figuring out how to use it.
I've tried to find some keyword, but I got no results. In addition,
having OO 1.1beta, not having this problem already solved seemd to me
that was because nobody reported it, since it's a realy fundamental
usability problem and a trivial fix.
Marco Menardi