Issue 14454 - [RFE] allow to bind image controls to text columns containing URLs
Summary: [RFE] allow to bind image controls to text columns containing URLs
Status: CLOSED DUPLICATE of issue 91310
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: All All
: P4 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: Frank Schönheit
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-15 08:32 UTC by Frank Schönheit
Modified: 2013-08-07 15:45 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2003-05-15 08:32:20 UTC
Currently, image controls can be bound to binary fields only ([[LONG]VAR]BINARY,
OTHER), which can contain an image stream.

It would be nice to have a feature to bind the controls to text fields
([[LONG]VAR]CHAR), which then could contain an URL of an image stream to load
(e.g. "file://...").

Shouldn't be too hard to implement - it would basically mean that the bound
control needs keep it's ImageURL property in sync with the content of the table
column it is bound to.
Comment 1 Frank Schönheit 2003-05-15 08:32:53 UTC
accepting and targeting
Comment 2 hans_werner67 2004-02-02 12:22:21 UTC
change subcomponent to 'none'
Comment 3 Frank Schönheit 2004-04-22 09:11:32 UTC
moving to later due to resource considerations (well, I'll try to find some
time, anyway, but it's not on the official "we want to have this for 2.0"-list
anymore).
Comment 4 ms2 2005-02-02 00:12:44 UTC
Not that I'm volunteering right now (spare time -2h/day ;), but:

To make this really easy to do, the experienced developers would do good in
adding some pointer to the involved sources.
Comment 5 Frank Schönheit 2005-02-02 07:26:40 UTC
I could do, however, the code in question has the habit of changing from time to
time. So, if I describe now what to do - in terms of methods to modify or
overload -, and next month, those methods have a different name - would it be
worth it?

So I think I wait until somebody volunteers, and then describe what's actually
to do. So as soon as your spare time situation changes, I'd be glad to give you
the pointers :)
Comment 6 Frank Schönheit 2008-11-05 13:34:27 UTC
Fixed meanwhile as issue 91310 for 3.1. Didn't know we already had an issue
requesting this.

*** This issue has been marked as a duplicate of 91310 ***
Comment 7 Frank Schönheit 2008-11-05 13:35:08 UTC
closing duplicate