Issue 14538 - autopilot forms for PostgreSQL have invisible fields.
Summary: autopilot forms for PostgreSQL have invisible fields.
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: recent-trunk
Hardware: PC Linux, all
: P3 Trivial with 1 vote (vote)
Target Milestone: OOo 3.2
Assignee: lars.langhans
QA Contact: issues@dba
Keywords: oooqa
: 22375 (view as issue list)
Depends on:
Reported: 2003-05-16 15:24 UTC by andremachado
Modified: 2017-05-20 10:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

simple form with invisible fields for PostgreSQL db (7.58 KB, application/octet-stream)
2003-05-16 18:59 UTC, andremachado
no flags Details
simple PostgreSQL schema for db used in the test (1.69 KB, text/plain)
2003-05-16 19:21 UTC, andremachado
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description andremachado 2003-05-16 15:24:10 UTC
I created forms using autopilot for a PostgreSQL db.
Tried both psqlodbc 7_02_003 and the newest 7_03_0100.
Using pg 7.3.2 running on cygwin (for concept demonstration).

When REOPENING saved forms, all but the first field are invisible!
Using form navigator, I can see that the remaining ones are there.
Clicking on blank areas shows the group limits, where the invisible fields are.
this behaviour happens even for the simplest db and form with only 2 fields (a
numeric and a varchar).
Also, happens for all form layouts OTHER than the default table/spreadsheet format.

This behaviour does not happens with MySQL forms.

I am trying to convince a company to leave M$-Office and Access in favor of
OpenOffice + PostgreSQL, but this behaviour will block this.

Please, give me a hint or a code solution. The time window is very narrow.

Andre Felipe Machado
Comment 1 Frank Schönheit 2003-05-16 16:01:10 UTC
can you attach such a broken document for evaluation?
Comment 2 Frank Schönheit 2003-05-16 16:22:34 UTC
sorry, but a target milestone of "next build" is not appropriate for a
bug which has not even been confirmed - resetting.
Comment 3 Frank Schönheit 2003-05-16 16:24:14 UTC
could not reproduce this with any of my tables in 1.0.3 - Andre, is
there something special about the tables you use, or something like
this? Can you describe the structure of a table which you use for this?
Comment 4 andremachado 2003-05-16 18:59:08 UTC
Created attachment 6227 [details]
simple form with invisible fields for PostgreSQL db
Comment 5 andremachado 2003-05-16 19:21:53 UTC
Created attachment 6228 [details]
simple PostgreSQL schema  for db used in the test
Comment 6 andremachado 2003-05-16 19:34:50 UTC
As you can see at the attached files, everything is simple.
nothing exoteric.
I would like to not loose this opportunity to introduce OO, Pg, and
Linux at the department of my new job.
A few minutes ago, a coleague told that a previous one tried 2 years
without success.
Now that the project I presented get the "OK" to start, I must
accomplish it in the narrow timeframe to get OO, Pg and Linux here.
Well, linux at least at the backend of the department.
The corporate lan is well another story...
Andre Felipe
Comment 7 andremachado 2003-05-16 20:29:56 UTC
I consistently reproduced the exact steps when the problem appears and
when it does not appear.

steps to create forms with invisible fields for PostgreSQL backend:
1) boot w98.
2) call OpenOffice with a blank page.
3) call autopilot > forms
4) create a simple form for the Pg db with more than 2 fields and with
a layout other than standart spreadsheet and standard background.
5) save and exit.

***** At this very moment, the PostgreSQL window shows a message:
NOTICE: Adding missing FROM-clause entry for table "pg_namespace" 

6) open the saved form.

***** At this very moment, the PostgreSQL window shows a NEW message:
NOTICE: Adding missing FROM-clause entry for table "pg_namespace" 

Now, from the second field onwards, all others are invisible.
they are still there, as showed by form navigator and by clicking at
the area.

Steps for NOT having invisible fields on forms for PostgreSQL backend:
1) boot w98
2) open a previouly created form for the same database. It will ask
for password and then connect.
3) call autopilot > forms
4) create a simple form for the Pg db with more than 2 fields and with
a layout other than standart spreadsheet and standard background.
5) save and exit.

***** At this very moment, the PostgreSQL window DOES NOT show any

6) open the saved form.

***** At this very moment, the PostgreSQL window STILL DOES NOT show
any new message.

Now, all fields are visible.

Maybe this behaviour is only at w98.

I hope this help.
Andre Felipe
Comment 8 Frank Schönheit 2003-05-20 08:08:16 UTC
fs->msc: still failing to reproduce this with the postgress
installation on clu-3111. Admittedly, I do not have Win98, but somehow
I doubt that it's a platform problem.
Do you have a chance to look at this?
Comment 9 marc.neumann 2003-05-20 12:32:16 UTC

I can't reproduce this, for me all fields are still there, no problems.
The only thing I can reproduce is the notice message in the Postgres

Bye Marc
Comment 10 thorsten.ziehm 2003-05-20 16:24:32 UTC
Works os is fixed in OOo 1.1 Beta2.
Comment 11 thorsten.ziehm 2003-05-20 16:36:51 UTC
closed ...
Comment 12 andremachado 2003-05-21 17:06:34 UTC
 Hello, Sir 
Yesterday, I executed more tests regarding this issue. 
I saw that the system load and memory used have direct connection to 
The more system load, more memory use, more swap, lead to the 
problem repetition. 
So, I deduced that there is some kind of time-out (hard coded?) 
affecting OO odbc communications with postgresql. 
This also could explain why you, using powerfull machines and better 
OS could not reproduce the problem. 
Andre Felipe 
Comment 13 Frank Schönheit 2003-05-22 08:10:42 UTC
somehow I don't believe that it's simply about performance - there
must be another difference -, but can you try to check this, Marc?
Andre, which version of OOo are you using (I suppose a spanish one?),
and where did you get it from?
Comment 14 andremachado 2003-05-28 11:54:49 UTC
Thanks for your attention. 
I am running the official brazilian portuguese 1.0.3 beta 4 translation (linked 
from to at w98 at an old Pentium 200 mmx. 
I can reproduce the problem, following the previously sent descriptions, all 
I really suspect there is something around performance issues and timings 
when used in low end machines and low end OS. 
Today I configured for dual boot with linux and will try to reproduce the 
problem in linux. 
Andre Felipe 
Comment 15 andremachado 2003-05-29 14:58:32 UTC
I tested OO 1.0.0 portuguese (portugal)  for linux and it WORKED. 
I was unable to test 1.0.1 portuguese, 1.0.1 brazilian portuguese, 1.0.2 and 1.0.3 
brazilian portuguese  for linux because of another error that crashes OO all times when 
form autopilot is called. 
Alread opened an issue for these. 
Best regards. 
Andre Felipe Machado 
Comment 16 andremachado 2003-07-18 20:35:13 UTC
I tested OpenOffice 1.1RC1 for linux and it has the same weird behaviour of 
opening saved forms with , now, invisible fields. 
Forms navigator shows that fields are part of document. 
By clicking over "invisible" fields area, one is able to select them! 
I hope this help to find the cause. 
Andre Felipe 
Comment 17 andremachado 2003-07-25 16:07:26 UTC
I contacted the team about this bug. 
Please, see the answer: 
> Ok, but the thing is the windows PG driver is not the one I distribute 
> its done by the Postgres folks, so if there is a common problem its more 
> likely to be in OpenOffice. 
The problem can be recreated with any table you create, with more than 13 fields 
when using OO 1.1RC1 for linux english, and unixodobc 2.2.6. 
When using OO 1.0.x and unixodbc 2.2.4, the problem pops up even with 2 fields. 
Please, try yourself. 
Andre Felipe 
Comment 18 marc.neumann 2003-12-11 13:59:04 UTC
I can reproduce this. When I click on the create button several times, then I
get a second save as dialog and when I save the form again I have broken fields.

set target and set to new.
Comment 19 mci 2003-12-18 14:54:38 UTC
*** Issue 22375 has been marked as a duplicate of this issue. ***
Comment 20 hans_werner67 2004-02-02 12:22:56 UTC
change subcomponent to 'none'
Comment 21 thorsten.ziehm 2004-05-26 14:34:56 UTC
Change the status to 'new' as MSC wanted.
Comment 22 thorsten.ziehm 2004-08-19 15:46:46 UTC
Because of limited resource for OOo2.0, it was decided to shift this tasks to
the next milestone. If somebody will be found, who can implement this until
OOo2.0, then this tasks will be re-targeted.
Comment 23 marc.neumann 2005-06-09 10:36:10 UTC

msc -> bc: 

Thsi still happend also with the new form wizard.

to reproduce:

- open biblio.odb
- start form wizard
- select all fields
- click next
- click next
- select the first layout
- click next until last page
- click twice on the finish button

==>> the form has no fields
Comment 24 berend.cornelius 2005-06-09 11:04:01 UTC
BC: This should be a general problem of all Java-implemented wizards. Double
clicking the finish button is not handled properly.
Comment 25 berend.cornelius 2006-05-19 16:34:12 UTC
bc: I think this should be fixed within a OOo2.x target, especially as all java
wizards are affected.
Comment 26 laura36 2006-07-18 02:07:25 UTC
I have the same or an similar behaviour - but I'm not shure if it's exactly the
same problem.

When I create more complex forms after a while (closing, reopening, editing)
some of the fields are not visible anymore in the form-editing-mode. When I
close the edit-function for using the form everything is all right. So using is
no problem, editing is. If I cut an unvisible field (to mark it is possible) and
paste it again it's visible again - but soon the next field disappear. 

I can reproduce this with 2.0.2 and 2.0.3, mysql 5.0, unixodbc 2.2.11, but it
doens't seem to depends on an specific database connection due to the fact that
the phenomenon also occurs when the form is disconnected from the database.

When I delete the configurations of openoffice in ~/.openoffice.org2 and
reinstall openoffice it appears for a short time a little bit better.

Is this the same Bug? Did anybody find a workaraound?

Comment 27 berend.cornelius 2008-01-21 09:54:24 UTC
bc: changing target to OOo 3.0
Comment 28 berend.cornelius 2008-06-16 14:54:09 UTC
resetting target to OOo.3.x
Comment 29 lars.langhans 2008-12-18 09:18:16 UTC
Finish Button can't press twice.
Comment 30 Frank Schönheit 2009-02-26 12:35:51 UTC
targeting to 3.2, since the fix is part of a CWS aiming for this release
Comment 31 lars.langhans 2009-02-27 10:32:20 UTC
please verify
Comment 32 marc.neumann 2009-04-15 13:28:03 UTC
reopen, now I get many java null pointer exceptions inside the terminal window
where I start the office, when creating a new form.
Comment 33 marc.neumann 2009-04-15 13:44:38 UTC
reassign back to lla. Please have a look on the exceptions
Comment 34 ocke.janssen 2009-04-16 12:10:35 UTC
Comment 35 marc.neumann 2009-04-16 14:04:41 UTC
verified in CWS dba32a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System: