Issue 15065 - Tools menu - duplicate hot key
Summary: Tools menu - duplicate hot key
Status: CLOSED DUPLICATE of issue 20057
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta2
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: matthias.mueller-prove
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-29 14:24 UTC by Unknown
Modified: 2013-08-07 14:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-05-29 14:24:13 UTC
Steps:

1) Open Writer
2) Drop open the Tools menu

Observed: Mail Merge and Macros both use "M" as the hotkey
Expected: No duplicates
Comment 1 dankegel 2003-06-04 04:15:55 UTC
Agreed.  Strongly suggest 'r' as hotkey for Mail Merge
to match what people are used to in other programs.
Comment 2 h.ilter 2003-06-04 11:10:10 UTC
Reassigned to EM
Comment 3 e.matthis 2003-06-05 11:03:39 UTC
Hi Dan

This hot key duplicate cycles through, so it works okay. There have to
be duplicates in many menus because there are not enough letters in
the alphabet to accomodate all the possible menu entries. e.g. "R" is
already used by "Sort" on the same menu.

I'm open to changing it to help the user feel more at home, but I
can't find a mail merge entry in MS that has the "R" mnemonic. Please
tell me which other programs you meant, so I can weigh the benefits of
a change (to yet another duplicate, just the same).

Thanks!
Liz
Comment 4 dankegel 2003-06-05 14:42:40 UTC
Hi Liz,
sorry, I should have been more specific and cautious!
I recommended the hotkey as I saw it in my copy of
Microsoft Office 97.  If more recent MS-Office uses
some other hotkey, that's probably a better choice.
And cycling's ok as long as it works, and users are used to it.
Comment 5 Unknown 2003-06-05 14:54:21 UTC
Just a user's opinion. (Well, not entirely a user--my job is writing 
database applications.) I don't think cycling is a good choice. When 
I look at a menu item and see a hotkey, I expect to press that hotkey 
for that item. I'm disconcerted when anything else happens. I've 
never used a product that cycled through hotkeys on a menu, and I'd 
view it as a bug.

Since no menu popup should have enough items to exhaust the alphabet, 
I think every item is entitled to its own hotkey.
Comment 6 e.matthis 2003-06-11 13:28:17 UTC
Thanks Dan and Tamar for your help! 
For 2.0 there will most likely be a change in the menu structure.
Hopefully that will give us enough letters so that each item can have
it's own hotkey, at least on this menu.

Dan, since you're owner, please set the target to 2.0 so we can
revisit this. Please also make me owner so I can watch this issue in
context with the others I have for 2.0 and make the adjustment. Thanks!
Comment 7 dankegel 2003-06-11 16:28:33 UTC
You got it.  (How'd *I* get to be owner? :-)
Comment 8 e.matthis 2003-06-12 13:43:54 UTC
OK, got it. Thanks Dan!
Comment 9 e.matthis 2004-05-24 14:20:32 UTC
Liz->MMP: please consider this in the course of the menu restructuring.
Comment 10 matthias.mueller-prove 2004-06-03 12:41:55 UTC
.
Comment 11 matthias.mueller-prove 2004-06-15 11:46:32 UTC
new summary
Comment 12 matthias.mueller-prove 2004-07-19 15:45:28 UTC
added mnemonic to
http://specs.openoffice.org/writer/mail_merge/mailmerge_specification.sxw
Comment 13 matthias.mueller-prove 2004-07-19 15:47:19 UTC
.

*** This issue has been marked as a duplicate of 20057 ***
Comment 14 Mathias_Bauer 2007-02-05 13:55:48 UTC
going to close ancient issues
Comment 15 Mathias_Bauer 2007-02-05 13:57:58 UTC
closing ancient issues