Issue 15374 - Changes in settings are not recognized
Summary: Changes in settings are not recognized
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta2
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2003-06-06 21:55 UTC by mkirchhof
Modified: 2013-08-07 15:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description mkirchhof 2003-06-06 21:55:50 UTC
After adding path to the list of template sources, they do not show up in selection boxes when 
creating new documents. 
How to reproduce:  
1) Open options dialog 
2) Add a path where some templates are stored (in my case, not on the top-level) 
3) close dialog 
4) Choose: File -> New -> Presentation 
5) AutoPilot shows up, select "from template" 
6) The recently added directories won't be displayed. 
(I use the german version of OOo, so the english names could differ.)
Comment 1 wolframgarten 2003-06-10 07:31:11 UTC
Reassigned to Christian.
Comment 2 christian.guenther 2003-07-01 08:31:07 UTC
set to new
Comment 3 christian.guenther 2003-07-01 08:31:54 UTC
I can reproduce the bug.
Please have a look.
Comment 4 clippka 2003-07-03 12:34:07 UTC
andré, ist that the autopilot or the template component?
Comment 5 groucho266 2003-07-04 09:14:17 UTC
Comment 6 groucho266 2004-04-14 15:14:44 UTC
The problem is that while iterating over the directory tree of the template
paths the root directories, i.e those specified in the template path list, are
skipped.  Only their sub directories are processed.  Is this a bug or a feature?
Comment 7 groucho266 2004-04-14 15:39:56 UTC
This is a general problem of our handling of the template files.  The
File->New->Templates and Documents dialog has the same behavior:
The paths specified in the Template path list are scanned for sub directories
and only those are scanned for template files.  Sub directories of the later and
template files on the top level are ignored.

A work arround for the original problem is to place a template file in a sub
directory of a path that is part of the template path list.
Comment 8 christian.guenther 2004-04-14 15:42:47 UTC
change the target
Comment 9 kassam_aly 2006-01-23 22:54:46 UTC
I reproduced the error with Windows 2000 and XP with OOo 2.0 and Linux 2.4.31
with OOo 1.1.0.  I used the following steps to replicate the error:

1.Open the option dialog box, using Tools->Options from the main menu.
2.Choose>Paths from the selections in the dialog box on the    
  left, then choose templates from the options in the dialog box on the right.  
3.Now click on the the Edit button, this prompts a new window listing the 
  selected paths.
4.Click Add and add a new path where some templates are stored.  
5.Then confirm all the changes by clicking OK on the selected paths window and 
  the options dialog box.
6.Now select File->New->Presentation.
7.The AutoPilot is prompted.  Of the three options here chose “From Templateâ€, 
  this shows a list of all the directories with templates and the new directory 
  doesn't show up. 

In addition I ran further tests to pinpoint where the error was occurring.

I created a subdirectory within the directory path which I created and stored
the template file in the subdirectory.  This is how OOo has its templates stored
so I attempted to mimic it.  This was a failure.

I also tried creating a subdirectory in an already existing path.  I stored my
template in this subdirectory.  OOo still did not pick up the template file.

Then I put my template file in the exact same file as the other template files
recognized by OOo.  This also did not work.

Finally, I moved one of the files, which OOo recognized as a template file, into
a different directory.  Then I tried to create an OOo presentation and selected
the removed template and OOo gave me an error. I then put my own template file
in the subdirectory and named the file the same name as the file I removed and
this worked.

So basically I had a file prs-strategy.otp in the directory:


which I replaced with my own template file and named the file prs-strategy.otp.
 The directory name may vary.