Issue 15379 - Add ability to resize inserted pics (save pics with reduced resolution)
Summary: Add ability to resize inserted pics (save pics with reduced resolution)
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 90 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa, rfe_eval_ok
: 15380 19084 26212 55061 68305 126504 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-06-07 05:30 UTC by bjohnsonoo
Modified: 2017-12-09 13:29 UTC (History)
15 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Import Picture Dialogue from Page Plus (42.98 KB, image/png)
2006-01-28 23:37 UTC, pesala
no flags Details
Example Compress and Cop Image Dialog from Excel (26.48 KB, image/png)
2009-05-13 09:42 UTC, slacka
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bjohnsonoo 2003-06-07 05:30:49 UTC
It looks like the default is to save the original pic with the file in it's
original size even if the object is shrunken to fit on the page or within the text

Is there (or could there be) an option that would allow the pic file size to be
automatically reduced on a file save to the size actually used in the document? 

We do a lot of pics in reports and having this as an automatic step (instead of
doing it prior to inserting the pic) would be really helpful, it would save
having to use an image editor and have new staff learn how to use
an image editor just to reduce pic size prior to inserting 

Maybe have this ability available in two spots, one as a (redefine image) button
on the toolbar so individual pics could be altered, and secondly, a checkbox in
the save as dialog (and/or as a user preference) to convert all of the pics in
the document
Comment 1 kelvine 2003-06-07 06:13:32 UTC
*** Issue 15380 has been marked as a duplicate of this issue. ***
Comment 2 kelvine 2003-06-07 06:15:24 UTC
Hi,

Marked issue 15380 as duplicate of this issue.

Kelvin
Comment 3 rblackeagle 2003-06-07 18:33:31 UTC
I would think this would be an improvement, but would like to see it
only as an option on Save or Save As, as I have a need for full-size
graphics but, when sending material to others, the full-size graphics
simply eat up too much bandwidth.
Comment 4 stefan.baltzer 2003-09-08 17:32:02 UTC
SBA: Reassigned to Bettina from the User Experience team for consideration.
Comment 5 guido.pinkernell 2004-02-14 23:14:21 UTC
.
Comment 6 lohmaier 2004-02-15 17:56:03 UTC
resize is misleading. change to crop.
Comment 7 kelvine 2004-02-15 22:00:15 UTC
Hi,

Just a bit of feedback on the change of the summary for this issue.

I think using the word crop in the summary completely changes the meaning of 
this issue as nothing has been mentioned about cropping pictures in the issue.

Crop is a specific function available in OOo. Resizing I tend to think of as 
the general resizing of the image by dragging the handles of the image or 
using the dialogue.

Issue 15378 is about providing the ability to store the cropped image in the 
document instead of the original image.

Hope this feedback helps.

Kelvin
Comment 8 lohmaier 2004-02-15 22:52:52 UTC
Ah, I see, sorry for that -> changing back.
But this RFE would mean changing the resolution of the source-image.
I certainly don't want OOo's wordprocessor to do that, and I think that this
will get closed wontfix, but I don't do the decisions...
Comment 9 kelvine 2004-02-16 02:36:40 UTC
Hi,

I appreciate your point of view and that is why I would like the feature to be 
an option. 

For example, the option to right click on a picture and adjust resolution for 
the resized picture. If I didn't select the option I would still want the Word 
Processer to keep the original picture as it currently in theory does. (Others 
from the comments in this issue would like to operate differently and a range 
of ideas is good.)

For myself (as a techo person) I nearly always create the picture close to 
what I want using products such as Gimp and then perform a minor resize if 
required. This takes a number of steps and thus takes time.

Example:
Picture from a digital camera (1600x1200 - 1.67MB) inserted into Writer 
document. Resize to a quarter of the original size and the resulting saved 
document is 1.67MB in size.

Picture from a digital camera (1600x1200 - 1.67MB), Resize and save using Gimp 
to a quarter of the size (400x300 - 39.8KB). Insert into Writer document and 
the resulting document is 39.8KB.

This is just for a single picture. Think about what happens when people insert 
5-10 pictures and how big the document becomes.

The document in the second instance is all that is required sometimes and 
saves enormously in transfer time and storage. (In my case I would always 
store the original image separate to the document so that it could be used in 
different ways.)

Whether it will be fixed or not is not a concern to me at least. It is after 
all a request for enhancement to be considered with the many ideas received. 

The productivity gain for end users by being able to perform such an action 
within the package is worth considering.

Thanks for your time. I hope this further information helps a little more.

Kelvin

Comment 10 bjohnsonoo 2004-07-24 04:11:38 UTC
I think kelvine has added a good explanation.

We use digital camera pictures in reports. The jpg from the digital camera is
usually around 400-600 kB

We routinely insert a number of pictures into the reports.

We currently reduce the resolution for the pics before adding them into the doc
so that the doc doesn't get too big (ie over 3 MB) .. but it would be convenient
to be able to skip that additional step and have the word processor do it for us.

Please note that I never asked it to be a default action.

I think an option that would apply to the current document only would be the
best solution.

I suggest that adding a checkbox to the saveas dialog be considered to flag the
current doc with reduced resolution pics.

I understand that oo.org includes a copy of the original image within the zipped
oo.org data file, so saving a reduced resolution image should not actually
affect the original source image.

Comment 11 elmede 2004-10-16 22:25:56 UTC
I couldn't agree more with this issue.

Here at work we handle reports which contain lots of pictures in them.  Right
now, we have to first resize the images to a size that is manageable and then
insert them to the report.  

The problem is that it's not always a first time to the solution situation. 
That is, sometimes some iterations are necessary to get to the desired result.

Storing the file isn't actually a problem because we all know storage is cheap
nowadays.  However, managing a 25 meg file (after pasting some 35 pictures) is
just impossible even with a decent machine

IMHO this would be a great option in Openoffice.org.  And now that we're talking
compatibility with MS-O, Word has exactly this option in the save-as dialog.
Comment 12 lohmaier 2004-12-07 21:03:25 UTC
reassigning, setting keyword according to new RFE-eval process.

(see summary)
Comment 13 lohmaier 2004-12-07 21:08:51 UTC
*** Issue 19084 has been marked as a duplicate of this issue. ***
Comment 14 lohmaier 2005-09-28 17:13:10 UTC
*** Issue 55061 has been marked as a duplicate of this issue. ***
Comment 15 bobharvey 2005-09-29 15:07:04 UTC
I made suggestion 55061 not for the Word Processor component but for the
framework.  I think this is even more of an issue in presentations than in
documents.
Comment 16 accentwd 2005-10-25 02:19:16 UTC
G'day all,

This is a very important issue, especially where the final result is to be 
included as website content, either HTML or as say a presentation.

Therfore it applies to not only Writer but virtually all components of OO.

First of all let me state that I have no time for Microsoft and a very, very 
big fan of OpenOffice.org . I would dearly love for more of my clients to use 
OpenOffice.org, also helping it to mushroom. 

Unfortunately Microsoft are ahead on the graphics resampling issue. Saving a 
document (created with Word) as HTML conveniently results in a sub-directory 
(sub-folder) with resampled versions of the images. It's then easy for even the 
least technically-minded of my clients who maintain their own pages with Word 
to upload the htm as well as the folder of resampled images. Microsoft also 
have an option in PowerPoint to resample inserted images, thus reducing the 
size of the presentation.

As digital camera images become bigger by default, and many users don't 
understand file sizes, adequate image resolution etc the problem is only 
getting worse.

Perhaps Writer etc should do the resample (down) automatically but could record 
the original image source location in case of the user wanting to resize the 
image up again at any point. Fair enough the original image would not be 
accessable if the document is emailed, uploaded etc but the document should in 
that case be layed out as the author intended for others to see it (ala PDF). 
The author would normally still have access to the original (and the recorded 
link in the source document to the original graphics file). At worst, if the 
graphics file was moved, the author would just have to re-insert it IF they 
wanted to resize upward again.

As someone else pointed out, this is a great opportuninty to get ahead of MS.


Ken Anderson,
Brisbane,
Australia.
Comment 17 pesala 2006-01-28 23:31:28 UTC
I think this needs some thought. There are obvious benefits, but also obvious 
problems. Every time an image is resized it gets degraded. What happens if the user 
changes his/her mind about how big the image needs to be on the page after resizing 
it? What if the user doesn't understand that the images need to be resized or how to 
do it? Let's try to make it automatic, but also easily reversible.

Maybe something along these lines could be made to work.

• If an image is more than a 100K (or a size definable in program options), a low 
resolution copy (96 dpi at the placed size) is automatically generated and embedded 
in the document for display purposes. This makes documents smaller, quicker to load 
and save, etc.

• If the user resizes a placed image, a new low-resolution image is generated from 
the original linked image and embedded in the document.

• If the linked image is missing when the document is loaded, a dialogue warns the 
user of this and asks if he/she wishes to browse to find it. It is then linked again 
from its new location.

• At print time, or when generating a PDF file, the user is offered an option to use 
the high resolution images or the low resolution (96 dpi) embedded copies. 

• Maybe we also need an option to change the default dpi for embedded low-resolution 
images. Some might want maximum speed so 48 dpi thumbnails would be good enough, 
while others might want to place images at 300 dpi ready for printing. 
Comment 18 pesala 2006-01-28 23:37:51 UTC
Created attachment 33649 [details]
Import Picture Dialogue from Page Plus
Comment 19 pesala 2006-01-28 23:45:05 UTC
The attached image shows the import picture dialogue from Serif Page Plus 11.
If the file is large, the link picture radio button is checked.
If the file is small, the embed picture radio button is checked.

"Place at 96 dpi" does not resample the image, it just resizes it on the page. If it 
1600 x 1200 pixels it will be placed at about 16" x 12"

Open Office could have an option to "Place at full resolution", but with "Place at 
xx dpi" as the default, were xx is the user's default setting. 
Comment 20 bobharvey 2006-07-16 22:16:37 UTC
I've just seen  pesala's suggestion from January - I think that is a fantastic
idea, and would really grab the headlines.  But, as I said above, this is not
just about WP but presentations, drawings, and spreadsheets too.
Comment 21 lohmaier 2007-06-05 12:16:18 UTC
*** Issue 68305 has been marked as a duplicate of this issue. ***
Comment 22 lohmaier 2007-06-05 12:16:52 UTC
*** Issue 26212 has been marked as a duplicate of this issue. ***
Comment 23 vossman77 2007-08-11 21:46:32 UTC
I think this should be assigned to a different component from "Word processor",
For example this feature is available from MS powerpoint:

http://www.dent.unc.edu/depts/admin/cedi/IT_files/Tutorial_Materials/CompressPPTimages.htm
Comment 24 yannoo 2008-02-02 04:28:32 UTC
Hi, I think this is a MAJOR need of OpenOffice because:
- Nowdays most of mailboxes can't send attached files bigger than 5Mo. 
- Current cameras and scanners usually make pictures bigger than 1Mo by default.
- In Office docs, people (nearly) never zoom on inserted pictures; inserted
picture resolution is just needed for printing or screen display.

First please have a look at MS Office's "Picture" toolbar (in Word  but also
Excel and Powerpoint):
http://mol-webdev4.princeton.edu/it/index.php?option=com_content&task=view&id=61&Itemid=36
In 2 clicks, you can optimize the size of ALL your inserted pictures!

I really think this possibility should be added in OO Writer, Calc and Draw.
I see 2 different ways to implement it:
(1) In the "Picture toolbar" like in MSoffice
(2) and as an option (or pop-up option) if there are more than 2Mo inserted
pictures when the user saves his document.


As Pesala accurately wrote in this thread, the resized picture gets degraded and
the user can change his mind: so what? Like for any other change, the user can
create a file backup! (ok to warn the user at 1st use).

Remarks: 
-Issue 15378 (compress cropped pictures) should be inserted in this topic, and
it is well processed by MS Office picture toolbar.
-A "crop" button on the "picture" toolbar like in MSoffice would be very
appreciated.

I hope this will help making OO better!
Thank you
Yann
Comment 25 slacka 2009-05-13 09:42:26 UTC
Created attachment 62229 [details]
Example Compress and Cop Image Dialog from Excel
Comment 26 slacka 2009-05-13 09:47:19 UTC
I agree with accentwd, that this feature should apply to all components of
OpenOffice, as either a save as or export option. Please refer to my attached as
example of how this is done in other Office Suites.
Comment 27 slacka 2009-05-16 12:57:56 UTC
This should be filed in the framework component. How can we request an admin to 
change the component tag?
Comment 28 richardschwarz 2009-07-25 00:07:08 UTC
It is the lack of this kind of thing which makes pushing for OOo in my school 
really difficult. I have trouble enough getting other teachers (or any staff for 
that matter) and students to resize images in MS Office (which is actually *really 
easy*) so having to teach them to resize images outside of the app? Ridiculous.

Really - we want to be a *great* office suite? Then we need to pay attention to the 
little things like this. Also - compressing images (like the -- I shudder to say it 
-- MS way) should be across the entire suite.

It's time we start thinking about the user experience and remember that a lot of 
people (read anyone who isn't a developer) don't want to have to think to do 
something that should be simple and intuitive.
Comment 29 bobda1st 2009-09-11 13:26:06 UTC
Recently (bah, a week ago), all the machines in the place I work in (30, more or
less ) changed from office to openoffice. In my department, Edition, we used
almost all the features Office gave concerning charts, tables and image
proccesing. Openoffice resulted to be a great tool for the work we do. It will
cost, course, because we change all concerning format: paragraphs, references,
heading, tables, charts, images, colours in tables and characters, and lots
more. The option of rezising images like word did would help me (and all my
department, course) to work faster and easier, because we don´t count with great
machines, and sometimes I have to manage files of 60 or 70 mb. It´s not a
negociable thing, because the other departments are not easy to argue with about
the image resizing before inserting in odt files.
And when you work with files sent from the outside of my company, there´s no
"resize-before-insert" option, specially when they are not even in openoffice
format. However, this is my particular case.
Comment 30 mr_smyle 2010-02-19 12:34:14 UTC
Also, if I use bitmap which dpi not set to 300 in bullets graphic it's size
greater than expected in Writer.
Comment 31 yannoo 2010-02-25 08:59:20 UTC
Does anybody know if it exists an OOo extension to resize inserted pics ?

(I recently saw there are some for issue 3545, image crop and rotation, for example)
Comment 32 yannoo 2010-02-25 09:05:53 UTC
FYI, there is this "Sun Presentation Minimizer" extension:
http://extensions.services.openoffice.org/en/project/PresentationMinimizer for
Impress.
Maybe it would be possible to adapt its source
(http://graphics.openoffice.org/source/browse/graphics/sdext/source/minimizer/)
to make it work with Writer ?

Comment 33 bigoud47 2010-05-06 12:03:51 UTC
save pictures with their attributes
Comment 34 bigbaka 2010-05-17 12:02:30 UTC
I agree that this is an issue that should be addressed if OOo is going to
seriously exist as an alternative to MS Word. Many people in the office write
reports and add pictures but do not know how to reduce picture image
resolutions. Even in MS office 2003 it is quite difficult to do and as a result
it is difficult to get less tech-savvy users to compress images in a document.
However, if using MS word at least I can always reduce after I receive reports.
Senior management has multiple offices and share reports between us by using a
yahoo mail group. However, max attachment is 1mb. Hence, reports need to have
images compressed before I can send to our management team. Including a
"compress resolution to screen 96 dpi / print 200 dpi" etc ala MS Word is a
must. Including in the picture toolbar would make things very easy. 
Comment 35 chrisjensen 2010-10-19 09:41:52 UTC
This issue was first raised in 2003.

The fact that this is a common issue across discussion boards, that there are duplicates of this, should 
be an indication that this is a needed feature.

As someone who has used and promoted OpenOffice.org to friends for ten years now, it makes me sad 
and embarrassed that this is not the first time I've discovered a request for a feature bogged down for 
years with discussions of "I don't need this, OOo isn't photoshop/firefox/eudora/linux".

Not everyone that uses OpenOffice.org is 'leet enough to save a picture, edit it, resize, save it, import it.

But even if they were, why should they, when their workflow could be copy, paste?
Isn't making things easier what the personal computer is about?
Comment 36 phochalbuse 2010-11-10 17:21:13 UTC
Created attachment 73458
Comment 37 stefan.le-du 2011-02-25 13:57:40 UTC
I'd like to vote for this issue but the vote link doesn't seem to work with me.

Anyway, I think this would be a very useful feature.

Even if not in the main software, it would be great to be able to add it as a plugin, like the Oracle Presentation Minimizer for Impress.
Comment 38 oooforum (fr) 2012-08-08 16:53:02 UTC
You can try PixCompress. 
http://extensions.services.openoffice.org/fr/project/PixCompress
This extension compress embedded pictures in your Writer documents.
Comment 39 Jonathan Heywood 2012-08-17 19:14:52 UTC
This is a really important issue to fix.  I provide support to a number of users who use Writer to document notes and photographs of sessions held with clients.  They add 30-40 pictures and being relatively naive users, they are unable to compress pictures before inserting.  As this about using the document on a daily basis over a two week period, it is important to be able to edit and add material.  At 30Mb the files become completely unusable.
Regards to all who commented.
Comment 40 Armin Le Grand 2012-08-20 10:11:40 UTC
ALG: Adding me to CC.
Comment 41 oooforum (fr) 2015-09-07 06:46:29 UTC
*** Issue 126504 has been marked as a duplicate of this issue. ***
Comment 42 openoffice 2015-09-07 10:29:53 UTC
I like the image compression function in libre office, works great, exactly what I am looking for in Open Office.
Comment 43 oooforum (fr) 2015-09-07 10:33:40 UTC
*** Issue 126504 has been marked as a duplicate of this issue. ***
Comment 44 openoffice 2015-09-07 10:37:40 UTC
Pix compress does not work it creat a file of 48mb, it was 10mb! 

The libre office image compression function creates a file of 8mb from 40mb...

It looks like an old request.. 

where is the santa wish list of AOO?
Can you put it on that list?
Comment 45 oooforum (fr) 2017-12-09 13:29:09 UTC
*** Issue 127627 has been marked as a duplicate of this issue. ***