Issue 16525 - Issuezilla mails not threaded
Summary: Issuezilla mails not threaded
Status: RESOLVED FIXED
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Website general issues (show other issues)
Version: current
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: CEE Rubicon
Assignee: Unknown
QA Contact: issues@infrastructure
URL:
Keywords: oooqa
: 66313 66787 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-07-07 09:11 UTC by mmeeks
Modified: 2009-01-19 13:30 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mmeeks 2003-07-07 09:11:33 UTC
One of the most useful features of issuezilla mail is the threading feature -
such that one can glup together all E-mail on an issue in a single thread.

This doesn't work with issuezilla, but works with eg. Gnome / Ximian bugzilla -
and is sorely missed. It should be _extremely_ easy to add an:

In-Reply-To: <bug-123456@bugzilla.gnome.org>

header in every mail - and this would have the desired effect - presumably this
is a minor template change somewhere - can we have it ?
Comment 1 pavel 2003-07-07 11:28:35 UTC
It would be useful to also not change the subject of the first (New)
e-mail:

pavel@linux:~> grep "^Subject: .* working sk_SK" Mail/OpenOffice
Subject: [sw-issues] [Issue 16527] New - Diacritics not working sk_SK
Subject: [sw-issues] [Issue 16527]  - Diacritics not working sk_SK

Comment 2 mmeeks 2003-08-05 13:24:07 UTC
Is there really no-one working on / triaging these bugs ? this should
be  a 2 minute template fix, my mailbox is getting more and more
unordered in the meantime ...
Comment 3 Martin Hollmichel 2003-08-05 15:35:34 UTC
mh->support: is there a possibilty to tweak issuezilla to get the
desired funtionality ?
Comment 4 Unknown 2003-08-06 21:17:55 UTC
Looking into this and referencing related internal issue, PCN 4278.
Thanks,
Kristen
Comment 5 Unknown 2003-08-06 21:37:11 UTC
Logged internal issue PCN 21311 requesting more information.
Comment 6 Unknown 2003-08-08 00:56:20 UTC
Updating status whiteboard with internal reference numbers.
Thanks,
Kristen
Comment 7 Unknown 2003-09-02 22:51:08 UTC
Update: This should be configurable by users with administrative 
permissions in IZ in SourceCast 2.6 (following the next upgrade) with 
the following steps.

IZ email notification is configure by following the path:

- select project
- select "Issue tracker" at bottom of left nav
- select "Configuration options" at the bottom of the list of 
available actions
- select "Edit email notification templates" from the middle of the 
Operating parameters actions
- select the email notification template to configure from the 
dropdown list
  Templates available are:
    - 'New/changed issue' notification template
    - 'Votes removed from issue' notification template
    - 'Issues untouched' notification template
- click the "Submit" button

From the email notification configuration page you can set the 
summary, reply-to, from, to, cc, and body contents based on a long 
list of available variables from the issue that the notification is 
sent about.

Action Plan: Marking this Resolved, Later in SourceCast 2.6.
We can review this once the staging server is available for testing.

Thanks,
Kristen


Comment 8 mmeeks 2003-09-03 09:43:48 UTC
Can you confirm that after nearly two months of contemplation, this
simple, single line template change simply cannot be done ?

Can you further confirm that in this hypothetical
wonderful-new-system-to-be that the default will still not be what
people want, but every developer will have to go through some umpteen
click gymnastics to set it up how it should have been initially?
Comment 9 Unknown 2003-09-04 22:15:58 UTC
When the staging server is available, this functionality can be 
tested by administrators of openoffice.org.
Thanks,
Kristen
Comment 10 stx123 2004-03-22 16:09:36 UTC
For technical reasons we have to move the issue to another subcomponent tan 'www'.
Sorry for bothering you with this generated notification message. There is no
need for any action from yor side.
Thanks for your understanding, Stefan
Comment 11 stx123 2006-06-28 11:31:14 UTC
*** Issue 66313 has been marked as a duplicate of this issue. ***
Comment 12 stx123 2006-06-28 11:31:49 UTC
*** Issue 66787 has been marked as a duplicate of this issue. ***
Comment 13 stx123 2006-06-28 11:32:25 UTC
The template provides no way to introduce a new header like in-reply-to.
But the subject is now the same for new and comment notifications. This should
allow mail clients to thread messages using the subject.
Comment 14 lohmaier 2006-06-28 11:41:53 UTC
resolved later issues are doomed to not being processed :-( 

Not sure how it is possible to modify the template (i.e what variables you can
use in there) - but maybe it is possible to put the In-Reply-To: line as the
very first line of the posting, making it act like a header?
Comment 15 Unknown 2007-03-13 11:12:51 UTC
Reopening this issue .
Comment 16 Unknown 2007-04-23 11:02:32 UTC
Updating whiteboard.
Comment 17 Unknown 2007-04-30 08:07:00 UTC
This is possible with the help of the new Discussion Service were we are allowed
to have custom header information for Mailing List/Discussion list .
Comment 18 Unknown 2009-01-19 11:35:49 UTC
CollabNet Support is currently reviewing the issues under Resolved-Later. If the
issues are fixed currently in any of the present CEE releases, then it will be
marked as Resolved-Fixed.

There might be a few issues which might not be in our future roadmaps which
might be closed as Wontfix unless it does not lie under any custom request.
Comment 19 Unknown 2009-01-19 11:36:29 UTC
This has been fixed in DS
Comment 20 stx123 2009-01-19 13:30:04 UTC
I assume we are talking about the Discussion Service in CEE 5.0 which was
codenamed Rubicon...