Issue 16759 - ability to format negative numbers with parentheses
Summary: ability to format negative numbers with parentheses
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 605
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-13 02:19 UTC by philmperry
Modified: 2003-09-08 16:55 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description philmperry 2003-07-13 02:19:36 UTC
Especially in financial work, it is often desired to format negative numbers
using parentheses () around them: e.g., -8 as (8), -$12.75 as ($12.75), -38% as
(38%). This would be independent of number of decimal places or color of the
text, and should work for all numeric formats. The minus sign "-" is simply
replaced by "(" and a matching ")" is added at the end. Note that this may be
US-centric formatting practice, and so might be locale-sensitive.
Comment 1 Regina Henschel 2003-07-13 09:56:59 UTC
It's already there. See in the help 'format codes'. I guess you need
#,##0.00;"("#,##0.00")"
Comment 2 oc 2003-08-08 11:41:30 UTC
Set to worksforme because feature is allready in the product
Comment 3 oc 2003-08-08 11:42:04 UTC
closed because feature allready available