Issue 17124 - hyperlinks destroyed, dataloss
Summary: hyperlinks destroyed, dataloss
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1 RC3
Hardware: PC All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0
Assignee: frank
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-07-19 15:53 UTC by Rainer Bielefeld
Modified: 2008-05-15 06:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document with destroyed hyperlinks (60.54 KB, application/octet-stream)
2003-08-07 17:18 UTC, Rainer Bielefeld
no flags Details
shows alert box (17.43 KB, image/png)
2003-09-11 12:29 UTC, Rainer Bielefeld
no flags Details
test kit, reproduces problem on my PC with 100% success (53.45 KB, application/octet-stream)
2003-09-12 15:13 UTC, Rainer Bielefeld
no flags Details
file with broken links as result of testcase (50.62 KB, application/octet-stream)
2003-09-12 21:29 UTC, andreschnabel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2003-07-19 15:53:16 UTC
I again and again have destroyed hyperlinks in my spreadsheets.

My first suspect under OOo 1.0.3.1 was that it had to do with Auto-Spellcheck
and "search and replace" in issue 9855, but I was not able to make that
reproducible. So I opened this new issue with a more general subject.

The effect:
From time to time links in my spreadsheets loose parts of the
folder-tree-structure in it.

Example for correct link:
file:///C:/Eigene%20Dateien/OpenOffice/Firma/PROJEKTE/0306_009/korr0609.sxw
destroyed link:
file:///C:/Eigene%20Dateien/Firma/PROJEKTE/0306_009/korr0609.sxw
You see that 'OpenOffice/' has gone lost.

In this spreadsheet I have several other similar hyperlinks with lost part 'Firma/'

My spreadsheet has been opened with 644m11 (seldom) and with 1.1Beta2, never
with 1.0.3.1.

Always all links are corrupted or no one.

I still have no Idea what might cause that dataloss. I can not make it
reproducible, but from time to time i find those corrupted links in my
(important and confidential) spreeadsheet.

Other issues for similar problems: issue  issue 9855,  issue 15327  

Any other users with this problem?

Rainer
Comment 1 Rainer Bielefeld 2003-08-06 06:04:18 UTC
Now I am quite convinced that the problem only appeared after I opened
a CALC-file with hyperlinks accidentally with 1.0.3!

No problems if I only use 1.1RC1

So --> WFM

Rainer
Comment 2 Rainer Bielefeld 2003-08-06 06:55:50 UTC
.
Comment 3 daniel.rentz 2003-08-06 12:36:22 UTC
Perhaps there is another problem. Please look at
Tools->Options->Load/Save->General->Store URLs
(Extras->Optionen->Laden/Speichern->Allgemein->URLs speichern). Is the
"in filesystem" checked? If yes, this is the problem.

Let's take your example. Your document is initially in
file:///C:/Eigene%20Dateien/OpenOffice/doc.sxw.
You insert a hyperlink
file:///C:/Eigene%20Dateien/OpenOffice/Firma/PROJEKTE/0306_009/korr0609.sxw.
While saving this URL is shortened to the relative URL
Firma/PROJEKTE/0306_009/korr0609.sxw,
because the "save relative" option is on. Now you move this file to
file:///C:/Eigene%20Dateien/doc.sxw
and reopen it. The relative URL is completed with the current path,
which results in the new URL without 'OpenOffice'. To fix this
problem, move the document to the old location, open it, change the
option in the Options dialog, and save again.
Comment 4 Rainer Bielefeld 2003-08-06 13:13:08 UTC
Hi Daniel,
thanks for your comment. I will do some further tests cncerning the
consequences of this checkbox, but I do not believe that that was my
problem, because I never moved the file with the hyperlinks or the
files where link points.

Rainer
Comment 5 Rainer Bielefeld 2003-08-06 16:40:26 UTC
I_get_some_crisis_today! :-((

I was absolutely sure that the problem was solved, but now it is back
with 1.1RC1 german!

Again all links in my example document are destroyed. I found
file:///C:/Eigene%20Dateien/OpenOffice/FIRMA/PROJEKTE/OpenOffice/Firma/ANGEBOTE/0305_010/korr0510.sxw
which must be
file:///C:/Eigene%20Dateien/OpenOffice/FIRMA/ANGEBOTE/0305_010/korr0510.sxw
Now OOo _added_ some paths into the hyperlink, as far as I see all
hyperlinks got an additional
"OpenOffice/FIRMA/PROJEKTE/"

I had activated the checkbox "save URL relative in file system" in
menu: Tools/Options/Load-Save/General, and no I will deactivate this
function in accordance to Comments From Daniel Rentz, but I co not
believe that that will save the problem.

Unfortunately my document is with confidential contents, so that I can
not attach it for further tests.

Rainer


Comment 6 Rainer Bielefeld 2003-08-06 16:41:13 UTC
Now it is absolutely sure that I did not open this document with any
other OOo build than 1.1RC1!

Rainer
Comment 7 Rainer Bielefeld 2003-08-07 17:17:59 UTC
I created a document without confidential condents.
Hyperlinks before 0305S008 are destroyed, later hyperlinks repaired.

I do not know whether this might be helpful to find the bug.

Rainer
Comment 8 Rainer Bielefeld 2003-08-07 17:18:54 UTC
Created attachment 8314 [details]
document with destroyed hyperlinks
Comment 9 Rainer Bielefeld 2003-08-23 10:20:13 UTC
Today I had it again with 1.1RC3., and still I am not able to make it
reproducible.

Rainer
Comment 10 frank 2003-08-25 12:13:59 UTC
Hi Rainer,

is it possible that you had some documents open which contain nearly
the same path. So one document in the base path, one document one or
two folders above and/or below the base path. 

So something like this :

/OpenOffice/Firma/PROJEKTE/  Basepath
/OpenOffice/Firma/     one above
/OpenOffice/Firma/test  one above and one deeper
/OpenOffice/Firma/PROJEKTE/test    one deeper


Maybe it has something to do with INetUrlObj in the code of the
Office. We are not sure, so please test it.

Frank
Comment 11 Rainer Bielefeld 2003-08-25 12:40:40 UTC
Hi,

yes, as far as I see I always had opened several other OOo files, all
with same start of path-structure C:\Eigene Dateien\  and most with 
C:\Eigene Dateien\OpenOffice\FIRMA\

I think your supect is very plausible.

Unfortunately until now I am unable to find our how I can enforce this
bug to make it reproducible. I will do some more intensive tests
concerning your suspect within the next 2 or 3 days.

Rainer
Comment 12 frank 2003-08-25 14:07:25 UTC
Thanks a lot.

Frank
Comment 13 Rainer Bielefeld 2003-09-02 13:37:22 UTC
Hi,

I still was not able to create a "reproducible bug set" for you, but I
have some news how I can one aspect of this bug on my PC.

Steps how I can reproduce the bug on my PC
0. I open several OOo- documents, one of them is the one which will 
   contain the broken links
1. I close all documents and exit OOo.
2. I use the WIN- Start- Function
   - START-button
     - DOCUMENTS
3. I select document 
   C:\Eigene Dateien\OpenOffice\FIRMA\PROJEKTE\0307_003\doku0703.sxw
   and so start OOo, what will show that document
4. I wait, until load progress (visible on OOo splash screen) is 
   app. 50%
5. again WIN- Start- Function
   - START-button
     - DOCUMENTS 
       for
C:\Eigene Dateien\OpenOffice\FIRMA\ORGANISATION\WichtigeDokumente.sxc

Now both documents will be opened, but the links in
"WichtigeDokumente.sxc" are destroyed.

Example: (Correct / destroyed)
file:///C:/Eigene%20Dateien/OpenOffice/FIRMA/DATENBANK/ADRESSEN/Adressen.sxc
file:///C:/Eigene%20Dateien/OpenOffice/FIRMA/PROJEKTE/DATENBANK/ADRESSEN/Adressen.sxc

All other hyperlinks in the document have the wrong additional "PROJEKTE/"


With the 2 mentioned documents the problem is more or less 100%
reproducible, but until now I was not able to find other combinations.

Rainer
Comment 14 Rainer Bielefeld 2003-09-02 13:39:29 UTC
Additional hints:

When I want to exit from OOo after reproducing the bug, OOo will not
ask me to save the changed document "WichtigeDokumente.sxc".


Rainer
Comment 15 Rainer Bielefeld 2003-09-05 06:45:20 UTC
I think reason for the bug in issue 19100 is the same as here.

Rainer
Comment 16 Rainer Bielefeld 2003-09-11 12:18:14 UTC
Still I am not able to create a testkit with reproducible results, but
I can add additional observations.

I had a destroyed link in a spreadsheet.

wrong:
file:///../WINWORKS.alt/FIRMA.DIR/PROJEKTE.DIR/0106_010/dok_06101.sxw
correct:
file:///C:/Eigene%20Dateien/WINWORKS.alt/FIRMA.DIR/PROJEKTE.DIR/0106_010/dok_06101.sxw

Funny thing, when I tried to correct the link I
- marked the text
- opened the hyperlink dialog
  a.m. destroyed link was shown
- I clicked to the "open file" button to browse for the file and to    
  find the correct hyperlink 
  expected: EXPLORE-window will open
  actual: an alert appears (pls see attached "/destroyedlink.png")

The mentioned file in the alertbox really does not exist. But why does
OOo ask me for that filename? The path 
C:\Eigene Dateien\OpenOffice\Firma\Finanzen\
Is a correct path on my PC, and some minutes before I found the
destroyed link, I opened a file in that correct path by clicking a
hyperlink in another OOo Document.

Rainer
          
Comment 17 Rainer Bielefeld 2003-09-11 12:29:39 UTC
Created attachment 9197 [details]
shows alert box
Comment 18 Rainer Bielefeld 2003-09-12 12:18:16 UTC
Hooray,

I think now I have the required testcase, pls see attached file
"test_destroyed_links.zip"

Steps to reproduce the problem are in accordance to  Comments From
RainerBielefeld 2003-09-02 05:37 PDT

Steps how I can reproduce the bug
0. unzip "test_destroyed_links.zip" ro C:\
1.  open all included OOo documents ),check the links (end of 
    document) and colose all files again.
2.  use the WIN- Start- Function
   - START-button
     - DOCUMENTS
3. select document "test0.sxc" and open with doubleclick
4. wait, until load progress (visible on OOo splash screen) is 
   app. 50%
5. again WIN- Start- Function
   - START-button
     - DOCUMENTS 
       for "test2.sxc"
       and open the file with doubleclick quickly before "test0.sxc"
       will be opened completely

Now both documents will be opened, but the links in
"test0.sxc" are destroyed.


With this method the problem is more or less 100%
reproducible on my PC. It will also work if you use the WIN EXPLORER
to open the files in step 2 and 5.

I increased Priority because this bug really is very annoying.

Questions:
- reproducible on other PC, OS ?



Rainer
Comment 19 Rainer Bielefeld 2003-09-12 13:12:35 UTC
I delete "Issue 17124 blocks issue 19100 in accordance to Comments
From Oliver Specht 2003-09-08 02:19 PDT in issue 19100 

Rainer
Comment 20 frank 2003-09-12 14:53:06 UTC
Hi Rainer,

I would be glad to check it if only the mentioned zip archive would be
there.

Could you attach it please ?

Frank
Comment 21 frank 2003-09-12 14:54:13 UTC
I take the ownership for this one and the moment.

Frank
Comment 22 Rainer Bielefeld 2003-09-12 15:13:57 UTC
Created attachment 9246 [details]
test kit, reproduces problem on my PC with 100% success
Comment 23 frank 2003-09-12 16:41:29 UTC
Hi Rainer,

I tried it 30 times. 20 on Win98 with a Pentium 256 MB starting OOo
via a netware connection and 30 times on an Athlon xp1800+ 512 MB
direct from the disk. In all cases I was not able to reproduce the
problem.

Can you tell me the configuration of your computer ?

I'm sorry and would thank you for all the power you have invested into
the investigation of the problem. Maybe other users from the QAdev
list can reproduce it.

Thanks

Frank
Comment 24 Rainer Bielefeld 2003-09-12 17:16:42 UTC
Hi Frank,

I made an additional test on an other WIN98SE computer (PIII, 400MHz,
256MB) and was able to reproduce the bug. But I found out an important
thing: it seems that it is only possible to reproduce the bug if
"Quickstart" is not active!

Rainer
Comment 25 Rainer Bielefeld 2003-09-12 17:22:50 UTC
My wife was able to reproduce it, too; it is nothing with my
forefinger ;-)

Rainer
Comment 26 andreschnabel 2003-09-12 21:28:16 UTC
Ok, I can confirm on WinXP, OOo 1.1RC4.

I followed the given descrition and could reproduce the broken links.
The "master key" is, that you have to open test2.sxc thile test0.sxc
is just about loading (the file, not the application).
It seems, that test0.sxc will be delayed, test2 will load and then
test0 will be loaded completetly (but the links got messed up meanwhile).

I'll attach the file.

I set Prio to 3, becasue these are (imho) *Very* special
circumstances. I would even lower to 4, becasue this is really easy to
workround: simply be aptient and wait for test0 to be loaded before
loading test2 .. or use the quickstarter. 
Comment 27 andreschnabel 2003-09-12 21:29:17 UTC
Created attachment 9257 [details]
file with broken links as result of testcase
Comment 28 gieschke 2003-09-13 00:39:49 UTC
I was also able to reproduce this on WinXP, RC4, German, with the same
observations (test0.sxc delayed, ...) as Andre.
Comment 29 dankegel 2003-09-13 07:26:12 UTC
Reproduced on Linux with the following script:

#!/bin/sh
set -x
rm -rf test
unzip test_destroyed_links.zip
cd test
~/OpenOffice.org1.1.0rc4-pre1/soffice test0.sxc &
sleep 7
~/OpenOffice.org1.1.0rc4-pre1/soffice test1/test2/test2.sxc 


You might need to adjust the sleep time; 7 seconds was what it took
to get the 2nd document to start loading when the 1st one
was half loaded for me on my dual 650MHz Pentium 3.

Good catch, Rainer!!
Comment 30 Rainer Bielefeld 2003-09-13 10:24:24 UTC
I was able to reproduce the problem with text documents, too. 
So Component -> Framework

By the way please let me remind: the biggest problem is not, that the
hyperlinks get destroyed if you go the the comlpicated way which is
necessary to reproduce the bug. The main problem is, that that damage
sometimes happens during quite normal work with OOo.

Rainer
Comment 31 frank 2003-09-15 11:30:47 UTC
Hi Mathias,

as discussed assigned to you.

Frank
Comment 32 Mathias_Bauer 2003-09-15 14:15:48 UTC
After reading the whole story, my impression is as follows:
If links are stored "relative", OOo makes them "absolute" on loading
time. As a reference for this process the URL of the documen is used.
Unfortunately the developers that implemented that many years ago used
a global variable(!) for this reference URL. It's easy to imagine that
this leads to a disaster if more than one document is loaded at a time.
I have the honour to coordinate the necessary rework, so I will keep
this bug as a wellcome reference. I don't expect that we can fix this
in a minor version, so I set the target to OOo2.0.
Comment 33 pgs 2003-11-18 01:20:16 UTC
I added votes for this because we got bitten this week by exactly this
with OOo 1.1, with members of our team truly puzzled.  One has spent
many hours rewriting his links... I gave him a workaround based on the
excellent diagnosis work here.
Comment 34 Rainer Bielefeld 2003-12-01 12:16:25 UTC
I found out that an other user operation causes the ugly problem: If
you use Menu: "File - Save All" (so that, as it seems, more than 1
document in time will be saved), the hyperlinks will be destroyed as
described. This makes it_very_ urgent to find a solution (I am quite
sure that the reason is the same as for the problem in the original
report) .

Rainer
Comment 35 Rainer Bielefeld 2004-09-27 18:28:16 UTC
There is some suspect in users@de.openoffice.org, that in global documents the
links to the sub-documents are affected by a similar problem, a user reported
the same damages in the path structure. Currently, there is no way to make that
reproducible, but may be you can check that while working on this issue, too?

As soon as I have more information, I will open a separate issue, if necessary.

Rainer
Comment 36 Rainer Bielefeld 2004-09-28 09:58:16 UTC
I created a separate issue 34705 for the "global documents problem" in comments
from rainerbielefeld Mon Sep 27 10:28:16 -0700 2004 

Rainer 
Comment 37 Mathias_Bauer 2004-10-28 10:24:55 UTC
The URLObject part is fixed. Now we must clarify that this was the real problem.
Comment 38 Rainer Bielefeld 2004-10-28 12:20:49 UTC
@mba: in what build the fix will be integrated?

Rainer
Comment 39 Mathias_Bauer 2004-11-05 15:21:40 UTC
Reopened for assignment to QA
Comment 40 Mathias_Bauer 2004-11-05 15:23:22 UTC
Frank, it would be great if you could verify the fix. :-)

@Rainer: if you or anybody else is interested in verifying the fix, we could
arrange that you can get an installation set of the CWS.
Comment 41 Rainer Bielefeld 2004-11-05 15:36:11 UTC
Yes, I am interested and would check that, if I can download an installation set.

Rainer
Comment 42 Mathias_Bauer 2004-11-10 08:43:09 UTC
Rainer, it seems that you want to have a Windows build. If you are fine with a
"NonProduct" version (it's much slower and shows a lot of assertions. As an
alternative, you could get a Linux "Product" version.

What's your choice?
Comment 43 Rainer Bielefeld 2004-11-10 10:56:12 UTC
I can test on WIN-XP or SUSE LINUX 9.0. The alternative causing least work for
qou ist the best one. 

Rainer
Comment 44 Mathias_Bauer 2004-11-16 17:25:22 UTC
Rainer, there is a Linux ("NonProduct") installation set available on
ftp.staroffice.de.
You need a password for downloading it, please send an e-mail to
Mathias.Bauer@sun.com and I give it to you.
Comment 45 frank 2004-11-18 15:26:52 UTC
finally I've found an Linux machine which allows me to re-produce this Issue
with an SO7. Testing cws sb19 I was not able to reproduce this behaviour. So I
set this one as verified fixed.

Frank

PS Rainer please comment on this one if you've got the Instset from Mathias.
Comment 46 frank 2005-01-25 13:36:37 UTC
fouund fixed on master src680m73