Issue 17155 - Strange handling of / in writer (line breaks after slash)
Summary: Strange handling of / in writer (line breaks after slash)
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 RC
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa
: 17269 17356 22872 24068 36038 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-07-20 23:15 UTC by jrh
Modified: 2013-08-07 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jrh 2003-07-20 23:15:59 UTC
Today I was trying to enter the text:
(i.e. the Japanese demo pages) and can be found on the file system under
/usr/local/apache2/htdocs/JPN.

Writer splits the line _after_ the first /, which destroys the formatting of the
path. In Writer it looks like:

(i.e. the Japanese demo pages) and can be found on the file system under /
usr/local/apache2/htdocs/JPN.

Without reformatting the paragraph such that the path occured in the middle (no
danger of wrap) it was not possible to achieve a sane rendering. I appreciate
writer must have some special rules for splittng lines on /, but in this case,
they don't work too well.
Comment 1 lohmaier 2003-07-27 14:23:14 UTC
*** Issue 17356 has been marked as a duplicate of this issue. ***
Comment 2 lohmaier 2003-07-27 14:23:35 UTC
*** Issue 17269 has been marked as a duplicate of this issue. ***
Comment 3 lohmaier 2003-07-27 14:27:23 UTC
extended summary, confirming, setting target-milestone, adjusting
priority.
Comment 4 h.ilter 2003-07-28 15:46:29 UTC
Reassigned to US.
Comment 5 ulf.stroehler 2003-07-29 09:14:00 UTC
us->fme:
reproduction is easy even if you don't have the mentioned document:
type some dummy text that covers aprox. half a line followed by a
blank. Than type a (long) path that forces linebreak.
The break happens after the first slash. 
That does not look very nice.
Wordbreak iterator? 
Comment 6 frank.meies 2003-08-04 08:33:18 UTC
FME: Yep. Breakiterator issue.
Comment 7 number5 2003-08-04 10:45:01 UTC
For one of the duplicate issues, I created a demo document
(http://www.openoffice.org/issues/showattachment.cgi?attach_id=7997).

I'd like to suggest that all leading single hyphens, slashes etc.
should stick to the following word in any case, since this is very
very likely the intended behaviour.
Comment 8 karl.hong 2003-08-08 19:45:33 UTC
Make slash and hyphen as part of word when doing line break in line 
breakiterator rule.
Comment 9 karl.hong 2003-09-09 23:28:31 UTC
Verified in cws i18n08.
Comment 10 karl.hong 2003-09-09 23:43:32 UTC
reassign to QA.
Comment 11 oc 2003-09-12 10:45:17 UTC
Reassigned to correct owner
Comment 12 Unknown 2003-10-13 21:05:37 UTC
This bug appears in Presentation too.
Comment 13 stefan.baltzer 2003-10-24 12:06:57 UTC
SBA: Verified in CWS i18n08. Slash is taken to the next line in Writer
and Impress now.
Comment 14 stefan.baltzer 2003-10-24 12:07:54 UTC
SBA: Set to "Verified"
Comment 15 stefan.baltzer 2003-10-27 16:08:53 UTC
SBA: Target changed to OOo 2.0 as this is the "destination" of the CWS. 

I think that fixing this P4 issue for OOo 1.1.1 is a "nice to have"
(as ALL bugfixes are!) but this one doesn't meet the scale (or
condition) that we have for issues that should make it into a Product
patch/update like OOo 1.1.1 (resp. the corresponding StarOffice 7 PP1) is.
Comment 16 lohmaier 2004-01-04 22:00:02 UTC
*** Issue 24068 has been marked as a duplicate of this issue. ***
Comment 17 stefan.baltzer 2004-02-20 16:39:03 UTC
*** Issue 22872 has been marked as a duplicate of this issue. ***
Comment 18 stefan.baltzer 2004-04-26 21:42:19 UTC
SBA: OK in Build 680m34. Closed.
Comment 19 lohmaier 2004-10-24 15:12:47 UTC
*** Issue 36038 has been marked as a duplicate of this issue. ***