Issue 17245 - Delete columns may delete two columns
Summary: Delete columns may delete two columns
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 RC
Hardware: PC All
: P3 Trivial with 16 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
: 9915 44620 50591 65248 65765 78094 86093 89964 102076 (view as issue list)
Depends on: 17239
  Show dependency tree
Reported: 2003-07-22 15:00 UTC by sq
Modified: 2013-08-07 14:44 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

bugdoc with instructions inside (5.75 KB, application/octet-stream)
2003-11-10 16:22 UTC, guido.pinkernell
no flags Details
Another table failing. (6.88 KB, application/vnd.sun.xml.writer)
2006-05-10 13:42 UTC, luisllana
no flags Details
a document with a table from which a single column cannot be deleted (12.88 KB, application/vnd.oasis.opendocument.text)
2009-04-28 20:09 UTC, skelem
no flags Details
can you find a column in this table? (9.15 KB, text/plain)
2009-05-29 21:58 UTC, fyva
no flags Details
select cell in any column and attempt to delete the column (11.14 KB, application/vnd.oasis.opendocument.text)
2009-09-24 13:33 UTC, neilwalkinshaw
no flags Details
example of bug in 17245 (8.57 KB, application/vnd.oasis.opendocument.text)
2009-10-27 02:33 UTC, scot23
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sq 2003-07-22 15:00:16 UTC
The attempt to delete one column of a table results in also deleting an adjacent
After this the cursor is placed outside of the table.
This behaviour was observed in a table having merged cells.

I think this issue is related to #17239 in that the surplus deleted cells were
these which would be selected accidentically when attempting to select the column.

Another behaviour which was observed is that the column is deleted correctly but
then the structure of the merged cells was not retained.
Comment 1 utomo99 2003-09-17 10:09:11 UTC
Please explain more about your problem, your information is not enough 
to investigate the problem.

Please try to find way how to reproduce the problem. if your problem
only sometimes happend we have difficulty to confirm it is real
problem or not. Please come back with more information. Thanks
Comment 2 sq 2003-09-22 15:13:17 UTC
See new attachment to Issue 17239 (id=9567)
Comment 3 utomo99 2003-11-04 10:21:17 UTC
Please explain step by step how to reproduce the problem. thanks
Comment 4 sq 2003-11-04 13:47:51 UTC
 - Download latest attachment for issue 17239 and open it with OpenOffice
 - Click into merged cell E2/3 containing "Stop selection here"
   or E4/5
 - Do "delete column"
 - Column E vanishes but also (accidently) does column F

BTW: I voted for this issue (and got e-mail on changes) but it shows 0
Comment 5 guido.pinkernell 2003-11-10 16:17:31 UTC
Can confirm this with the attached bugdoc, and from scratch, with OOo
1.1.0(en) on Win98.

sq, if an Issue needs an attachment please attach it and do not refer
to the bugdoc of another Issue, even if it´s identical. And, if it is
a sxw file, choose application/octet stream as file type. This time I
do it for you.

As to your votes: Click on "My votes" on top of this (or other) pages
after you've logged in, to check whether your vote has been recorded
with the right Issue number.
Comment 6 guido.pinkernell 2003-11-10 16:22:28 UTC
Created attachment 11112 [details]
bugdoc with instructions inside
Comment 7 h.ilter 2003-11-11 09:45:02 UTC
HI->FME: Cursor Position info is also wrong. New Task?
Comment 8 frank.meies 2003-11-11 11:22:10 UTC
FME: Looks like a rounding problem in lcl_FindStartEndCol during the
calculation nSX. Does not occur with small amount of columns.

FME->HI: No, the cursor position info is not wrong. The cell names
shown in the status bar match the actual table structure.
Comment 9 frank.meies 2004-01-05 07:55:34 UTC
Comment 10 okapi1253 2005-03-07 16:44:59 UTC
This is still present in 1.9.79. Though occasionally it actually seems to work
correctly. I've also seen this kind of situation delete the whole table
occassionally. Can this issue be retargeted for 2.0 since the later decision was
made back in 2003?
Comment 11 michael.ruess 2005-05-26 14:33:53 UTC
*** Issue 44620 has been marked as a duplicate of this issue. ***
Comment 12 michael.ruess 2005-06-14 10:56:28 UTC
*** Issue 50591 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2006-05-10 13:09:51 UTC
*** Issue 65248 has been marked as a duplicate of this issue. ***
Comment 14 luisllana 2006-05-10 13:40:49 UTC
This issue is still present in 2.0.2 version.
Comment 15 luisllana 2006-05-10 13:42:36 UTC
Created attachment 36373 [details]
Another table failing.
Comment 16 michael.ruess 2006-05-25 14:26:29 UTC
*** Issue 65766 has been marked as a duplicate of this issue. ***
Comment 17 michael.ruess 2006-05-25 14:38:42 UTC
*** Issue 65765 has been marked as a duplicate of this issue. ***
Comment 18 avagula 2006-05-25 14:44:49 UTC
mru: are you sure that 65766 is a dupe of this issue? I agree that 65765 (mine)
is the duplicate, but 65766 seems totally different?
Comment 19 michael.ruess 2007-06-05 08:53:43 UTC
*** Issue 78094 has been marked as a duplicate of this issue. ***
Comment 20 alownie 2007-10-21 21:59:48 UTC
I've never had this problem before, but in OOo 2.3.0 am getting a column delete 
removing whole table when a merged cell exits across all columns. In previous 
versions this has worked fine for my WinXP/Vista systems. Can't see anyone else 
reporting this effect though...
Comment 21 michael.ruess 2008-02-15 15:06:44 UTC
*** Issue 86093 has been marked as a duplicate of this issue. ***
Comment 22 kpalagin 2008-04-30 18:08:06 UTC
5 year old issue with 7 duplicates and still not fixed.
Any chance for 3.x?
Comment 23 Mathias_Bauer 2008-05-02 15:28:54 UTC
I agree that the duplicates (not the age) of this issue are an indication that
we should promote its target to avoid that it falls into oblivion (2500 issues
on "OOoLater" and without target - sigh). 
Comment 24 michael.ruess 2008-05-26 14:28:29 UTC
*** Issue 89964 has been marked as a duplicate of this issue. ***
Comment 25 skelem 2009-04-28 20:07:12 UTC
Please fix this.  I have attached (or will, after this page has been submitted)
a document with a table for which I can find no workaround for what I need done.

There are merged cells in the first two columns. I'm not trying to delete
anything in the first two columns. If you click in the headers for columns 3
through 9 (labeled A through G), then that column and the one to the right are
deleted! I need to delete only one, not both, of columns A and B. There doesn't
appear to be any way to do that!

How can I turn out a professional-looking document with extra blank columns in
it? How can this bug have no resolution for SIX years?
Comment 26 skelem 2009-04-28 20:09:10 UTC
Created attachment 61870 [details]
a document with a table from which a single column cannot be deleted
Comment 27 michael.ruess 2009-04-29 08:01:45 UTC
*** Issue 9915 has been marked as a duplicate of this issue. ***
Comment 28 michael.ruess 2009-05-20 12:44:41 UTC
*** Issue 102076 has been marked as a duplicate of this issue. ***
Comment 29 kpalagin 2009-05-22 10:48:21 UTC
please consider this 6 year old bug with 12 votes and 10 duplicates for 3.2.

Thanks a lot for your attention.
Comment 30 fyva 2009-05-29 19:49:58 UTC
This is not a clear bug. A table with merged cells can't have exact columns and
rows. Such tables should be edited with mouse, and cells are to be deleted by
merging with another cells. When you select a column, you select not an exact
column, but a column defined by the first row cell. For example, one cell can be
so wide that it covers a few cells in the lower rows. In the dialog for columns,
there is no clear columns, but just the cells of the first row. And the widths
are just the widths of the first cells. This is why only the first cells with
equal widths are resized by this dialog. This is not a bug. Maybe it just looks
 like a bug, because the dialog continues to claim that it is the column width,
but there are merged cells already and no definite columns or widths.
Comment 31 macias 2009-05-29 20:08:39 UTC
> cells are to be deleted by merging with
> another cells. 

User does not want to delete other cells (adjacent column). Such UI would be a 
joke really.
Comment 32 fyva 2009-05-29 20:59:07 UTC
For tables with merged cells, there are no columns or rows, there are only
cells. When you select a few cells and click "delete row" or "delete column",
you can't delete neither a row nor a column (there are no rows, no columns), you
can either delete the whole table or merge the cells with right, left, upper or
lower cells, by your choice, because each cell have 4 adjacent cells.
Comment 33 fyva 2009-05-29 21:10:40 UTC
Sorry, I was wrong. Each cell can have a lot of adjacent cells. This is a lot
more complicated.
Comment 34 fyva 2009-05-29 21:58:07 UTC
Created attachment 62646 [details]
can you find a column in this table?
Comment 35 chemtech 2009-07-27 14:53:09 UTC
This issue is still present in OOo-Dev_OOO310_m15 version.
Comment 36 neilwalkinshaw 2009-09-24 13:33:04 UTC
Created attachment 64931 [details]
select cell in any column and attempt to delete the column
Comment 37 neilwalkinshaw 2009-09-24 13:34:24 UTC
The bug does not merely cause adjacent columns to be deleted, it can cause the
entire table to be deleted. See attachment column-delete-failure. 
Comment 38 scot23 2009-10-27 02:31:02 UTC
I have this problem too and have an example to upload
Comment 39 scot23 2009-10-27 02:33:51 UTC
Created attachment 65644 [details]
example of bug in 17245
Comment 40 compkupleiplet 2010-11-10 16:33:09 UTC
Created attachment 73215