Issue 17439 - Landscape Printing to HP DeskJet 970CXi
Summary: Landscape Printing to HP DeskJet 970CXi
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stephan_schaefer
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-07-26 17:25 UTC by peterhb
Modified: 2004-03-03 12:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Minimal dummy test file (7.56 KB, application/octet-stream)
2003-08-13 22:07 UTC, peterhb
no flags Details
Minimal dummy test file (6.89 KB, application/octet-stream)
2003-08-13 22:09 UTC, peterhb
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description peterhb 2003-07-26 17:25:08 UTC
Using an HP 970CXi DeskJet printer in double-sided printing mode results in a
landscape orientated spreadsheet being printed in portrait orientation with all
output condensed to fit the page. Printing in single-sided mode is correct. This
problem is manifest with single or multiple page output.

Exporting to PDF and printing via Adobe Reader allows correctly orientated
printed output, as does saving the file as an MS Excel 2000 document and
printing via Excel, although a separate issue, not yet reported, prevents the
latter option being viable.
Comment 1 peterhb 2003-08-01 20:39:29 UTC
Just to close the loop, the separate issue alluded to in the original
issue report is 17440. Now that that issue has been resolved Excel
export becomes a technically viable option, but who wants to use Excel
as an output option for native OOo files:-)

Come on guys, this looks like a mis-read of the printer metrics and
should be easy to fix, pretty please.
Comment 2 frank 2003-08-07 10:54:38 UTC
Hi,

I wasn't able to reproduce this. As no other people seem to have such
problems, I have to close it as worksforme.

Maybe it's a problem with your printer driver. 

If anybody out there could confirm that this is happening, then feel
free to reopen this Issue.

Best regards and Sorry

Frank
Comment 3 frank 2003-08-07 10:54:56 UTC
closed worksforme
Comment 4 peterhb 2003-08-10 13:20:28 UTC
I'm sorry to hear you can't identify the bug. There is a high
probability that it is in OpenOffice.org, rather than in the printer
driver, as ALL my current software functions correctly with the sole
exception of OOo.

As my original issue report made clear, exporting to Excel, or PDF
format enables me to achieve the desired result and I rather hoped
that the humiliation of having to use Excel as an output filter for a
far better product would encourage a fix!

Let's hope that some other users hit it soon and provoke a re-think.
Comment 5 frank 2003-08-11 11:05:30 UTC
Hi,

have you tried OOo1.1rc2 ?

If so, please attach a document that prints out in the false way.

Also what's the printer driver used and there can we get it ?

Frank

PS. Please let this Issue stay as worksforme. If we can reproduce this
behaviour, we will re-open it.
Comment 6 frank 2003-08-11 11:06:28 UTC
closed worksforme
Comment 7 peterhb 2003-08-13 22:07:44 UTC
Created attachment 8442 [details]
Minimal dummy test file
Comment 8 peterhb 2003-08-13 22:09:52 UTC
Created attachment 8443 [details]
Minimal dummy test file
Comment 9 peterhb 2003-08-13 22:24:54 UTC
I am using RC2; I reported the bug before it was released. Please
assume that I'll always re-test a bug against the current version
before continuing the issue (too long in software development myself!)

To confirm why I think the bug is in calc: a similar file created in
writer prints correctly and I assume that all OOo modules use a common
print output routine (??). The spreadsheet is only a membership list
and could have been created with either component - I just prefer
calc. Attached are two minimal, dummy files of similar content: the
calc file exhibits the bug symptoms, the writer one does not.

To answer your question about the printer driver, it's the standard HP
product and is available on their support web site
(970-enu-win2k.exe). It's an 8 mbyte file and therefore I'd prefer
that you downloaded it if necessary, rather than me uploading it at
56kbps, but I will if you wish although any Win2K system with an HP
970CXi should already be using it The version info from the driver
properties identifies it as 64.29!

Thanks for your continuing interest.
Comment 10 frank 2003-08-14 13:32:22 UTC
Hi,

I'm sorry to tell you that this is not reproducible. I've downloaded
th current driver from HP and checked it both on W2k and on XP. In
both cases the printout works just fine.

This leads me to the assumption that the problem is on your maschine.

I suggest to inspect your printer settings. 

By the way the Version Number of the HP Toolbox and I think therefore
the driver number indentifies itself as 4.3.0.0

Best regards

Frank
Comment 11 peterhb 2003-08-15 19:17:46 UTC
Hi Frank,

I can only conclude that I'm not giving you enough information so I
hope you'll bear with me if I reiterate:

1  An HP DeskJet 970CXi WITH a fitted and functional duplex unit. This
is a standard feature with the 970Cxi, not an optional extra, although
it may not be fitted as it is supplied as a separate unit.
2  In Printer Properties select the Printing Preferences button then
select the Features tab. From there select Landscape AND Two-Sided
Printing - This is the essential prerequisite to provoke the bug.

You will now not be able to print a landscape page from Calc ONLY.
There is no problem with OOo Writer, nor any other print enabled
program on my system.

If the above conditions are not fully met, i.e. the Duplex Unit is not
fitted, or is faulty, then landscape printing works correctly.

NB. The driver version is provided in the output from the "Print Test
Page" in the Properties dialogue. It is not the same as the Toolbox
version.

Regards

Peter HB
Comment 12 frank 2003-08-19 16:14:01 UTC
I'm sorry to tell you that I'm not able to reproduce your problem.

I will re-assign it to one of the guys who is responsible for the
printing. Maybe he has hint or a solution.

Frank
Comment 13 frank 2003-08-19 16:14:35 UTC
Hi Herbert,

can you have a look at this problem ? I can place the printer driver
from HP on X: if needed.

Thanks

Frank
Comment 14 peterhb 2003-08-20 22:10:43 UTC
Frank. Thanks for your continued interest and refusal to give up. This
is a real bug; I've been in software development - operating systems
and data comms - since the early 70s and I wouldn't wind you up with a
non-issue. If the source wasn't too big for my 56k line I'd have a go
myself!

Regards

Peter HB
Comment 15 hdu@apache.org 2003-08-21 07:51:08 UTC
HDU->CD: I forgot the reassign to the expert in this field 
Comment 16 carsten.driesner 2003-09-09 08:06:46 UTC
CD->SSA: Please take over as this looks more like VCL based problem.
Comment 17 Rainer Bielefeld 2004-01-18 14:04:05 UTC
I tested with 1.1.1 and "Test{1}.sxc" on a 895Cxi with various printer
configurations, and was not able to reproduce the problem.
I will try to find other users with that printer.

Rainer
Comment 18 peterhb 2004-01-18 17:45:14 UTC
Rainer Bielefeld seems to be missing the point! I initially raised this issue
because of a problem with the DeskJet 970Cxi - NOT the 895C. The latter does not
have - and never has had - the duplex unit that is at the root of the problem.
As soon as I can find a copy of OOo 1.1.1 I will download it and re-prove the issue.

If there is anything I can do to progress a resolution of this bug please,
pretty please, someone tell me what is required! I have the time, skills and
resources to do anything other than download the full source via a 48Kbps line!!

Regards

Peter HB
Comment 19 Rainer Bielefeld 2004-01-18 18:31:46 UTC
Hi Peter,

you can be sure that your problem has been recognized ;-)

> If there is anything I can do ...

except buying a new printer? HP (printer drivers) are well known for those
"special effects", which they show with some software and with other they do not.
Helpful information will be
- did you try other versions (us / english / german / ...)
- does the problem even happen if you print only 1 page (might be you will not
  get the "double side mode ...")?
- can you reproduce the problem on an other computer with a completely native 
  OOo installation?
- please tell us as many details concerning your OOo- and printer- settings as 
  possible, might be Frank can find something he did in an other way than you.

An other suspect (also from other issues) might be that we might have "hidden"
printout settings in OOo, which override the printer settings (here might be
something like "2 pages per sheet" instead of "all to sides of the sheet"), but
those problems were easily to be reproduced, because visible with other
printers, too.

I do not believe that it is something with your machine, because it works for
writer documents, but as long as no one other has this problem, I do not have
much hope that this problem can be solved.

Rainer

Comment 20 stephan_schaefer 2004-02-05 16:02:18 UTC
ssa->phb7: There were changes to the paper handling recently, so please try  the
upcoming OOo 1.1.1b.
Comment 21 peterhb 2004-02-08 22:33:41 UTC
phb->ssa:

I'm happy to confirm that the bug has been eliminated in 1.1.1b. Many thanks to
whoever finally put this issue in front of a programmer!

All the best.

Peter HB
Comment 22 stephan_schaefer 2004-02-09 09:22:47 UTC
according to the reporter the issue has been fixed.
Comment 23 stephan_schaefer 2004-02-09 09:23:35 UTC
closing
Comment 24 utomo99 2004-03-03 03:46:48 UTC
Utomo > SSA:
Please check if Issue 25342 is regression which is caused by this fix. 
Regression from OOo 1.1.0 which occured in 1.1.1b. 
Thanks

Quote from issue 25342 :
"Regrettably the paper handling modifications in OOo 1.1.1b, which resolved the
problem described in Issue 17439, have apparently introduced a new bug.

It is no longer possible to successfully print a DL sized envelope via the
envelope slot in the paper feed mechanism of the HP DeskJet 970Cxi and the
DeskJet 890C. The envelope is handled as if it were orientated for portrait
printing, rather than the correct landscape orientation.

This bug was not present in any prior release of OOo at least as far back as 
1.0.3.
"

Comment 25 frank 2004-03-03 12:13:51 UTC
removed me from CC List