Issue 17514 - incorrect letter order / word order when exporting Hebrew as swf (flash)
Summary: incorrect letter order / word order when exporting Hebrew as swf (flash)
Status: CLOSED FIXED
Alias: None
Product: Internationalization
Classification: Code
Component: BiDi (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial with 62 votes (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@l10n
URL:
Keywords:
: 26903 35441 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-07-28 16:40 UTC by sforbes
Modified: 2013-08-07 15:01 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
original impress file (9.37 KB, application/octet-stream)
2003-07-28 16:41 UTC, sforbes
no flags Details
exported flash file (5.12 KB, application/octet-stream)
2003-07-28 16:41 UTC, sforbes
no flags Details
screen shot- the file in flash (37.41 KB, image/gif)
2003-07-28 16:43 UTC, sforbes
no flags Details
screen shot- the file in impress (37.98 KB, image/gif)
2003-07-28 16:43 UTC, sforbes
no flags Details
original draw file with Hebrew (6.34 KB, application/octet-stream)
2003-12-24 10:27 UTC, sforbes
no flags Details
exported flash from draw 1.1/ Compare the Hebrew tot he original (1.38 KB, application/octet-stream)
2003-12-24 10:28 UTC, sforbes
no flags Details
Passes text through bidi algorithm (3.04 KB, patch)
2006-11-15 13:59 UTC, alan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description sforbes 2003-07-28 16:40:39 UTC
When exporting a Hebrew presentation from impress to flash, it brakes completely.

* word order is incorrect
* letter order inside words is incorrect- hebrew HELLO becomes OLLEH
Comment 1 sforbes 2003-07-28 16:41:06 UTC
Created attachment 8080 [details]
original impress file
Comment 2 sforbes 2003-07-28 16:41:29 UTC
Created attachment 8081 [details]
exported flash file
Comment 3 sforbes 2003-07-28 16:43:26 UTC
Created attachment 8082 [details]
screen shot- the file in flash
Comment 4 sforbes 2003-07-28 16:43:55 UTC
Created attachment 8083 [details]
screen shot- the file in impress
Comment 5 Dieter.Loeschky 2003-08-20 11:23:35 UTC
DL->CL: Would you please takeover?
Comment 6 clippka 2003-08-28 09:44:18 UTC
will have a look
Comment 7 clippka 2003-08-28 10:24:10 UTC
set target milestone
Comment 8 clippka 2003-09-12 12:56:38 UTC
.
Comment 9 marc.neumann 2003-09-19 13:33:49 UTC
"According to the OpenOffice.org roadmap
(http://tools.openoffice.org/releases) this issue was retargeted to
OOo Later."
Comment 10 sforbes 2003-12-03 13:47:42 UTC
dina: fwi.
I wonder how the press reviews of Hebrew OO missed the fact that this
feature is cxompletly broken?
Comment 11 sforbes 2003-12-24 10:26:46 UTC
this is true for Draw as well. When it comes to Hebrew, flash export is
completely broken an unusable.

Any chance that this will be fixed by version 2?
Comment 12 sforbes 2003-12-24 10:27:33 UTC
Created attachment 12101 [details]
original draw file with Hebrew
Comment 13 sforbes 2003-12-24 10:28:12 UTC
Created attachment 12102 [details]
exported flash from draw 1.1/ Compare the Hebrew tot he original
Comment 14 sforbes 2004-04-19 04:17:51 UTC
*** Issue 26903 has been marked as a duplicate of this issue. ***
Comment 15 itzikhoffenung 2005-11-04 20:06:54 UTC
First:
Issue 35441 is duplicate of this one.

Second:
OOo 2.0 is out and working and this issue, well... Is still an issue!
Did any one took a look at it since Oct 13, 2004?
Flash export is a grate feature in open-office, but as of now it is useless for 
Hebrew users.

 
Comment 16 sforbes 2005-11-04 20:44:25 UTC
*** Issue 35441 has been marked as a duplicate of this issue. ***
Comment 17 sforbes 2005-11-04 20:53:41 UTC
updated version info
Comment 18 sforbes 2006-07-01 14:34:33 UTC
this bug is 3 years old and has 70 votes. 
Any chances on getting it back on the roadmap?
Comment 19 alan 2006-09-12 12:43:49 UTC
ayaniger->cl:
Have you been able to look at this issue? If not, can you give me direction on
how to deal with it (where to look in the code, is there existing documentation,
related bugs, etc.)?
Comment 20 alan 2006-09-12 12:44:33 UTC
ayaniger->cl:
Have you been able to look at this issue? If not, can you give me direction on
how to deal with it (where to look in the code, is there existing documentation,
related bugs, etc.)?
Comment 21 sforbes 2006-10-18 21:22:13 UTC
Any news on this front?
Comment 22 yba 2006-10-19 13:52:35 UTC
yba->Alan: Let me know where you think that we stand on the Hebrew PPT->Impress
project. Either you can fix this bug after you make more progress on
PPT->Impress , or I could assign the fix to Moshe since it *appears* to be not
connected with other work that you are currently doing on Impress. Let me know
what you think.

 - yba
Comment 23 clippka 2006-10-19 15:09:01 UTC
retargeted due to the high vote count.

cl->ayaniger: thanks for you offer to help, I will try to have a quick look at
this issue soon and then see if I can give you some hints or need some help for
you to fix this
Comment 24 clippka 2006-10-19 15:11:21 UTC
can someone please verify if we have the same issue with svg?
Comment 25 munzirtaha 2006-10-20 04:02:38 UTC
cl, I checked the svg support with Arabic and Hebrew but unfortunately, I 
couldn't see any text. I checked with Firefox, Konqueror, Opera and ksvg in 
linux.
Comment 26 yba 2006-10-20 07:50:25 UTC
yba->cl: Please assign this issue to Alan Yaniger. We have started work on it.
Comment 27 alan 2006-10-20 10:04:38 UTC
ayaniger->cl:
I noticed that in swfwriter1.cxx, in Writer::Impl_writeActions, there is no case
statement for META_TEXTLANGUAGE_ACTION (like there is in pdfexport.cxx). When I
added one, execution reached the code I added. Might this be the problem? If so,
we need an "Impl_setLanguage" function, or the like.
Comment 28 clippka 2006-10-20 13:38:51 UTC
reassigning as requested

cl->ayaniger: that may be true, but you are on the right track. Comparing pdf
and svg export with flash is a good start to find out what is missing.
Comment 29 alan 2006-10-22 19:01:16 UTC
ayaniger -> cl: 
I think you've mixed up your "alan"'s. :)
My first name is Alan, but my OOo name is "ayaniger". You assigned the issue to
"alan" (ahmad azlan) instead of "ayaniger".

Alan Yaniger
Comment 30 alan 2006-10-22 19:02:45 UTC
Correcting reassignment
Comment 31 yba 2006-10-24 17:00:00 UTC
yba->cl,ayaniger,alan: Sorry, this is my fault. I thought that "alan" was a
duplicate alias for "ayaniger".
Comment 32 clippka 2006-11-15 10:31:12 UTC
cl->alan: As soon as you have a fix, I'm happy to review it and maybe put it in
a CWS for integration
Comment 33 alan 2006-11-15 13:57:40 UTC
ayaniger->cl:
For now, I hacked a solution by passing the reversed text through the bidi
algorithm, thus reversing the reversed text, and getting the text reordered.
Intending to really solve the problem when I have more time, I've refrained from
posting the patch until now because it's such a kludge. But I'll post it anyway,
since it may be useful for the time being.
Comment 34 alan 2006-11-15 13:59:54 UTC
Created attachment 40585 [details]
Passes text through bidi algorithm
Comment 35 clippka 2006-11-22 10:11:12 UTC
cl->ayaniger: I don't understand hebrew so I can only verify that this patch
only hack hebrew text. I also see that this is only a hack. Question is, does it
make things only better for hebrew export? Should we integrate it as it is now?
Or does it break other things?
Comment 36 alan 2006-11-22 10:50:21 UTC
ayaniger->cl:
There is no doubt that this patch makes things only better for Hebrew. In the
current version, all Hebrew text is simply backwards, which is about as bad as
you can get. 

I've looked at the Flash export code again recently and compared with SVG
export. I found that the Hebrew string retrieved from the metafile is in the
same order for both Flash export and for SVG export, yet in SVG, the string is
displayed in proper order, while in Flash it isn't (unless you apply my patch).
Since I haven't worked with the SVG export code at all, I think it might be a
good idea at this point to hand the issue over to someone who is more familiar
with the SVG and Flash code. Since the issue was originally assigned to you, I
guess you are that person. If you have the time now to look into it and find a
more elegant solution fairly soon, maybe you'll want to do that before
integrating the patch. If you don't have time for that now, Hebrew users would
be grateful if you integrate the patch, and at some point one of us can look
further into the problem. I will update you if I go back to working on the
issue, and if you don't mind, I would appreciate it if you update me if you
begin work on the issue.

From my tests with English text, my patch doesn't break anything, but your QA
people may want to confirm this. 

Comment 37 clippka 2006-11-22 11:02:56 UTC
ok so I target this issue for 2.2. I will either find time to have a look at
this prior to 2.2 code freeze or integrate this patch for 2.2 before code
freeze. Whatever comes first :)
Comment 38 pavel 2007-01-15 19:11:41 UTC
cl: what about your promise? ;-)
Comment 39 clippka 2007-01-17 14:09:53 UTC
good news is I fixed this issue, not only for hebrew but for all asian and
complex text.

When exporting text I check for bidi and asian/complex script. In that case I
ask the vcl outputdevice for a polygon representation of the text. This works
always as all our text formating functionality is already implemented in vcl.
This also solves the problems for languages where one character could be
rendered with different glyphs (polygons) depending on the context.

The drawback is that exporting bidi/asian/complex text will create bigger swf
files as glyph polygons are currently not reused. I will ask on the mailing
list, maybe someone likes to dedicate some time on this issue.
Comment 40 clippka 2007-01-23 12:51:44 UTC
verified in cws, back to qa
Comment 41 christian.guenther 2007-01-24 16:20:51 UTC
CGU: Verified in cws impress116
Comment 42 christian.guenther 2007-02-14 09:54:51 UTC
Integrated in src680m203 and OOF680m6