Issue 17567 - WW8: Negative vertical graphic positioning
Summary: WW8: Negative vertical graphic positioning
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC2
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: ms_interoperability, oooqa
: 12293 36788 (view as issue list)
Depends on:
Blocks: 11493 18998 20124 20458
  Show dependency treegraph
 
Reported: 2003-07-29 13:08 UTC by Unknown
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Original Word 97 document (380.00 KB, text/word97-document)
2003-07-29 13:10 UTC, Unknown
no flags Details
Same document after reading and saving in OpenOffice.org (17.36 KB, application/octet-stream)
2003-07-29 13:12 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-07-29 13:08:32 UTC
When reading in HeaderTest.Doc, image in page header is shown in incorrect size
Comment 1 Unknown 2003-07-29 13:10:20 UTC
Created attachment 8114 [details]
Original Word 97 document
Comment 2 Unknown 2003-07-29 13:12:42 UTC
Created attachment 8115 [details]
Same document after reading and saving in OpenOffice.org
Comment 3 tamblyne 2003-08-03 21:07:44 UTC
Confirmed -- WinXPPro/OOo 1.1rc2
Comment 4 h.ilter 2003-08-06 14:22:48 UTC
Reassigned to CMC
Comment 5 caolanm 2003-08-06 15:09:04 UTC
cmc->hi: This looks the same in writer and word in SRX645m15 i.e. both
say 0.95cm X 0.76cm for the graphic. The only different is that the
graphic is set -0.15 below (i.e. above) the paragraph in word,
something that we cannot currently do. That extra negative vertical
feature is a to-do for 2.0
Comment 6 h.ilter 2003-08-11 16:01:03 UTC
Retarget ot OO2.0
Comment 7 caolanm 2003-08-14 12:42:44 UTC
cmc->od: I think you are involved in this enhancement ? If not move it
on to ama. Here we have an example of a graphic anchored as paragraph
(in a header) which has negative vertical positioning relative to the
paragraph i.e. -0.15 below (0.15 above), something writer cannot do at
the moment.
Comment 8 Oliver-Rainer Wittmann 2003-08-14 12:55:49 UTC
OD (14.08.2003):
Right, I'm working on it.
Comment 9 Oliver-Rainer Wittmann 2003-09-16 10:10:22 UTC
*** Issue 8456 has been marked as a duplicate of this issue. ***
Comment 10 Oliver-Rainer Wittmann 2003-09-23 14:21:09 UTC
.
Comment 11 Oliver-Rainer Wittmann 2003-11-20 10:22:57 UTC
fixed in internal cws swobjpos02
Comment 12 Oliver-Rainer Wittmann 2003-11-20 10:23:49 UTC
OD->MRU:
Checked in internal installation set of cws swobjpos02 - please verify.
Comment 13 Oliver-Rainer Wittmann 2003-11-20 10:53:14 UTC
specification for negative positions for Writer fly frames can be
found at http://specs.openoffice.org
Comment 14 michael.ruess 2003-12-11 10:29:12 UTC
Checked fix in CWS swobjpos2.
Comment 15 michael.ruess 2003-12-11 10:30:04 UTC
Verified. Fix will be included in OO 2.0.
Comment 16 michael.ruess 2004-04-27 13:08:16 UTC
Cklosed. Fixed in current snapshot.
Comment 17 gieschke 2004-07-11 18:24:15 UTC
*** Issue 12293 has been marked as a duplicate of this issue. ***
Comment 18 michael.ruess 2004-11-25 14:50:03 UTC
*** Issue 36788 has been marked as a duplicate of this issue. ***