Issue 17959 - Cropped image not handled correctly when save doc as HTML
Summary: Cropped image not handled correctly when save doc as HTML
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1
Hardware: PC Windows XP
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@ui
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-08-07 12:13 UTC by Unknown
Modified: 2003-10-23 14:12 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
demo file (62.44 KB, application/octet-stream)
2003-10-21 16:10 UTC, guido.pinkernell
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-08-07 12:13:19 UTC
Cropped image not cropped but rescaled when I save writer-document as HTML.

1 Create document in writer picture (I used png-format)
2 Crop picture so you show lets say just upper right 1/4 of picture
  (Remember to keep scale)
3 Save document as HTML
4 Open resulting HTML-document i browser
5 The whole picture is now shown in 1/4 scale of original

Expected result:
Cropped image presented as it was in Writer. That is just the upper right 1/4 
in original scale.

As it is I cannot crop any pictures inside Writer if I want to save it as HTML 
later on.
Comment 1 Unknown 2003-08-07 12:14:10 UTC
This bug would seem to be related to bug 15378.
Comment 2 guido.pinkernell 2003-10-21 13:26:40 UTC
I can confirm this with OOo 1.1.0(en) on Win98. Will attach files for
demonstration
Comment 3 guido.pinkernell 2003-10-21 16:10:21 UTC
Created attachment 10521 [details]
demo file
Comment 4 stefan.baltzer 2003-10-23 14:12:01 UTC
SBA: This one is the same as issue 18168. Both are a duplicate of
issue 19690. The general problem is that the UI for editing HTML
documents is the same as for Writer documents, thus having features
(like cropping) enabled that HTML does not support. Set to Duplicate.

*** This issue has been marked as a duplicate of 19690 ***
Comment 5 stefan.baltzer 2003-10-23 14:12:28 UTC
Closed.