Issue 1810 - Saving as HTML causes wrong &char codes.
Summary: Saving as HTML causes wrong &char codes.
Status: CLOSED DUPLICATE of issue 2144
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 638
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-10-06 18:58 UTC by tomee
Modified: 2003-09-08 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tomee 2001-10-06 18:58:09 UTC
I use polish locale settings everywhere on my machine, which is fine with Open 
Office. It open Word documents with Polish chars (no idea whether it's CP1250, 
Latin2 or UTF8 there) flawlessly and prints out Truetype fonts with Latin2 
characters. However, when I type in a text containing Latin2 chars and save it 
as HTML, the <META HTTP-EQUIV> tag is set correctly, but the &#char; symbols 
to be an absolute representation of Latin1 equivalents of what it would look 
like in Latin2 (not too clear explanation. Imagine you tried to type Latin2 
chars with a Latin1 charmap -- you'd see some other chars, like <sup>3</sup> 
instead of "?" (l/) or +/- instead of "?" (a,). Thats what happens to HTML: 
it's remapped to Latin1 in spite of the HTTP EQUIV (which proves OO knows what 
kind of characters it bothers with) and then converted to &#char;. 

I hope I made myself clear...
Comment 1 stefan.baltzer 2001-10-08 15:11:32 UTC
Reassigned to Eric.
Comment 2 eric.savary 2001-11-12 16:28:34 UTC
ES: well, if you don't mind I'd rather take Issue 2144 as reference a 
flag this issue as duplicate.

*** This issue has been marked as a duplicate of 2144 ***
Comment 3 eric.savary 2003-02-17 16:17:27 UTC
closed