Issue 18168 - graphics in html format too large, not cropped
Summary: graphics in html format too large, not cropped
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC2
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-08-12 20:39 UTC by mmelchior
Modified: 2013-08-07 14:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Demo for this problem. (32.94 KB, application/octet-stream)
2003-08-18 21:44 UTC, mmelchior
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mmelchior 2003-08-12 20:39:17 UTC
Take a document with graphics.  In my case they were embedded screen
shots of single windows [made using Alt-PrintScreen].  Since only
a small part of the screenshot was relevant for the discussion at hand,
I have used the Crop parameters to select the relevant part.
This works OK in Writer.

Now I have saved this document as a html file for publication on a
web server.  The screenshots do not look the way I want, they have
the dimentions as specified by the crop parameters and contain the
full screen shot, so the text is not legible any more and the reader
does not know what part of the picture is relevant.

Please correct the html save routine to only save the cropped part
of the graphic in the .png file for inclusion on the web page.
The html <img> tag will use the height and width attributes to determine
the display size and than only *scale* the image to fit that area.
<img> will not *crop* the image!
Comment 1 tamblyne 2003-08-18 14:33:36 UTC
Please attach the referenced document to your issue report.  

Thanks,  

Tam  

Comment 2 mmelchior 2003-08-18 21:44:29 UTC
Created attachment 8554 [details]
Demo for this problem.
Comment 3 tamblyne 2003-09-02 12:15:33 UTC
Unable to reproduce 1.1rc3
Comment 4 mmelchior 2003-09-02 20:21:03 UTC
In my version of 1.1RC3 (645m15(Build:8669)[CWS:ooo11rc3] on Debian
Linux, PC hardware), it still behaves like before: no cropped image
in the html version, just a vertically compressed image....

Please add the .html and .png files you get when saving IZ18168.sxw
as "HTML Document" to this issue, so I can verrify your results.
Comment 5 jack.warchold 2003-09-04 14:57:10 UTC
jw: reproduced with OOo1.1RC3
reassigned to es
prio changed to P3
Comment 6 jack.warchold 2003-09-04 14:57:37 UTC
jw:set state to new
Comment 7 stefan.baltzer 2003-09-12 14:53:34 UTC
SBA: As far as I know, this is not supported by HTML so the problem is
that OOo offers the option while editing a HTML doc or doesn't show an
appropriate warning when saving to HTML.
Target changed to "OOo later" 
Comment 8 eric.savary 2003-09-19 09:55:40 UTC
Duplicate of a larger task

*** This issue has been marked as a duplicate of 19690 ***
Comment 9 eric.savary 2003-09-19 09:56:07 UTC
closed
Comment 10 jogi 2003-09-24 08:53:21 UTC
-