Issue 18259 - external data import, fixed width text file, does not work
Summary: external data import, fixed width text file, does not work
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-08-15 21:21 UTC by Unknown
Modified: 2003-09-08 16:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
BOM for a pcb with fixed width columns (54.40 KB, text/plain)
2003-08-15 21:22 UTC, Unknown
no flags Details
imported text file into OOo 1.02 in xls format (36.50 KB, application/octet-stream)
2003-08-19 17:12 UTC, Unknown
no flags Details
Swriter document of procedure to import text. (209.63 KB, application/octet-stream)
2003-08-19 22:11 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-08-15 21:21:16 UTC
When importing a fixed width columns text file via the insert external data,
after I set the type to text and set the columns, click OK, the dialog box goes
away leaving the External Data dialog box, but it never imports into the
spreadsheet. This worked in 1.02, but 1.1rc2, it quit working. This time at
least you get to where you can set the columns, but no further. (I set the text
type is western european iso8859-1 but that did not help. File is straight text)

I had filed a previous issue, but it is no longer shown under my issues.

Art
Comment 1 Unknown 2003-08-15 21:22:39 UTC
Created attachment 8490 [details]
BOM for a pcb with fixed width columns
Comment 2 andreschnabel 2003-08-19 13:19:38 UTC
Art: can you try to define the columns? Simply put the mouse pointer
to the lower part of the dialogue - the shown table - and klick in the
ruler just before the end of each column.


your first issue was issue 16916

just to clearify (because I used the wrong function at the first shot):
CVS-files should be importet via "file - open" or "Insert- table",
"Insert - external data" is the wrong way (although it looks like the
right)
Comment 3 frank 2003-08-19 15:52:20 UTC
Hi,

this has never been possible. For now Insert External Data just works
with documents containing Range names. Your lst file or any other text
file do not contain such name. 

This Issue is a double to Issue 1834.

So I set the flags.

Frank

*** This issue has been marked as a duplicate of 1834 ***
Comment 4 frank 2003-08-19 15:52:40 UTC
closed double
Comment 5 Unknown 2003-08-19 17:09:10 UTC
I will beg to differ with you that it never has worked. It worked in
1.0 to 1.02 I know. Your range names comment would need explaining as
I do not know what you are talking about. When importing before, I
would set column markers for each column. Is this what you are talking
about? Attached is an older file which I imported in 1.02 and it did work.

Art
Comment 6 Unknown 2003-08-19 17:12:02 UTC
Created attachment 8571 [details]
imported text file into OOo 1.02 in xls format
Comment 7 andreschnabel 2003-08-19 21:21:44 UTC
Art:
please have a look at Issue 1834. If this description fits to your
problem, please vote for this issue.
If development should pay more attention, ask the reportes of the
duplicated issues to vote, too.

If your problem is an other, please give a detailed description, what
menu item do you select, what dialogue apperears ....
Sorry for that, but there seems to be some misunderstandings, what you
are trying to do (or the way you are doing it). Pleas make this
"idiot-proof".

anyway - thank you for supporting OOo and reporting Issues.

Andre
Comment 8 Unknown 2003-08-19 22:11:50 UTC
Created attachment 8581 [details]
Swriter document of procedure to import text.
Comment 9 frank 2003-08-20 10:15:07 UTC
Hi Art,

what you have done to import the *.lst file into OOo is just go to
Insert Sheet and select 'from file' or directly importing the file
into a new Spreadsheet by using the file open dialog and selecting
Text-CSV as the filter.

The external data dialog never had the functionality you want to use.
Therefore I've set the Issue as double to 1834.

After I've got your sxw document containing the description what
you've done I've to close this as invalid.

Frank
Comment 10 frank 2003-08-20 10:16:04 UTC
closed invalid