Issue 18305 - User settings lost in upgrade from 1.1rc1 to 1.1rc3
Summary: User settings lost in upgrade from 1.1rc1 to 1.1rc3
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC3
Hardware: PC Windows XP
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: Olaf Felka
QA Contact: issues@installation
: 18229 (view as issue list)
Depends on:
Reported: 2003-08-17 08:38 UTC by oblong
Modified: 2003-09-16 11:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description oblong 2003-08-17 08:38:15 UTC
I currently had installed 1.1rc.
I ran "setup /net" and there was an option to upgrade into the same
directory. Good!

Then I ran the "setup" as user. I was informed that as the network
installation had been updated, I had to do an update. No problem with that,
and all went smoothly.

However, I discovered that not all settings were preserved. For example:

Macros in Writer have gone.
Autotext entries in Writer have gone.
Some Tools|Options not retained. E.g., Autosave settings.
Tools|Spellcheck|AutoSpellcheck was no longer ticked.

The Australian dictionary I had installed is not shown as installed.
Language settings are back to USA, rather than Australia. (The Australian
dictionary itself is still in C:\Program
Files\OpenOffice.org1.1\share\dict\ooo, but dictionary.lst has been

Tools|Autocorrect|English(Australia) was retained.

I was hoping that as it did an "official" upgrade that such settings would
not be lost.
Comment 1 Olaf Felka 2003-08-18 11:27:27 UTC
*** Issue 18229 has been marked as a duplicate of this issue. ***
Comment 2 oblong 2003-08-18 12:00:56 UTC
Also noticed that Tools|Options|Text Document|Print|Fax was set to 
<none> and no longer set to what it was previously.
Comment 3 Olaf Felka 2003-08-18 14:14:35 UTC
I can confirm for updating RC1 to RC3. It's much better when updating
RC2 to RC3. All settings but user data are updated. I think that this
is similar to 17676. To fix this problem is to risky.
Comment 4 oblong 2003-08-19 03:36:32 UTC
I'm asking for clarification: does this mean that an upgrade from 
rc3 to the next rc (or even jumping to an even later rc) *will* keep 
existing macros, AutoText and other settings? 

And I don't understand what is meant by "To fix this problem is to
[o] risky".
Comment 5 Olaf Felka 2003-09-16 11:29:15 UTC
Update from RC3 to RC4 or final will not be possible as default. It's
only possible to update OOo 1.1 with 1.1.0. Your personal hack for OOo
RC4 ot later might be to edit the setup.inf file:
The line:
should be enhaced with ;%PRODUCTNAME 1.1.0:
This should work, but no garanties, this is just your personal workaround.
'To risky to fix' means that more settings might break than get repaired.