Issue 18417 - copy/cut/paste
Summary: copy/cut/paste
Status: CLOSED DUPLICATE of issue 17171
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 RC3
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-08-19 20:04 UTC by Unknown
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-08-19 20:04:57 UTC
copy/cut/paste does not work regardless of how you try to execute the command
(i.e., keystroke, edit menu, mouse). this is incredibly an annoying bug.
Comment 1 Unknown 2003-08-19 21:07:16 UTC
The behavior of Paste degrades with time. Initially it works. Later, 
you have to use the menu command, as the keyboard command doesn't work 
(or vice versa; apologies -- I forget which way it happened). Now, it 
doesn't work at all for me. 
Comment 2 tamblyne 2003-08-20 04:40:49 UTC
WinXPPro/1.1rc3

Original reporter states that cut/copy/paste do not work at all. 
Initially functioned as expected via keyboard, mouse and menu.  

However, Ananda commented that paste function degrades, so I attempted
to reproduce degraded paste performance as well.  

Working with a letter sized page set to shipping defaults, I copied a
single line of text and pasted it repeatedly until it filled a full
page with no problems.  

I then copied that page and pasted it repeatedly.  At 21 to 22 pages
(I tested this several times, thus the inconsistency), the CTRL+V
failed to paste the text.  I used right-click on the document and to
paste via mouse for another ten pages, after which the CTRL+V from the
keyboard worked again for another twenty pages.  

At this point, neither keyboard, mouse nor menu would perform the
paste operation from the full page copy (which by this time has been
pasted 60 times).  

I selected five lines from the same document, copied them and pasted
them via the keyboard commands.  Paste was slow and delayed -- I
thought it wasn't working at all -- but after about ten seconds, the
paste appeared.  By this time, the document is 62 pages long.  

This is not the behavior originally reported.  Should a new issue be
filed?  

Tam  

Comment 3 h.ilter 2003-08-20 11:25:33 UTC
What about when you press return. Can you paste further?
Comment 4 tamblyne 2003-08-20 14:06:11 UTC
Yes -- I can paste approximately 20 pages.  Then hit return, then can
paste another 20 pages, hit return, paste again, etc., etc.  This is
from the same original CTRL+C copy command.  

If you need actual file size as opposed to arbitrary "pages", let me
know.  

Tam  

Comment 5 h.ilter 2003-08-20 15:28:49 UTC
HI->OS: Please comment the rules about the character count within a 
paragraph. And, how we will handle it in the future. May I label it 
as an enhancement to BH?
Comment 6 Oliver Specht 2003-08-21 07:15:24 UTC
The 'problem' here is that paragraphs in Writer have a maximum of 64K
characters. I can't see this as a P2 problem. 

Anyway, duplicate of 17171

*** This issue has been marked as a duplicate of 17171 ***
Comment 7 lohmaier 2003-08-31 20:05:07 UTC
closing duplicate.