Issue 18731 - Unsubscribed user should be added in reply-to field
Summary: Unsubscribed user should be added in reply-to field
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Mailing lists (show other issues)
Version: current
Hardware: PC Linux, all
: P3 Trivial with 15 votes (vote)
Target Milestone: CEE Rubicon
Assignee: Unknown
QA Contact: issues@www
URL:
Keywords:
: 26449 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-08-27 14:01 UTC by lduperval
Modified: 2009-11-05 23:29 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Discussion Service - Advanced Config Setting (45.17 KB, application/pdf)
2007-12-14 05:48 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lduperval 2003-08-27 14:01:18 UTC
When an unsubscribed user sends a message, there is no easy way to know this
unless you take a look at the complete headers. This is a bit time consuming. It
would be nice if the Reply-To field also contained the address of the
unsubscribed sender.
Comment 1 con.hennessy 2003-08-27 20:08:01 UTC
This would be VERY useful and make sure that the user does not miss good 
information. 
Comment 2 dcarrera 2003-09-04 19:15:01 UTC
We could also get the mailing list to add the text "USER NOT
SUBSCRIBED" to the top of the post.  Perhaps add the line "for
subscribing instructions please see ..."
Comment 3 lsuarezpotts 2003-09-04 23:07:09 UTC
Hi
I think these are fine suggestions. Now for the pessimism.  To change the mail 
system would be non-trivial and requires significant changes to the core SourceCast 
application. It has been discussed at CollabNet, as part of the general evolution of 
SourceCast, but any changes won't be apparent for, in all likelihood, at least a year, 
probably 18 months.  That's the normal cycle time for software products (think of 
StarOffice cycle).

Meanwhile, we can try working around the mail system we have now. I'm not closing 
this issue, as I think it is useful for tracking valuable suggestions. But just keep the 
time dilation effect in mind.
cheers
Louis 
Comment 4 leggewie 2004-03-13 18:50:33 UTC
Please don't forget the impact that gmane.org has on this:

1) users may read (and post) from gmane.org -> no need for a cc for those users
2) answers from gmane users will be NNTP, not SMTP -> reply-to inappropriate

I think, the best way for implementation is to cc: unsubscribed posters for all
messages of a thread at server level (!) while excluding those posters whose
messages came from gmane.org.  Client side solutions will most likely not work.
Comment 5 tamblyne 2004-03-13 21:50:52 UTC
Unless I am missing something very basic, gmane posters would not be affected 
by such a change -- the headers from their postings do not indicate they are 
unsubscribed, i.e., the "Delivered-To:  moderator" does not appear on the 
newsgroup posts.   
Comment 6 dcarrera 2004-03-13 21:57:46 UTC
We should get CollabNET to install procmail.  With procmail installed, you can
just add the following in the procmailrc file:

# Identify moderated messages.
:0 H
*^Delivered-To:.*moderator*.
{
        :0 fwh
         |sed -e 's/^Subject:[   ]*/Subject: [moderated] /'
}


That will pre-pend the text [moderated] to all moderated messages.  It works
like a charm.  I've only been using it for a couple of days and I don't know how
I ever managed without it.
Comment 7 lsuarezpotts 2004-03-14 03:16:57 UTC
Hi Daniel,
as commented on discuss@ooo...
"My understanding of procmail is that it is "a mail processing utility,
which can help you filter your mail; sort incoming mail according to
sender, Subject line, length of message, keywords in the message, etc;
implement an ftp-by-mail server, and much more."
<http://rhols66.adsl.netsonic.fi/era/procmail/mini-faq.html#description>


Thus, it is a solution that would be applied after mail goes through the
CollabNet servers.  We do not host user mail, SourceCast just routes it to
the user address.  In short, my response was not at all that SourceCast
could not do this--SC is not a mail server, and is not a mail host, and is
merely a router for mail address--it was rather that an issue would
accomplish two things:
	1. Get the CollabNet engineers to voice specifically on the feasibility
of this particular solution *as well as* adding to the numerous RFEs
related to the mail system.  I can holler all I want but it makes a
difference if it seems that the community perceives the current mail system
to be inadequate.
	2. Notify moderators of the script that they can deploy on their mail
servers if relevant.

Oh, when I said, 'manually doing it' I meant that each moderator may have
to do it, not that the script was not useful.

That is, I don't think it makes sense for CollabNet to install procmail, which, if I understand correctly 
(about which I have no confidence) works as an intermediary between a mail server and you; and that 
you have it on your machine.


But SourceCast is not a mail server at all. It routes mail. There would be no place to install it; or if there 
were, it would have to be done for every single subscriber.

But maybe I'm missing something here?

meanwhile, I followed up on your clever suggestion of adding the automatic subject line, "[moderated]" 
to all user email sent from the web.
Louis
Comment 8 dcarrera 2004-03-14 03:25:24 UTC
Louis,

Alright, what should I do?
How do I submit an RFE?  I thought that an RFE was just an IZ entry.  It looks
like I'm just confused.
Comment 9 lsuarezpotts 2004-03-14 03:45:58 UTC
Hi
Sorry to exasperate you ;(
To file an RFE, file a regular issue and call it an enhancement.  Assign it to me, www component, www 
subcomponent.

I'll relay it to CollabNet support.

Daniel, your ideas are good; I regret being a bureaucrat.
Cheers,
louis 
Comment 10 leggewie 2004-03-14 15:54:25 UTC
@tamblyne: OK, apparently point 1) is luckily not an issue.  Just wanted to make
sure it gets considered.  Point 2) definitely needs to be taken into
consideration though.

@louis: I am not so sure CollabNET cannot install procmail.  They must have some
form of MTA.  Can you figure out which one?

@dcarrera: Simply tagging is not sufficient.  Please refer to issue 26449 which
has been opened on this subject as well for my reasoning and proposed
alternative solution.
Comment 11 lsuarezpotts 2004-03-15 02:50:43 UTC
hi I am reassigning to collabnet support and keeping this as an RFE.
louis
Comment 12 Unknown 2004-03-15 11:51:49 UTC
*** Issue 26449 has been marked as a duplicate of this issue. ***
Comment 13 Unknown 2004-03-15 11:52:01 UTC
*** Issue 26449 has been marked as a duplicate of this issue. ***
Comment 14 Unknown 2004-03-18 10:49:33 UTC
St: Looks like all the three issues 24325, issue 26449 and issue 18731 all are 
similar. can you put altogether as an single issue so that it will easy to 
track.

-Priya
Comment 15 grsingleton 2004-03-20 15:25:56 UTC
Adde myself to cc list
Comment 16 Martin Hollmichel 2004-04-04 18:21:30 UTC
set version to current
Comment 17 leggewie 2005-07-22 16:59:48 UTC
What is the status of this?
Comment 18 lsuarezpotts 2006-10-26 17:09:48 UTC
Support, is there any way of implementing this prior to upgrade to discussion
services? (provided that such implementation is free?)
Comment 19 grsingleton 2006-10-26 17:17:30 UTC
Depending on the software, detecting the header Delivered to: moderator might
provide a reasonable trigger. Mimedefang can do this with the addition of a test.
Comment 20 Unknown 2007-01-05 10:06:02 UTC
To CRM
Comment 21 Unknown 2007-12-14 05:44:53 UTC
The requested feature is already available in our new tool which would be soon
replacing existing mailing list tool . Attaching a pdf containing the setting
available in the new tool .

Moving this issue into the resolved later queue
Comment 22 Unknown 2007-12-14 05:48:42 UTC
Created attachment 50304 [details]
Discussion Service - Advanced Config Setting
Comment 23 Unknown 2008-02-26 12:14:43 UTC
Hi

This feature is fixed in Rubicon and I have verified the same on a test box
carrying the latest version. I shall close this case for now. Please feel free
to re-open, if the functionality does not satisfy your expectation when site
gets upgraded to Rubicon version of CEE.

Regards,
Vathsan
Support Operations.
Comment 24 leggewie 2008-02-26 12:37:50 UTC
Wow!  Forgive my sarcasm, but five years down the road, this very essential bug
might finally be fixed?  Unbelievable.  That would indeed be nice, although
personally I have lost interest - and faith in Collabnet.

Srivathsan, thank you for looking into this.  Are you sure you have dealt with
the following issues correctly?

a) poster from gmane -> no cc necessary
b) A sends a question to the ml, B answers to A (and sends a mail to the list as 
   well as a cc to A, I suppose).  Then C reponds to B.  Does A get a cc?
Comment 25 kpalagin 2008-03-17 20:53:49 UTC
When we are going to get this new behavior?

Thanks.
Comment 26 Unknown 2008-03-19 11:49:54 UTC
Hi

The requested feature will be made available when Openoffice gets upgraded to
CEE 5.0 release. 


Regards,
Vathsan
Support Operations.
Comment 27 Larry Gusaas 2009-05-22 05:01:23 UTC
This issue is marked as closed. It has not been fixed after almost six years.

Over a year ago it was said to be fixed. It is not fixed.

Why is this issue closed when it has not been fixed?
Comment 28 ericrenaud 2009-05-22 07:51:57 UTC
This issue is marked closed/later.  Per desc27, this has been added into CEE 5.0
(and later).  OpenOffice.org is currently on release 4.5.2.  
Comment 29 Larry Gusaas 2009-05-22 08:08:09 UTC
Does that mean we have to wait another five years or longer for this problem to
be fixed? I have now decided not to give support to unsubcribed users until this
is fixed!!
Comment 30 paul.m.nz 2009-11-05 23:26:39 UTC
Can we have confirmation whether this upgrade will fix the scenarios listed by
'leggewie' on Tue Feb 26 12:37:50 +0000 2008?
Comment 31 eric.renaud 2009-11-05 23:29:36 UTC
This is irrelevant.  Sun refuses to upgrade OpenOffice.org onto a newer version
of CEE.