Issue 19105 - Problem with displaying bullets from unicode fonts on Win9x and WinME
Summary: Problem with displaying bullets from unicode fonts on Win9x and WinME
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1
Hardware: PC Windows ME
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0.3
Assignee: hdu@apache.org
QA Contact: issues@installation
URL:
Keywords: oooqa
: 21056 28364 (view as issue list)
Depends on: 21466 26679
Blocks: 64250
  Show dependency tree
 
Reported: 2003-09-05 08:35 UTC by rjbutler
Modified: 2010-11-10 16:54 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot shows missing bullets and garbled "Insert Special Characters" - I believe you know all that :-/ (43.40 KB, image/png)
2004-06-10 07:21 UTC, Rainer Bielefeld
no flags Details
New document with bullets (6.25 KB, application/vnd.sun.xml.writer)
2005-07-31 02:43 UTC, jjr16
no flags Details
With 1.1.5ja on Windows 98 SE (38.27 KB, image/jpeg)
2005-07-31 05:30 UTC, khirano
no flags Details
With 1.9.121ja on Windows 98 SE (40.85 KB, image/jpeg)
2005-07-31 05:32 UTC, khirano
no flags Details
With 1.1.5de on Windows Me (41.36 KB, image/jpeg)
2005-07-31 05:37 UTC, khirano
no flags Details
With 1.9.115ja on Windows Me (44.21 KB, image/jpeg)
2005-07-31 05:38 UTC, khirano
no flags Details
document I used for testing on Windows 98 SE and Me (6.07 KB, application/vnd.sun.xml.writer)
2005-07-31 05:41 UTC, khirano
no flags Details
I see bullets in m121... (72.38 KB, image/png)
2005-07-31 07:32 UTC, pavel
no flags Details
Screenshot showeing strange rectangles in installation splash screen (no Idea whether that has to do with the problem what this issue is for) (239.98 KB, application/vnd.oasis.opendocument.text)
2006-03-17 11:51 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rjbutler 2003-09-05 08:35:27 UTC
I have an installation of OOo.RC3 on Windows ME, another on Mandrake 9.1, and my
wife has one on Windows XP Home. The latter two have no
problem showing bullets, but the WinME installation will not show the
default (small) bullets.  Using Times New Roman, Palatino or Palatino Linotype
fonts. I have tried reinstalling "opens___.ttf" font
Comment 1 korsi 2003-09-06 12:55:00 UTC
Hi, thank you for reporting this problem 
 
I can confirm the issue: 
 
1. I installed OOo-1.1RC3 on a Windows ME (norwegian) system. The 
locales was set to english/US in the os when installing. 
 
2. Started writer and wrote a document with bulleted list, using 
standard font and direct formatting. 
 
3. The standard small bullets was represented by squares. Other 
bullet symbols are shown as normal. 
 
Håvard 
Comment 2 rjbutler 2003-09-08 09:50:09 UTC
Just to confirm that the problem is still evident with RC4
Comment 3 jack.warchold 2003-09-11 19:24:22 UTC
set prio to P3
reassigned to jw
Comment 4 utomo99 2003-09-12 04:33:35 UTC
Please attach the documents, so we can test it using 1.1 Rc4 

Comment 5 rjbutler 2003-09-12 04:45:03 UTC
Happens in Win Me with new document - click "bullets on/off"
Comment 6 utomo99 2003-09-16 09:14:17 UTC
Please Attach the documents which make this problem, so we can test it. 
 (Without the documents, we cannot confirm the problem easily)
Don't forget to cut other part of the documents, so the file size is 
small, but we still able to see the problem.
Comment 7 jack.warchold 2003-09-16 13:39:03 UTC
reproduced with OO1.1RC4 and the latest staroffice build under win98
reassigned to hdu

instead of seeing a circle/ball seeing a squaere in default zoom (100%
)zooming in (200%) shows this is a flat circle/ball.

set status to new
set prio to P4
set target to OOo2.0
Comment 8 hdu@apache.org 2003-09-23 16:24:29 UTC
.
Comment 9 guido.pinkernell 2003-10-13 12:47:47 UTC
*** Issue 21056 has been marked as a duplicate of this issue. ***
Comment 10 guido.pinkernell 2003-10-13 13:19:42 UTC
Can confirm this with 1.1 on Win98. It looks this is a defect for all
Win9x and WinME OS. I have modified the summary accordingly.

Workaround:

In a doc, create a bulleted list. If it shows rectangles instead of
bullets, do this:

Place cursor in one of the list lines. Then > Format > Numbering >
Options > Character > Click on "..." > Click on bullet, even if it´s
selected already > OK.

If necessary, one needs to repeat this for every level, or select
levels 1-10. If necessary, one needs to repeat this for the list
styles as well.

Another workaround is to install an older Opensymbol Font, as one
reporter of a duplicate tells: "If I replace the file OPENS___.TTF in
my %windir%\FONTS directory with an older file (Version 1.3, 101kB)
downloaded from http://www.8ung.at/ooo.org/OpenSymbol.zip, all
enumeration symbols are displayed in the right way."
Comment 11 guido.pinkernell 2003-10-13 13:21:22 UTC
keyword oooqa added and OOo version changed to 1.1
Comment 12 foxboy 2003-10-27 09:11:43 UTC
Seems to be a similar problem to the Wingdings-Problem with Win 98. I 
have had this problem all the way back to the first Staroffice 6 beta-
release until now with OO 1.1. With Staroffice 5.2, there are no 
issues with Symbol Fonts, Wingdings and Bullets. But since StarOffice 
6.0, Wingdings and other Symbol Fonts won't print - instead I get 
these rectangles.

Fox
Comment 13 foxboy 2003-10-31 11:44:53 UTC
Just to say my wingdings-Issue was a printer driver issue. But the 
standard small bullets are still rectangles by default. I can confirm 
this issue.

Wouldn't it be a nice feature if we could customize the default 
bullets? It's annoying that everytime i click on the bullet-button, 
only the first style is available automatically (the small bullets).

Fox
Comment 14 hdu@apache.org 2003-10-31 12:35:03 UTC
HDU->Russell: Can you attach the document that behaves ok on one
system but has the problems on the other system?
Is this a display only problem or a printout problem?
Does installing the old OpenSymbol font help as Pinkernell suggested?
Comment 15 rjbutler 2003-11-01 11:39:56 UTC
Sorry,  I should have responded earlier. Yes the installation of the
old Opensymbol font corrects the problem entirely.

Responding to Herbert Duerr, there was no need for upoading a
document, as the problem was evident in a new document. If I clicked
on the "bullet" icon on the task bar, it would produce rectangles
only, unless  I went through the process suggested by IIRC Guido
Pinkernell of editing the character in the Numbering/Bullets Options
Menu. This should be in the users mail archive.
Comment 16 mjharris13 2003-11-24 18:02:16 UTC
I am running OpenOffice 1.1.0 (final) on Win98 SE and am having the 
same problem with the small bullets being rectangles (the type that 
indicate characters not recognized by the system).  I have also copied 
in the old Opens___.ttf file to the Fonts directory.  Unfortunately 
for me it did not correct the problem.  I still get the rectangles.
Comment 17 ptkho 2004-01-09 08:27:03 UTC
I recognize this problem on 1.1 on Win98SE (Dutch version). Strange thing
however is that I have no problem on my laptop (it shows the small bullets
directly), but on my work-desktop I only see the rectangles. Both computers are
running Win98SE Dutch version.
Comment 18 hdu@apache.org 2004-01-12 16:26:40 UTC
Are the Opensymbol font files on both computers the same? The font files are
probably at C:\Windows\Fonts\opens___.ttf .
Comment 19 mjharris13 2004-01-14 01:10:25 UTC
The OpenSymbol fonts are identical on both my systems.  One Linux Mandrake 9.1,
which works perfectly. The other Win98SE, which does not work properly.  Even if 
I follow the workaround suggestions given, I may be able to get the small 
bullets to show on the screen, but if I print the document it prints with the 
rectangle.  It used to work for me with OOo1.03 but has not worked since 
updating to 1.1.
Comment 20 hdu@apache.org 2004-01-19 11:00:32 UTC
Do you see differences between the two platforms in the "Insert Special
Character" dialog when both have "OpenSymbol" font selected? You can open the
dialog through the menu
Insert -> Special Character
Use the vertical scrollbar in this dialog to compare the whole font.
Comment 21 mjharris13 2004-02-07 19:12:01 UTC
There are differences between the two platforms in the "Insert Special
Character" dialog when both have "OpenSymbol" font selected.  In the Linux 
version the characters are complete.  In the Win version there are many that 
have the rectangle instead of the character.  
Comment 22 ptkho 2004-03-05 13:55:29 UTC
Just downloaded the 1.1.1rc version. To my big enjoyment I see that this issue 
has been fixed! Does somebody else have tried it? If there are more positive 
reactions, then we can finally change this issue into FIXED!
Comment 23 guido.pinkernell 2004-03-05 14:58:24 UTC
Sorry, can't confirm a fix on Win98 with 1.1.1rc. I installed 1.1.1rc after I
had deinstalled 1.1.0, and during install I selected to replace the old
opensymbol font with the new that came with 1.1.1rc.

So the problem remains as described by korsi's comment from Sep 6 2003.
Comment 24 ptkho 2004-04-16 10:56:45 UTC
After my early enjoyment of a probable fix in 1.1.1rc I see the problem surfaced
again in the final 1.1.1. Still looking for a solution I found on the OOo-forum
(http://www.oooforum.org/forum) a simple but effective solution from one of the
guests who deals with the problem. I will quote the solution he gave on the 7th
April 2004
(http://www.oooforum.org/forum/viewtopic.php?t=5949&highlight=bullets) and hope
it will work for others too, as it has worked for me:

my understanding is that the when you press the bullet button on the toolbar,
the program tries to use the character U+2022 of the font "StarSymbol" as the
bullet. if you have never installed some older versions of StarOffice or
OpenOffice on your computer, you won't have "StarSymbol" and the program will
use another font. unfortunately, in that replacement font U+2022 isn't mapped to
the dot (or bullet) that you're looking for. that's why you get an empty box.

here's a simple workaround. go:
tools -- options -- OpenOffice.org -- fonts

create a new rule on the replacement table:
Font: StarSymbol (Comment from me: "this is not listed, so you have to type it,
do not use OpenSymbol, this won't work")
Replace with: Times New Roman (several other fonts will also work)

now, the empty boxes will be replaced by bullets.

someone suggested to replace the current version of the "opens___.ttf" font with
an earlier version, but that didn't work on my computer. 
Comment 25 lohmaier 2004-04-30 20:16:52 UTC
*** Issue 28364 has been marked as a duplicate of this issue. ***
Comment 26 mjharris13 2004-05-01 06:12:23 UTC
Is there a way we can get the StarSymbol font?  Can Sun make it available to 
Openoffice.org or is there a plan to change the font used to create the bullets?
Comment 27 jjr16 2004-05-01 23:16:43 UTC
Well, I am using Windows 98 SE. I have OpenOffice.org 1.1.2 RC installed. I used
to have StarOffice 6.1 beta 1 installed and so I still have the StarSymbol font
installed.  But I do not have this problem because:
When I open a new Text Document, and 
go to the Format menu 
then Numbering/Bullets... 
then click on the Options tab 
then next to Character click on the "..." button, 
I see that the StarSymbol font/typeface is selected as well as the standard
bullet character (Unicode character code 2022; can also be entered by typing
Alt+0149 in Windows).  So, hopefully ;), this should tell you that the
OpenSymbol font is not the main problem.

Now, as to freely obtaining the StarSymbol font, I am not sure but I think it is
doubtful that StarSymbol will be released without requiring a license because my
copy says that the "Digitized data copyright (C) 2001-2002 Agfa Monotype
Corporatio" and that if Sun could have released it as a part of the OOo
application, IMO, they would have.

So, until this is fixed in a release of the OOo application, the workaround
mentioned by ptkho will work the best (unless one feels like manually changing
the character every time a new bullet list is started).

As to fixing the problem, it seems like we will have to wait until OOo 2.0,
because someone believes that it depends on Issue 26679 (see top of page).  It
does not seem that difficult to fix though.  My guess would be to change OOo
from using StarSymbol for the bullet to using the default document font.  Also,
if there are problems with that I suppose OpenSymbol could be used but it would
have also have to map to the Unicode character code E01E when using OpenSymbol.

One last thing, could someone, who does not have the StarSymbol font, confirm
exactly what they see (which font, what character code, if any) when they lookup
what character is being used for the bullet (as described at beginning of my
comment).
Comment 28 mjharris13 2004-05-07 01:14:38 UTC
I do not have the StarSymbol font.  When I follow the steps that jjr16 
mentioned, I get a blank for font/typeface.  The character code is given as 
U+2022.  However, when I insert the bullet, all I get is the empty box.  Seven 
other characters display on the bullet tab.  When I go to Options-
>Character "..." the code given is U+F001 regardless of which character I have 
selected in the bullets tab.  Although the other characters display on the 
document screen, when I print the page all I get is the empty rectangle.  When 
I use the fix described by ptkho, I do get the correct bullet with the code 
U+2022.  On the bullet tab two different sized bullets are displayed.  The 
second has the code U+F001.  All six other options are squares, also with the 
code U+F001.
Does anyone know if the StarSymbol font was part of the StarOffice 5.2 free 
download from several years ago?  If it was, can it be used to solve the 
problem, and can it be made freely available? 
Comment 29 Martin Hollmichel 2004-05-28 14:54:26 UTC
according to the announcement on releases
(http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=7503) this issue
will be re-targeted to OOo Later.
Comment 30 Rainer Bielefeld 2004-06-10 07:11:02 UTC
Due to comments
<http://qa.openoffice.org/servlets/ReadMsg?list=dev&msgId=1288168>,
<http://qa.openoffice.org/servlets/ReadMsg?list=dev&msgId=1241840>,
<http://qa.openoffice.org/servlets/ReadMsg?list=dev&msgId=1253900> 
I rise priority to 3 and rechange Target Milestone to OOo 2.0, because it is
really important to fix these very visible bugs for 2.0! You will find this text
in all Issues where I rechanged TM due to a.m. reasons.  

Pls see that this bug makes OOo unusable for the still very popular OS WIN98. A
bugfix for this problem is a must for 2.0!

Rainer
Comment 31 Rainer Bielefeld 2004-06-10 07:21:01 UTC
Created attachment 15789 [details]
screenshot shows missing bullets and garbled "Insert Special Characters" - I believe you know all that :-/
Comment 32 hdu@apache.org 2004-11-05 13:01:00 UTC
The fix for issue 21466 in the CWS vcl29 will help for most of these issues with
the one exception that if StarSymbol only codepoints were used then OpenSymbol
alone will not suffice. I suggest to retest the many subissues mentioned above
when CWS vcl29 got integrated (maybe SRC680m63?) and to isolate the remaining
problems...
Comment 33 Rainer Bielefeld 2004-11-05 14:53:52 UTC
I will scheck with SRC680m63 (or later)

Rainer
Comment 34 stx123 2005-01-19 14:54:14 UTC
Hi Rainer, it would be great, if you could find some time to check the fix and 
close the issue if you agree with Herbert.
Thanks, Stefan
Comment 35 Rainer Bielefeld 2005-01-19 18:27:35 UTC
Just downloading OOo_1.9.m69_native_Win32Intel_install.zip, I will check until
weekend.

Rainer
Comment 36 Rainer Bielefeld 2005-01-23 15:28:47 UTC
I installed OOo_1.9.m69_native_Win32Intel_install.zip on a WIN98 (not SE)
laptop, and unfortunately I still see the "missing bullets problem". So I can
not close this issue.

Rainer
Comment 37 Martin Hollmichel 2005-02-14 14:20:41 UTC
don't forget the reassign back then.
Comment 38 hdu@apache.org 2005-02-24 18:16:56 UTC
hdu->rainerbielefeld: is the problem the same as in your old screenshot? How
many bytes exactly does your opens.ttf font have? If the problem only occurs in
the document (from your creenshort) could you provide a mini exctract of this
document with just a few letters including one symbol.
Comment 39 pavel 2005-07-29 12:08:27 UTC
rainerbielefeld: please provide sample document. Without it developers can't
work on this issue.

Can *anyone* provide sample document?
Comment 40 jjr16 2005-07-31 02:43:24 UTC
Created attachment 28363 [details]
New document with bullets
Comment 41 jjr16 2005-07-31 03:10:21 UTC
OK, the above file was created on the same machine that I used with my last
comment, but I'm now using OpenOffice.org 1.9.118.  I simply opened a New
Document and clicked the bullets button typed the text and hit Save.  I moved my
StarSymbol font out of my FONTS directory and rebooted.  Loaded OOo and the
bullets weren't displayed, just an placeholder rectangle like the others.  I
immediately copied the font back, switched back to OOo and it displayed as it
should.  Didn't change anything with OOo just the font!
The problem is OOo selecting or not selecting an alternative font/typeface.
Comment 42 khirano 2005-07-31 05:29:18 UTC
Bullets are displayed OK on Windows 98 SE.
Please take a look at screenshots I will attach.
Comment 43 khirano 2005-07-31 05:30:49 UTC
Created attachment 28364 [details]
With 1.1.5ja on Windows 98 SE
Comment 44 khirano 2005-07-31 05:32:15 UTC
Created attachment 28365 [details]
With 1.9.121ja on Windows 98 SE
Comment 45 khirano 2005-07-31 05:36:07 UTC
Bullets are not displayed but squares show on Windows Me.
Please take a look at screenshots I will attach.
Comment 46 khirano 2005-07-31 05:37:17 UTC
Created attachment 28366 [details]
With 1.1.5de on Windows Me
Comment 47 khirano 2005-07-31 05:38:34 UTC
Created attachment 28367 [details]
With 1.9.115ja on Windows Me
Comment 48 khirano 2005-07-31 05:41:02 UTC
Created attachment 28368 [details]
document I used for testing on Windows 98 SE and Me
Comment 49 khirano 2005-07-31 06:25:55 UTC
As you see my screenshots above, I have:
OPENS__.TTF 2004/12/13 on Windows 98 SE (old), and
OPENS__.TTF 2005/06/16 on Windows Me (new).

On Windows Me I replaced the new one with the old one.
Then I reboot the system and open the testing document with the 1.1.5 and the
1.9.115.
Doesn't work.
Still shows squares instead of Bullets.
Comment 50 khirano 2005-07-31 06:43:30 UTC
As you see my screenshots above, I have:
OPENS__.TTF 2004/12/13 on Windows 98 SE (old), and
OPENS__.TTF 2005/06/16 on Windows Me (new).

On Windows 98 SE I replaced the old one with the new one.
Then I reboot the system and open the testing document with the 1.1.5 and the
1.9.121.
Looks fine.
They show Bullets correctly.
Comment 51 pavel 2005-07-31 07:32:53 UTC
Created attachment 28369 [details]
I see bullets in m121...
Comment 52 pavel 2005-07-31 07:37:02 UTC
khirano: to sum up:

- you do not see bullets on ME
- you see bullets on 98 SE

... and it doesn't matter what file opens*ttf you have.

OK?
Comment 53 khirano 2005-07-31 07:44:07 UTC
pjanik:  sorry for my lengthy report.
I had to test and confirm them step by step ;)
This will be the last report.

Now on Windows Me I tried:
http://www.8ung.at/ooo.org/OpenSymbol.zip
OPENS___.TTF 101K 2003/03/31 6:00 (the oldest)  :)

On Windows Me I replaced the old one with the oldest one.
Then reboot the system and open the document with the 1.1.5 and the 1.9.115.
Fine, Bullets show correctly.

Comment 54 pavel 2005-07-31 08:04:00 UTC
Ah, OK. So can you sum it up?

It depends on the file opens___.ttf right? On Windows ME, the current version,
that is:

-r--r--r--  1 pavel users  55404 2005-06-12 15:36 opens___.ttf
MD5SUM: dd604fd024ebb8efc7872e2f5dd4b927

doesn't work and the old opens___.ttf:

-rw-r--r--  1 pavel users 103208 2003-05-07 01:01 opens___.ttf
MD5SUM: 6405139774b6a2b50121bc8a4e28603f

Works correctly, OK?

On other systems it works well even with the current file?
Comment 55 mdsimdsi 2005-07-31 09:52:11 UTC
I try to sum up :

* Win 98 :
- 2003-05-07 opens___.ttf is ok (mdsi, pinkernell, ...)
- 2004-12-13 opens___.ttf is ok (khirano, ...)
- 2005-06-12 opens___.ttf is NOT ok (mdsi, rainerbielefeld, pinkernell, ...)

* Win ME :
- 2003-05-07 opens___.ttf is ok (mdsi, pjanik, ...)
- 2004-12-13 opens___.ttf is NOT ok (khirano, ...)
- 2005-06-12 opens___.ttf is NOT ok (mdsi, rainerbielefeld, ...)

I try to sum up possible solutions :
- install and use 2003-05-07 opens___.ttf for Windows 98 and Me (that's what I
did manualy for 10 computers with OOo 1.1.x and 3 with OOo 1.9.98)
- automatic replacement of StarSymbol missing font by Times New Roman ? (ptkho)
- try to make openoffice use OpenSymbol and not StarSymbol for standard bullet
character ?
- install old StarSymbol fonts ?
- ...

Well, I'm not OpenOffice developper...
Comment 56 lohmaier 2005-07-31 11:44:21 UTC
@pjanik: again you were trying to reproduce a windows-only bug with linux...

reassigning back to hdu - the changes in vcl29 did not fix this issue.

Comment 57 pavel 2005-07-31 12:05:22 UTC
cloph: I was not trying to reproduce the bug. As you can see in my comments
about varioes Windows versions, it was only to add additional working system.

BTW: what was done to opens___.ttf font in the past?

I do have this on my system:

55404 ooo_SRC680_m121_src/extras/source/truetype/symbol/opens___.ttf
51220 ooo_SRX645_m57_src/extras/source/truetype/symbol/opens___.ttf

and also Novell's

118588 /usr/lib/ooo-2.0/share/fonts/truetype/opens___.ttf

Hmm.
Comment 58 khirano 2005-07-31 14:26:24 UTC
I said "Bullets are displayed OK on Windows 98 SE."
I have just found that this is because I have StarSymbol on my Win98SE system:
starsymb.ttf 511KB 2003/02/12 6:10
I uninstalled starsymb.ttf and opened the document, then squares show instead of
Bullets.

I have starsymb.ttf maybe because I have installed StarOffice8 Beta and
uninstalled it but StarOffice's fonts including starsymb.ttf remained in
/windows/fonts/.
Comment 59 jjr16 2005-08-01 03:12:52 UTC
*sigh*

I looked in the OOo_1.9.118_Win32Intel_install.zip file and the included .CAB
files and only found fonts in openofficeorg3.cab.  There was OpenSymbol font,
the Vera Sans fonts, and the Vera Serif fonts, that was it.  The file I attached
shows in the XML that the StarSymbol font was automatically being used for the
bullets.

Either way since the StarSymbol font is not included with OOo or Windows, I
don't think it should even be considered by OOo to be the default bullets font
anymore.  Especially because of the obvious font substitution problem here.

So, OOo should use a font for the bullets that either comes with OOo or that all
Windows users have.  We have four options that I can see:
* Use OpenSymbol as is and point to U+E01E
* Use a standard Windows font (Arial, Courier New, Times New Roman) with the
standard U+2022
* Use the standard (Windows) Symbol font and point to U+F0B7
* Change OpenSymbol to have U+2022 display a bullet

BTW, the font used for the bullet is not the same as the font used for the text
surrounding it.
Comment 60 lohmaier 2005-08-03 21:57:03 UTC
> BTW: what was done to opens___.ttf font in the past?

couple of display fixes ("=" was displayed as "-" on certain zoom factors, the
squareroot-symbol wasn't displayed at all, there were display problems with
brackets, ...)
Comment 61 Rainer Bielefeld 2005-08-04 06:36:11 UTC
What ever this might tell us:

On a WIN98 PC we had that bullets trouble with 1.1.4, we fixed it by usen an old
older Opensymbol Font.

After Installation of a parralel 2.0 (1.9.m104) German version WIN 98:
[680m104(Build8913)], that problem did _not_ appear.
Comment 62 bernhard 2005-08-08 00:08:59 UTC
Looking at a list of opensymbol issues I found Issue 45163, where "ih" attached
a *new* opensymbol font (V1.8, size 103.428 byte). 
http://www.openoffice.org/nonav/issues/showattachment.cgi/24155/opens___.ttf

With one of my latest snapshots (or OOo1.1.5rc1) I got V1.7 (size 51.220) that
didn't solve the problem.

Now I deleted my old opens___.ttf, rebooted and copied the new one in the fonts
directory - and it DOES WORK on my Win98SE! No more sqares, real bullets!

If you can reproduce the solution (hopefully on Win ME as well) and this font
could be included in one of the next snapshots this really long issue can
probably be closed (even if the IMHO underlying problem is not solved by now -
replacement of StarSymbol by OpenSymbol - see Issue 26319)

Regards
Bernhard
Comment 63 lohmaier 2005-08-08 00:34:15 UTC
But hdu wrote:
"Version 1.8 of the OpenSymbol font IH provided as attachment above works,
because this font just claims to support Latin-1 and Win32 happily accepts that.
On the other hand support for Latin-1 is non-existant in OpenSymbol, so there
may be some side-effects, e.g. not accessable symbols on a chinese Win98..."
Comment 64 hdu@apache.org 2005-08-18 12:13:43 UTC
This issue has become rather long and complex. Looking at the last comments it
seems that everybody is happy now with what we have in the recent development
releases for OOo2.0?

> BTW: what was done to opens___.ttf font in the past?
All the different versions of OpenSymbol and their history are available at
http://installation.openoffice.org/source/browse/installation/extras/source/truetype/symbol/opens___.ttf
The one for OOo 2.0 has the CVS revision 1.14. The font's version string is
"1.9" though.
Comment 65 hdu@apache.org 2005-08-24 11:05:15 UTC
Setting status back to fixed then.
Comment 66 hdu@apache.org 2005-08-24 11:07:33 UTC
Closing.
Comment 67 abonky 2005-10-26 05:29:42 UTC
Hello again,
I just installed OOo2.0 on Win98.
Installation was without any problems.
My first action with OOo2.0 was to open an new writer document and click on
bullet list.
And what did I get? Again these ugly squares.
I also have OOo1.1.4 installed.

Please re-open this bug again.
Comment 68 abonky 2005-11-19 13:39:53 UTC
Hi again,
since I got no reply to my last entry. I just want to ask for status....
Comment 69 Rainer Bielefeld 2006-03-17 11:49:38 UTC
Today I saw it again with a clean new installation of "2.0.2  German version WIN
98: [680m5(Build9011)]".

On that PC we had 1.1.4 and later 680m122. I uninstalled all old OOo versions,
installation (I had to du in "Safe mode" because of  Issue 47110) of 2.0.2 woked
fine, but with one thing strange: in the installation splash screen I also saw
lots of those rectangles (pls see attached "fontproblem.png"!).

The workaround with replacement of symbol font by an older one still works 

Comment 70 Rainer Bielefeld 2006-03-17 11:51:54 UTC
Created attachment 34955 [details]
Screenshot showeing strange rectangles in installation splash screen (no Idea whether that has to do with the problem what this issue is for)
Comment 71 Martin Hollmichel 2006-04-10 14:33:40 UTC
set target.
Comment 72 hdu@apache.org 2006-04-10 15:47:17 UTC
I changed the issues subject line to make the original problem of this issue
clearer (problem with the display of symbols from unicode fonts on Win98/WinME)

The other problems that were mentioned in recent comments were
abonky: please see issue 59997 for problems with "default numbering bullets not
in OpenSymbol"
rainerbielefeld: the screenshot looks like the "one click installer" has a
problem with an encoding. I opened issue 64219 for this. Please followup there.
Comment 73 hdu@apache.org 2006-04-10 15:48:16 UTC
Closing the fixed issue.
Comment 74 amesates 2010-11-10 16:54:10 UTC
Created attachment 73321