Issue 1940 - remove -net option (better and easier behaviour)
Summary: remove -net option (better and easier behaviour)
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: 638
Hardware: PC Linux, all
: P2 Trivial with 29 votes (vote)
Target Milestone: OOo 2.0
Assignee: dirk.voelzke
QA Contact: issues@installation
URL:
Keywords:
: 1307 5791 10250 (view as issue list)
Depends on: 3977
Blocks: 4490
  Show dependency treegraph
 
Reported: 2001-10-18 15:55 UTC by jur
Modified: 2004-05-06 11:22 UTC (History)
3 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jur 2001-10-18 15:55:00 UTC
StarOffice supports SingleUser and MultiUser environments. Currently the
SingleUser is default and the user has to use the "-net" option for enabling the
MultiUser mode before installing.

As several mails in the mailing lists show this is a very irritating behaviour.
Nearly no user finds the -net option himself (I don't any other program doing it
that way, so a user simply doesn't expect it) and gets surprised if SO doesn't
work , which hurts the first using experience badly.
When using the MultiUser install, every user has to start the setup program
themself, which also hurts the user experience badly, since one can not expect a
user to know that.

We must remove the -net option and the per user setup and replace both by a
better, easier to understand behaviour.

1. is it necessary to make a difference between the MultiUser and the SingleUser
install? A user expects that if he installs a software he and everyone else can
use it, so what is so special about the single user mode?

2. If a difference is needed:
We have a GUI installer. Why do we have to give it the -net option as a
parameter for the program? It should be possible to choose this function in the
GUI installer, together with a small description which explain it to the average
user.
It is possible to choose the install size (something like default, minimize,
custom). I think that the logical place for asking for the -net option is just
before that dialog.

3. currently each user has to manualy start the setup program before he can use
SO/OO the first time. If SO/OO can find the configuration files, it should be
able to find out, if the setup program was already executed before. If it was
not, then start the setup program. 

If point 3 should go into a new issue, then I would file it.
Comment 1 jur 2001-10-18 15:57:38 UTC
I forgot to mention that there are people suggesting to make -net the
default.
Comment 2 Olaf Felka 2001-10-19 08:52:33 UTC
Hi Falko,
it's your turn.
Comment 3 skiani 2001-10-19 21:25:41 UTC
This has been a big pain for me too, thanks for posting. I wanted to
add to/expand this thread. I would suggest the following changes:

A) Installer should be smart enough to tell if the user is
root/administrator or not. If not, should tell them that they are not
and suggest that the change users for install. (Optionally it could
pop up a dialog requesting root password)

B) If they choose to not install as root then the installer should
default the file location to user's home path as UNIX install does
today without -net.  (I should note root premission is not an issue
for MOST Windows/NT configurations, I call these unsecure systems).
User home path is $HOME on NT and %HOME for Linux (I don't know other
systems).

C) If installing as root (or on unsecure system) the installer should
again be smart and suggest the best location for the system (here are
some I know:
	$SystemDrive\Program Files for Windows NT
	/usr/share/	for Redhat and Mandrake Linux
	/opt/	for Solaris (I believe?)

D) Following on C. This install would be similar to today's -net
install.

E) In the Windows/KDE/CDE/Gnome start menus links should be made to
all the respective programs for all users on the system when installed
as root\unsecure and just the user's menus when just user install.

F) When a user first launches openoffice (i.e. user has no setting
yet) a dialog box pops up asking for user information (that's it no
paths nothing). The program automatically creates user and share
directories in proper locations (again the ones I know):
	Windows NT:	$USERPROFILE\openoffice
	Linux:		%HOME/.openoffice (note the dot path)

G) User's document directory should not be in the openoffice
directory!!!! The default document path should be system standard:
	Windows NT:	$HOME\
	Linux:		%HOME/

I think I got it all. But, what I have above is no different than most
other applications do on respective systems. OOo having different
standard is confusing, and is (IMHO) worst that convention.
Comment 4 skiani 2001-10-19 22:11:09 UTC
Minor correction to my last posting. Linux system vars are $HOME etc. 
And Window's are %HOME% etc.
Comment 5 falko.tesch 2001-10-22 10:10:07 UTC
This is basically (not in all respects though) double with 1307

*** This issue has been marked as a duplicate of 1307 ***
Comment 6 Unknown 2001-10-29 09:46:54 UTC
as discussed I reopen this
ok@sun.com
Comment 7 Unknown 2001-10-29 09:49:31 UTC
back to me...
Comment 8 stx123 2001-11-27 19:18:19 UTC
seems there is a serious need for that, Oliver...
Comment 9 Unknown 2002-01-21 14:15:37 UTC
first step is our proposal for new net installation behaviour. 
please visit our hp
Comment 10 jur 2002-01-21 14:40:00 UTC
btw, the full links is
http://installation.openoffice.org/proposals/netinstall.html
Comment 11 jur 2002-01-21 14:55:02 UTC
I like the proposal. 
I also saw that you cared about the problem of the current bad default
to install OO at /root when user root is doing the install. 
Comment 12 dirk.voelzke 2002-01-23 11:04:00 UTC
Looks like this one is for me now.
Comment 13 dirk.voelzke 2002-01-23 11:32:05 UTC
have a look at 
http://installation.openoffice.org/proposals/netinstall.html
Comment 14 jlapham 2002-04-24 15:32:00 UTC
Please, for the sake of the children, make "/net" the default!  Heck
this can be the world's largest "ease of use for smallest amount of
code" fix in the world. 

I understand why this issue has been kicking around for so long,
because the "right" way to fix this is to rewrite the installer so it
supports "/net" installs graphically.  But, with the release of OOo
v1.0 coming up soon, why not for now simply change the default
behavior to "/net" and work out the graphical solution for a later
version?

This is a simple "bash" wrapper script that will accomplish this. 
Actually, what it does is that you can pass "/net" or "/nonet" to
force a net or nonet install, or by default the "root" user does a
"/net" install and non-root users will do a non "/net" install.

#!/bin/sh

function install_multiuser {
	echo "Installing in multi-user mode"
	./setup /net
}

function install_singleuser {
	echo "Installing in single-user mode"
	./setup
}

echo "Installing OpenOffice.org as $USER"

if [ -z $1 ]; then
	# No CLAs
	if [ $USER = "root" ]; then
		install_multiuser
	else
		install_singleuser
	fi

else 
	# CLAs exist
	if [ $1 = "/net" ]; then
		install_multiuser
	else
		install_singleuser	
	fi
fi

exit
Comment 15 dirk.voelzke 2002-04-26 10:46:33 UTC
Please have a look at the discussion in the
dev@installation.openoffice.org mailing list titled:
[installation-dev] Re: Use of a unix shell wrapper for setup - Was
-net and font issues.
Comment 16 jur 2002-04-26 21:26:17 UTC
just adding dependency do issue 3977, where some of this issues are
done...
Comment 17 Unknown 2002-05-24 11:16:28 UTC
Is it possible (I should say, *will* it be possible) to do a system
wide install, and then have the users just run the program installed
system wide immediatly (without needing to run the user install)?  

This is how I wish OpenOffice was by default.  The only other program
I can think of that requires users to run an "install" again is GIMP,
but I've found that the ~/.gimp directory can just be placed in the
/etc/skel directory and then the users don't need to run the install.  

The reason I care so much about having it work in this manner is that
I think schools wanting to use OpenOffice don't wan't it to be
necessary that the students preform installations (this is mostly just
an issue for schools switching to Linux, with each student having a
/home directory).  

If the installation program must be run for each user, would it be
possible to create a command line version which could be run in a
script to install OpenOffice in all the users' /home directories?  
With perhaps a config file passed to the script which would give it
whatever information it would otherwise have to ask interactively
(State, Organization, etc.)  

Thanks. 
Comment 18 dirk.voelzke 2002-06-14 11:18:00 UTC
*** Issue 5791 has been marked as a duplicate of this issue. ***
Comment 19 castleinfo 2003-02-13 14:00:54 UTC
This issue is a pain in the back side, it took me a week to find /net
option via the mailing list, and its naff.
MS Office auto installs for a new user and this is OBVIOUSLY the way
to go.
As for network based install (which most small to medium companies
really don't trust these days.. due to server & network reliability)
does this really really have to have a workstation install as well ?
It would be pretty kewel if you could host the user settings on the
server (auto generated in advance of course) and the users just
clicked on a link to run the program ? (maybee not technicaly possible)

Comment 20 settantta 2003-07-21 14:26:24 UTC
As co-lead of the CD-ROM project, I've been looking for something like
this. I want to be able to fire up the installer using Windows autorun
feature, but...

It is necesary to run the correct type of install, based on the OS. I
envisage the following changes to the GUI:

The installer should ideally autodetect the OS. If WinXP or 2000, tehn
run the Multi-user install. Alternatively:
A radio button group, "Please select your version of Windows". 
Button 1 = Windows XP or 2000
Button 2 = Windows 98 or ME

If button 1 is selected, run Multi-user install
If Button 2, then another dialog with radio buttons "How many user
profies do you have?"

Button 1 = Only myself
Button 2 = Myself and at least one other.

If Button 1, then single user installl, else Multi-user install.

I could probably make the dialogs using Qt, but someone else would
have to write the code, as I know absolutely no C++ (A tiny bit of
Pascal, but no C).

If you would like to see one, let me know and I'll attach it (after I
create it) :)...

This would be IMO the ideal. The rest of the proposals seem ideal,
it's just this initial part that is stumping me ATM.
Comment 21 Peter Lairo 2003-09-04 13:00:19 UTC
> If Button 2 (win9x), then another dialog with radio buttons 
> "How many user profies do you have?" 
>   Button 1 = Only myself
>   Button 2 = Myself and at least one other.

This is still WAY too cumbersome. The installer should be able to
detect whether a win9x system has more than one user-profile. There is
no need to pester users with these questions.

PS. win9x use: +30%.

PPS. OOoo should reall upgrade to a newer version of BugZilla
(hovering over a bug 1234 should yield that bug's description).
Comment 22 dankegel 2003-09-04 20:03:48 UTC
*** Issue 10250 has been marked as a duplicate of this issue. ***
Comment 23 falko.tesch 2003-09-12 11:28:19 UTC
*** Issue 1307 has been marked as a duplicate of this issue. ***
Comment 24 falko.tesch 2003-09-12 11:28:20 UTC
*** Issue 1307 has been marked as a duplicate of this issue. ***
Comment 25 jur 2004-03-16 13:25:51 UTC
some days ago I downloaded a developer snapshot. during install one is asked, if
one wants to install OpenOffice for one or all users.

Resolving this as "WORKSFORME"?
Comment 26 thorsten.martens 2004-05-06 10:43:41 UTC
Issue has already been fixed for 2.0 -> fixed !
Comment 27 thorsten.martens 2004-05-06 10:44:25 UTC
TM: Closed !
Comment 28 Olaf Felka 2004-05-06 11:22:59 UTC
We have inntroduced this feature for OOo 680. As stated it's working, try OOo
680m36.