Issue 19453 - Directory lock until quickstarter closed
Summary: Directory lock until quickstarter closed
Status: CLOSED DUPLICATE of issue 21747
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC4
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: ivaroo
QA Contact: issues@sw
URL:
Keywords: oooqa
: 19613 23081 38428 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-09-11 15:49 UTC by ivaroo
Modified: 2005-01-22 12:02 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The error message i get with this issue (2.35 KB, image/png)
2003-09-23 06:25 UTC, ivaroo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ivaroo 2003-09-11 15:49:54 UTC
When i open a file in some directory, close the file again, delete the file and
then try to delete the whole directory i get an sharing violation on the last
action.

When i close the Quickstarter i can remove the directory.
Comment 1 jack.warchold 2003-09-11 17:55:56 UTC
hello ivarOO, sorry but i can not reproduce this here.
can you tell me the way you open the file? (doubleclick or over the 
file menu?)

reassigned to jw
Comment 2 ivaroo 2003-09-11 21:52:15 UTC
I opend the file by duble clicking it from the directory.

I now see it has to do with the quickstarter itself. 

This is 100% reproducable (on my system) :

exit Quickstart
create folder
copy file in folder
open file (any file will do, tried text and presentation)
close aplication
delete file
delete folder (error)
exit quickstart 
delete foler (no error)
ad infinitum
Comment 3 jack.warchold 2003-09-15 10:36:28 UTC
sorry but i can't reproduce this here. 
is the file on a networl share or on the local harddisk?
can you reproduce this on a other pc?
Comment 4 utomo99 2003-09-23 04:05:17 UTC
Hello Ivar, 

It is strange things. 
Are you sure that no other aplication including OOo which open one of
the file in that folder when you delete it ? 
and please try again to include the screenshoot or text of the error
message. 

thanks
Comment 5 ivaroo 2003-09-23 06:25:54 UTC
Created attachment 9584 [details]
The error message i get with this issue
Comment 6 utomo99 2003-09-24 11:47:04 UTC
please try to repair the installation. 

when you have that problem, look at the ctrl+alt+del, is there any
other Openoffice application running ? If yes please explain more 
Comment 7 thorsten.martens 2003-09-24 15:59:54 UTC
*** Issue 19613 has been marked as a duplicate of this issue. ***
Comment 8 thorsten.martens 2003-09-24 16:05:15 UTC
This problem only occurs when the systems file-open dialog is used and
the quickstarter is still running. When using the
staroffice/openoffice file-open dialog
(tools/options/staroffice/general -> checkbox "use staroffice
dialogs"), this problem doesn´t occur.

TM->TRA: please have a look, if there is a possibility to fix this
misbehaviour within the systems dialog.

TM->utomo: doing a repair is sometimes usefull, but in this case
simply useless ! 
Comment 9 ivaroo 2003-09-24 19:50:43 UTC
Thanks, saves me a repair. And thanks again for the workaround. 
The system dialogs you say...
<paranoia>MS is clinging to every straw to hinder us !</paranoia>
Comment 10 tino.rachui 2003-09-29 09:47:35 UTC
Hi *,

unfortunately yet another "System FileOpen" dialog issue. May only be
fixed in Redmond with reasonable effort, may only be fixed for OOo
with unjustifiable effort. So I reject this one - sorry.

Kind Regards,
Tino
Comment 11 ivaroo 2003-11-15 10:52:51 UTC
As it has to do with the 'startup-path' of OOO, When nothing is done
this wil be the directory that contains the original file. A simple
solution would be to change the default directory from wherever it is
at startup to the homedir of the binary files. This should be done
very early to make sure the offending windows functionality is not in
use yet.
Comment 12 jack.warchold 2003-12-04 18:09:51 UTC
*** Issue 23081 has been marked as a duplicate of this issue. ***
Comment 13 lohmaier 2004-12-07 21:22:15 UTC
*** Issue 38428 has been marked as a duplicate of this issue. ***
Comment 14 thackert 2005-01-16 14:18:41 UTC
I have seen that this issue is 1.1RC4 related and that the last entry was in
December. Does this problem also occur with newer versions of OOo like 1.1.3,
1.1.4 or some 1.9.xx builds? If not: Could someone close this issue, please?
Comment 15 ivaroo 2005-01-16 19:07:31 UTC
Just tested it in 1.1.3, it's still there. I have to stop Quickstarter before I
can remove the directory.
Comment 16 flibby05 2005-01-21 21:03:26 UTC
hi ivaroo, all,

does this problem maybe originate from the same root as issue 21747?
Comment 17 ivaroo 2005-01-22 08:54:10 UTC
21747 is a duplicate allright.
(http://www.openoffice.org/issues/show_bug.cgi?id=21747)
I put it in under 'blocks' because I can not mark the other one as dupe.
Comment 18 flibby05 2005-01-22 12:02:13 UTC
.

*** This issue has been marked as a duplicate of 21747 ***
Comment 19 flibby05 2005-01-22 12:02:41 UTC
closing as duplicate