Issue 1967 - Compatibility problem with MS Excel 97 (lines exceed, >32000 rows)
Summary: Compatibility problem with MS Excel 97 (lines exceed, >32000 rows)
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 632
Hardware: All All
: P3 Trivial with 13 votes (vote)
Target Milestone: ---
Assignee: peter.junge
QA Contact: issues@sc
URL:
Keywords:
: 2534 4253 5924 8874 9036 10978 11606 13506 16617 18203 20765 20856 22797 23615 26023 26763 29378 41376 43347 (view as issue list)
Depends on: 11190
Blocks: 28834
  Show dependency tree
 
Reported: 2001-10-20 18:34 UTC by csabka
Modified: 2013-08-07 15:15 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description csabka 2001-10-20 18:34:37 UTC
When I have tied to open an Excel 97 document, OpenOffice632 said that The 
document had been exceed the rows limit.
The Excel 97 works fine with 65535 lines but the OpenOffice632 and the 
StarOffice 6.0 beta can work just 32000 lines. Finally the Excel 2000 works 
fine more than 65535 lines. I hope it will work fine as well.
Comment 1 niklas.nebel 2001-11-05 16:22:09 UTC
Eike is currently looking into ways to remove the 32000 rows limit.
Comment 2 ooo 2001-11-05 20:12:46 UTC
see also http://sc.openoffice.org/row-limit.html
Comment 3 frank 2001-12-14 07:56:19 UTC
*** Issue 2534 has been marked as a duplicate of this issue. ***
Comment 4 oc 2002-04-26 08:34:28 UTC
*** Issue 4253 has been marked as a duplicate of this issue. ***
Comment 5 aschrage 2002-06-17 21:21:00 UTC
*** Issue 5924 has been marked as a duplicate of this issue. ***
Comment 6 daniel.rentz 2002-11-01 10:06:50 UTC
*** Issue 8874 has been marked as a duplicate of this issue. ***
Comment 7 daniel.rentz 2002-11-07 11:19:35 UTC
*** Issue 9036 has been marked as a duplicate of this issue. ***
Comment 8 ooo 2002-12-09 14:14:30 UTC
Target to OOo 2.0
Comment 9 frank 2003-01-27 12:05:14 UTC
*** Issue 10978 has been marked as a duplicate of this issue. ***
Comment 10 bobthehamster 2003-01-28 23:12:22 UTC
http://sc.openoffice.org/row-limit.html says that before work can
start on this issue, it is neccisary to "Wait for feature completeness
and new SO5 binary filter", saying that these things are "ongoing". I
have been trying to find the tracking issue for this new SO5 binary
filter, but can find nothing at all about it in issuezilla. Does
anyone know the Issue# of this work? Or is the work being done outside
issuezilla?
Comment 11 ooo 2003-02-04 16:00:09 UTC
@James: No, there is no issue# for the removal of the binary filters.
It started as a Sun inhouse project, work progresses on a branch
called SRX643_TF_BINFILTER throughout the entire office code. But now
that you mention it, probably it wouldn't be a bad idea to have an
issue for that, even if it's only to create a dependency between the
two tasks. I'll do that.
Comment 12 frank 2003-02-19 09:00:06 UTC
*** Issue 11606 has been marked as a duplicate of this issue. ***
Comment 13 ooo 2003-03-27 11:21:33 UTC
*** Issue 3491 has been marked as a duplicate of this issue. ***
Comment 14 ooo 2003-03-27 11:26:17 UTC
Changed summary to contain the wording "32000 rows" for easier retrieval.
Comment 15 frank 2003-04-16 14:39:02 UTC
*** Issue 13506 has been marked as a duplicate of this issue. ***
Comment 16 john.marmion 2003-07-09 18:41:06 UTC
*** Issue 16617 has been marked as a duplicate of this issue. ***
Comment 17 Unknown 2003-07-10 09:07:12 UTC
Regarding my Issue 16617, its not an exact duplicate since I also 
proposed to remove (or at least increase) the column limit.
Comment 18 daniel.rentz 2003-08-14 08:13:38 UTC
*** Issue 18203 has been marked as a duplicate of this issue. ***
Comment 19 frank 2003-10-06 13:39:40 UTC
*** Issue 20765 has been marked as a duplicate of this issue. ***
Comment 20 frank 2003-10-08 11:43:33 UTC
*** Issue 20856 has been marked as a duplicate of this issue. ***
Comment 21 jur 2003-10-08 14:01:32 UTC
any advances in fixing this?
Comment 22 ooo 2003-10-08 14:11:18 UTC
As it looks now, work on this will start in November.
Comment 23 ooo 2003-11-19 14:07:10 UTC
Development will take place on branch cws_src680_rowlimit. We will not
wait for completion of issue 11190 anymore, otherwise we might run
into trouble regarding the timeline of the OOo2.0 roadmap. Doing so
will put a whole bunch of extra work on it, both in developing on this
CWS as well as resyncing to a then (hopefully) binary filter stripped
HEAD in future, but there is no other choice.
Comment 24 frank 2003-11-24 14:17:25 UTC
*** Issue 22797 has been marked as a duplicate of this issue. ***
Comment 25 ooo 2003-11-28 20:01:44 UTC
http://sc.openoffice.org/row-limit.html#step1 completed.
Comment 26 daniel.rentz 2004-01-08 13:41:27 UTC
*** Issue 23615 has been marked as a duplicate of this issue. ***
Comment 28 ooo 2004-02-04 20:12:08 UTC
http://sc.openoffice.org/row-limit.html#step4 completed.
Waiting for availability of m24 (or m23s1) where CWS calcrtl will be integrated,
to resync and continue with step2.
Comment 29 ooo 2004-02-14 00:38:42 UTC
Status update: resynced to m24, newly adopted USHORT replaced with appropriate address types. Would have been nice if CWS calc18 was ready..
Comment 30 frank 2004-03-02 11:09:44 UTC
*** Issue 26023 has been marked as a duplicate of this issue. ***
Comment 31 flibby05 2004-03-20 15:23:38 UTC
*** Issue 26763 has been marked as a duplicate of this issue. ***
Comment 32 ooo 2004-03-25 22:49:26 UTC
http://sc.openoffice.org/row-limit.html#step5 completed.
Comment 33 ooo 2004-04-13 15:03:10 UTC
Skipped step7 for now (will do it later), started work on
http://sc.openoffice.org/row-limit.html#step8 and step9.
Comment 34 ooo 2004-05-06 19:16:46 UTC
Specification available at
http://specs.openoffice.org/calc/compatibility/number_of_rows.sxw

Finished step9 and resynced to HEAD as of m36s1.
cws_src680_rowlimit will be QA'ed and integrated at this stage, new CWS will be
created from the resulting milestone then, new tracking issue to be created.

Remaining:
http://sc.openoffice.org/row-limit.html#step7 and step9a.
Comment 35 ooo 2004-05-07 10:21:28 UTC
Reassign to QA.
Comment 36 john.marmion 2004-05-21 08:55:18 UTC
*** Issue 29378 has been marked as a duplicate of this issue. ***
Comment 37 peter.junge 2004-06-01 18:33:21 UTC
fixed now
Comment 38 peter.junge 2004-06-01 18:34:22 UTC
OK in CWS src680m36s1/rowlimit
Comment 39 peter.junge 2004-06-14 16:56:22 UTC
Found 65536 lines implemented in src680m42
Comment 40 frank 2005-01-26 16:09:35 UTC
*** Issue 41376 has been marked as a duplicate of this issue. ***
Comment 41 frank 2005-02-23 08:40:34 UTC
*** Issue 43347 has been marked as a duplicate of this issue. ***
Comment 42 snoopy_78 2005-12-08 18:05:51 UTC
Please reopen this bug, because I need more then only 65k rows. I'm working for
a translationtool and some languages has about 200k rows.

It isn't possible to decrease the columns and for this make more rows possible?
Comment 43 credmann 2005-12-09 00:07:09 UTC
More than 65k rows is not necessary. You need a database. Use Base.
Comment 44 jkonecn 2005-12-09 02:06:50 UTC
Although I agree with the statement about using a database... wasn't there an
initiative to provide unlimited rows as a next step after 65K?
Comment 45 credmann 2005-12-09 02:57:29 UTC
Any other spreadsheet program does more than 65k rows?
VisiCalc, maybe?
Comment 46 peter.junge 2005-12-09 09:10:44 UTC
@snoopy_78:
Hi,
this issue is fixed because the goal was to provide 65K rows. If you want more
rows please feel free to open a new issue. Enhancement to 2M rows is in
discussion for OOo 3 anyway. For the OOo 2.x branch it wouldn't make much sense
to break the row limit because we're too bad in performance. This is also planed
to be resolved for OOo 3.

Best regards
Peter
Comment 47 snoopy_78 2005-12-23 11:29:19 UTC
Thank you

My problem is, that I have to prepare documents to save them in mysql.
But I think, I write the routines to to it all in mysql ;-)